Bug 409344 - KMail crashes when closing a message opened twice or more
Summary: KMail crashes when closing a message opened twice or more
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail2
Classification: Applications
Component: composer (show other bugs)
Version: 5.9.3
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-30 22:04 UTC by SasQ
Modified: 2019-08-15 04:33 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description SasQ 2019-06-30 22:04:45 UTC
SUMMARY
The entire program crashes when I open the same message more than once (by double-clicking on in in the inbox).
I discovered this by accidentally opening more than one instance of the same message because my mouse is broken and sometimes it gets "autofire" :J

STEPS TO REPRODUCE
1. Double-click on a message in the inbox to open it.
2. Open the same message again in the same way.
3. Close one of those editor windows.

OBSERVED RESULT
The entire program crashes.
I can reproduce it every time.

EXPECTED RESULT
No crash, obviously :q

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Gentoo Linux 4.14.65-gentoo
KDE Plasma Version: kde-frameworks/plasma-5.54.0:5/5.54::gentoo
KDE Frameworks Version: No clue. Where can I find it?
Qt Version: dev-qt/qtcore-5.11.3-r2:5/5.11::gentoo

ADDITIONAL INFORMATION
Comment 1 Christoph Feck 2019-07-16 10:25:34 UTC
Please add the backtrace for the crash. For more information, please read https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
Comment 2 Bug Janitor Service 2019-07-31 04:33:10 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Bug Janitor Service 2019-08-15 04:33:10 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!