Bug 409341 - Unable to start stable version of akonadi server or file bug report (Fedora 30)
Summary: Unable to start stable version of akonadi server or file bug report (Fedora 30)
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: server (show other bugs)
Version: 5.11.2
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-30 20:59 UTC by Sid Hymes
Modified: 2019-08-14 01:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Crash information from bug reporter (52.78 KB, text/plain)
2019-06-30 20:59 UTC, Sid Hymes
Details
Missing, but not really, files (104.97 KB, image/png)
2019-06-30 21:00 UTC, Sid Hymes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sid Hymes 2019-06-30 20:59:24 UTC
Created attachment 121246 [details]
Crash information from bug reporter

SUMMARY
Kontact, etc., report Akonadi as not being operational. Attempts to start result in large error messages. Attempts to file bug report result in error message that required files are not present; presence confirmed in specified location. Crash information (attached) deemed "not useful". All problems occurred after recent Fedora update.

STEPS TO REPRODUCE
1. Start Kontact.
2. Kontact/KOrganizer opens with error message that akonadi not operational.
3. Manually starting akonadi results in repeated crash reports.
4. Use of system requires stopping akonadi.
5. See kdepim-users Digest, Vol 187, Issue 10 for additional details.

OBSERVED RESULT
Repeated crashes of akonadi and disabling of reliant apps.

EXPECTED RESULT
No crashes.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Fedora 30, most recent versions
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
Comment 1 Sid Hymes 2019-06-30 21:00:19 UTC
Created attachment 121247 [details]
Missing, but not really, files
Comment 2 Sid Hymes 2019-06-30 21:01:37 UTC
Response to starting Akonadi manually:
akonadictl start (06/30/19 11:40:21)
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
[sid@hallie ~]$ org.kde.pim.akonadiserver: Starting up the Akonadi Server...
org.kde.pim.akonadiserver: Failed to use database "akonadi"
org.kde.pim.akonadiserver: Database error: "Can't connect to local MySQL server through socket '/tmp/akonadi-sid.T04dCL/mysql.socket' (2) QMYSQL: Unable to connect"
org.kde.pim.akonadiserver: Failed to connect to database!
org.kde.pim.akonadiserver: Database error: "Can't connect to local MySQL server through socket '/tmp/akonadi-sid.T04dCL/mysql.socket' (2) QMYSQL: Unable to connect"
org.kde.pim.akonadiserver: Failed to remove runtime connection config file
org.kde.pim.akonadiserver: Shutting down AkonadiServer...
org.kde.pim.akonadicontrol: Application '/usr/bin/akonadiserver' exited normally…
Comment 3 Sid Hymes 2019-06-30 21:36:28 UTC
"Details" button is non-responsive so cannot generate self-test report and don't know of another way to generate the self-test results.
Comment 4 Christoph Feck 2019-07-16 09:16:52 UTC
The crash report lacks debug symbol information.

Please ask for help in a forum of your distribution how to provide these.

See also https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
Comment 5 Christophe Giboudeaux 2019-07-16 09:42:42 UTC
Is there a message from apparmor in the dmesg output?
Comment 6 Bug Janitor Service 2019-07-31 04:33:10 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 7 Sid Hymes 2019-07-31 19:45:15 UTC
All attempts to obtain necessary files thru Fedora were unsuccessful. I therefore removed the entire kde-pim suite and reinstalled which corrected the problem. I noticed a few days later that some of the offending files had been updated (by Fedora) and it is unknown whether this would have resolved the problem.

I have therefore marked the bug as resolved.