Bug 409290 - Kmail "Import/Export Kmail data" won't work. Window is blank.
Summary: Kmail "Import/Export Kmail data" won't work. Window is blank.
Status: RESOLVED DUPLICATE of bug 337856
Alias: None
Product: kmail2
Classification: Applications
Component: UI (show other bugs)
Version: 5.11.2
Platform: Neon Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-28 23:01 UTC by Unknown
Modified: 2019-06-30 23:07 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot (92.50 KB, image/png)
2019-06-28 23:01 UTC, Unknown
Details
Screenshot - full window (2.04 MB, image/png)
2019-06-30 17:27 UTC, Unknown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2019-06-28 23:01:50 UTC
Created attachment 121212 [details]
Screenshot

SUMMARY
When I attempt to export my Kmail data, the window titled "PIM Setting Exporter" is blank.

STEPS TO REPRODUCE
1. Open Kmail or Kontact
2. In the Kmail menu, go to Tools>Import/Export Kmail Data
3. Watch new open window and observe results

OBSERVED RESULT
PIM Settings Exporter window is blank.

EXPECTED RESULT
For PIM Settings Exporter window to have UI content to execute the Kmail data exporting features.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: KDE Neon 5.16.2
KDE Plasma Version: 5.16.2
KDE Frameworks Version: 5.59.0
Qt Version: 5.12.3

ADDITIONAL INFORMATION
See screenshot for observed result
Comment 1 Laurent Montel 2019-06-29 08:18:22 UTC
It's a bug from your distro.
Missing toolbar.
Comment 2 Unknown 2019-06-29 15:00:49 UTC
I thought KDE Neon was maintained by the KDE community? If it's not, where do I go to report this but?
Comment 3 Unknown 2019-06-29 15:01:08 UTC
Bug**
Comment 4 Christoph Feck 2019-06-30 09:08:30 UTC
Please first check if this is not an issue with a freshly created user account. By default, the exporter application should show a menubar.
Comment 5 Unknown 2019-06-30 17:27:37 UTC
Created attachment 121239 [details]
Screenshot - full window
Comment 6 Unknown 2019-06-30 17:50:56 UTC
I didn't realize this was significant until now, but I have the global menu bar widget in the panel at the top of my screen. In there I find menu items pertaining to PIM Exporter tool. For those that use the global menu widget, being greeted to a blank screen appears that the program isn't loading or that there are buttons one might expect that are missing.

I would encourage adding a few simple buttons on the main screen interface, the most obvious being "Import Kmail data" and "Export Kmail data", clicking either of those opening the appropriate import & export windows. I feel that would clear up any confusion users might have like me who have global menu enabled and don't see any buttons, icons or any elements in the window.
Comment 7 Christoph Feck 2019-06-30 23:07:16 UTC

*** This bug has been marked as a duplicate of bug 337856 ***