Bug 409131 - krita: moving 2 selected shapes (text and polygon) resets both shapes opacity to 0 if polygon had opacity less than 1
Summary: krita: moving 2 selected shapes (text and polygon) resets both shapes opacity...
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Layers/Vector (show other bugs)
Version: 4.2.1
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: vanyossi
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2019-06-24 13:01 UTC by unxed
Modified: 2019-07-17 09:13 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
sample_kra_file_for_reproducing (26.58 KB, application/x-krita)
2019-06-24 13:01 UTC, unxed
Details

Note You need to log in before you can comment on or make changes to this bug.
Description unxed 2019-06-24 13:01:33 UTC
Created attachment 121112 [details]
sample_kra_file_for_reproducing

SUMMARY


STEPS TO REPRODUCE
1. Open attached file
2. Select both shapes, text and polygon
3. try to move

OBSERVED RESULT
Shapes disappear (opacity reset to 0 for both)

EXPECTED RESULT
Shapes not disappear

SOFTWARE/OS VERSIONS
Kitra 4.2.1 on linux mint 19.1 x64 (flatpack install)

ADDITIONAL INFORMATION
n/a
Comment 1 Halla Rempt 2019-06-24 13:03:07 UTC
I can confirm that with this file, but not with another file I've just created. I wonder what's up there...
Comment 2 unxed 2019-06-24 13:09:58 UTC
Reproduced on a clean, just-created file.

Steps to reproduce:
1. Create new file, leave all properties default.
2. Add new text (leave default "loren ipsum", for example)
3. Add polyline to the same vector layer
4. Set polyline's opacity to 0.75
5. Select both polyline and text
6. Try to move
Comment 3 Halla Rempt 2019-06-24 13:21:16 UTC
Also curious, if I add a 3rd shape, it doesn't happen anymore. I'm not sure what's up with this file...
Comment 4 Halla Rempt 2019-06-24 13:22:26 UTC
Nope... Doesn't reproduce for me that way.
Comment 5 unxed 2019-06-24 13:34:14 UTC
Removed ~/.var/app/org.kde.krita/ completely to reset settings to defaults (flatpak stores settings there AFAIK).

Still reproducing. Is there anything else can I do to help with investigation on this?
Comment 6 Halla Rempt 2019-06-24 13:58:18 UTC
Not right now, I'm guessing that we'll have to inspect the actual svg in the kra files.
Comment 7 Ahab Greybeard 2019-06-24 19:14:34 UTC
@unxed: Can you try this with the 4.2.1 appimage from the krita download site?

The bug.kra file provided shows a green colour in the Tool Options docker when the shape is selected but indicates full opacity on the opacity slider.

If I try to recreate this image with a new file, I get opacity of about 0.75 showing on the opacity slider after save and re-open and selecting.

Also, copy/pasting the text from bug.kra to a new image (same size of course) and using the same font/size etc values, I get larger text.

Examining the original bug.kra file svg contents, the detailed syntax is different from anything I create and is also different if bug.kra is saved to a new filename. This is for both the shape and the text.

In the bug.kra file (as in one I create), the shape stroke is opacity=0 and width=0 (i.e. no stroke). If I manually edit bug.kra to have width=1, then the total transparency effect doesn't happen when you move both together.

There seems to be something unusual happening with the .svg representations and interpretation.
Comment 8 unxed 2019-06-28 17:57:55 UTC
It's currently 4.2.2 appimage on download page.

Not reproducing in 4.2.2 appimage on new clean file, but still reproducing on bug.kra.

4.2.2 from flatpack behaves just the same as 4.2.1 (reproducing both on clean file and on bug.kra).

So it seems to be flatpack-releated issue.

btw, window resize/maximize is not working in appimage.

Linux Mint 19.1 amd64.
Comment 9 unxed 2019-06-28 18:15:05 UTC
flatpack from https://flathub.org/apps/details/org.kde.krita
Comment 10 Ahab Greybeard 2019-06-28 21:25:33 UTC
You can get the 4.2.1 appimage here: https://download.kde.org/stable/krita/4.2.1/krita-4.2.1-x86_64.appimage if you want to try it.

I tried the flatpak (I have the flatpak infrastructure) but it needed a massive download and didn't work for me.

I have no problems with window resize/maximize using appimages on Debian 9 and Linux Mint 18.3 (x86_64)
Comment 11 vanyossi 2019-07-16 20:49:41 UTC
Git commit 9855b267f7ec418ff76d22017abc653c2b73d89c by Ivan Yossi.
Committed on 16/07/2019 at 20:41.
Pushed by ivany into branch 'master'.

Do not trigger value Change when selecting multiple shapes

M  +1    -1    libs/ui/widgets/KisSelectionPropertySlider.cpp

https://invent.kde.org/kde/krita/commit/9855b267f7ec418ff76d22017abc653c2b73d89c
Comment 12 Halla Rempt 2019-07-17 09:13:47 UTC
Git commit 637b13630ba8fa415ed0abbef2c13aad553e8c99 by Boudewijn Rempt, on behalf of Ivan Yossi.
Committed on 17/07/2019 at 09:13.
Pushed by rempt into branch 'krita/4.2'.

Do not trigger value Change when selecting multiple shapes

M  +1    -1    libs/ui/widgets/KisSelectionPropertySlider.cpp

https://invent.kde.org/kde/krita/commit/637b13630ba8fa415ed0abbef2c13aad553e8c99