Bug 409110 - Akonadi Server crash after some time of having Kontact running
Summary: Akonadi Server crash after some time of having Kontact running
Status: RESOLVED DUPLICATE of bug 408897
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: server (show other bugs)
Version: 5.11.2
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-24 08:18 UTC by Robby Engelmann
Modified: 2020-03-23 18:02 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
crash information from Drkonqi (97.75 KB, text/plain)
2019-06-24 08:18 UTC, Robby Engelmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robby Engelmann 2019-06-24 08:18:59 UTC
Created attachment 121108 [details]
crash information from Drkonqi

SUMMARY
Akonadi Server crash after some time of having Kontact running. I do not observe any special events going on, when it happens. Also akonadictl fschk / vacuum does not solve it (worked often in the past to solve such crashes for me).

STEPS TO REPRODUCE
1. Start Kontact
2. Have E-mail coming in from time to time
3. see the crash

OBSERVED RESULT
crash

EXPECTED RESULT
no crash

All crash information attached...
Comment 1 Christophe Giboudeaux 2019-06-25 07:54:31 UTC
Pasting inline 
Thread 7 (Thread 0x7fb1b8eeb700 (LWP 5950)):
[KCrash Handler]
#6  0x00007fb1bfb7b42e in std::__atomic_base<int>::load (__m=std::memory_order_relaxed, this=0x0) at /usr/include/c++/9/bits/atomic_base.h:413
#7  QAtomicOps<int>::load<int> (_q_value=...) at ../../include/QtCore/../../src/corelib/thread/qatomic_cxx11.h:227
#8  QBasicAtomicInteger<int>::load (this=0x0) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:103
#9  QtPrivate::RefCount::deref (this=0x0) at ../../include/QtCore/../../src/corelib/tools/qrefcount.h:66
#10 QString::operator= (this=this@entry=0x7fb13428f018, other=...) at tools/qstring.cpp:2413
#11 0x0000563227d5fd61 in Akonadi::Server::ItemRetrievalManager::retrievalJobFinished (this=0x5632288a5ea0, request=0x7fb13428f000, errorMsg=...) at /usr/src/debug/akonadi-server-19.04.2-188.1.x86_64/src/server/storage/itemretrievalmanager.cpp:224
#12 0x00007fb1bfce5b78 in QtPrivate::QSlotObjectBase::call (a=0x7fb1b8eea700, r=0x5632288a5ea0, this=0x7fb1a8006fc0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#13 QMetaObject::activate (sender=0x7fb1a8005240, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3776
#14 0x0000563227daab94 in Akonadi::Server::AbstractItemRetrievalJob::requestCompleted (this=this@entry=0x7fb1a8005240, _t1=<optimized out>, _t2=...) at /usr/src/debug/akonadi-server-19.04.2-188.1.x86_64/build/src/server/libakonadiserver_autogen/5XLNPBDXWK/moc_itemretrievaljob.cpp:135
#15 0x0000563227d61f23 in Akonadi::Server::ItemRetrievalJob::callFinished (this=0x7fb1a8005240, watcher=<optimized out>) at /usr/include/qt5/QtCore/qchar.h:88
#16 0x00007fb1bfce5b78 in QtPrivate::QSlotObjectBase::call (a=0x7fb1b8eea8c0, r=0x7fb1a8005240, this=0x7fb1a8005030) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#17 QMetaObject::activate (sender=0x7fb1b4026a70, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3776
#18 0x00007fb1c0034d7f in QDBusPendingCallWatcher::finished(QDBusPendingCallWatcher*) () from /usr/lib64/libQt5DBus.so.5
#19 0x00007fb1c0034e80 in ?? () from /usr/lib64/libQt5DBus.so.5
#20 0x00007fb1bfce643a in QObject::event (this=0x7fb1b4026a70, e=<optimized out>) at kernel/qobject.cpp:1260
#21 0x00007fb1bfcbae6f in doNotify (event=0x7fb134119940, receiver=0x7fb1b4026a70) at ../../include/QtCore/../../src/corelib/kernel/qobject.h:142
#22 QCoreApplication::notify (event=0x7fb134119940, receiver=0x7fb1b4026a70, this=<optimized out>) at kernel/qcoreapplication.cpp:1136
#23 QCoreApplication::notifyInternal2 (receiver=0x7fb1b4026a70, event=0x7fb134119940) at kernel/qcoreapplication.cpp:1060
#24 0x00007fb1bfcbda88 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x5632288b2f20) at kernel/qcoreapplication.cpp:1799
Comment 2 Daniel Vrátil 2020-03-23 18:02:31 UTC

*** This bug has been marked as a duplicate of bug 408897 ***