Bug 408949 - Black border around windows with blur enabled
Summary: Black border around windows with blur enabled
Status: RESOLVED DUPLICATE of bug 408594
Alias: None
Product: kwin
Classification: Plasma
Component: aurorae (show other bugs)
Version: 5.16.1
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-20 12:07 UTC by Kailash
Modified: 2019-06-20 12:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
This black border occurs on all 4 corners. (66.80 KB, image/png)
2019-06-20 12:07 UTC, Kailash
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kailash 2019-06-20 12:07:11 UTC
Created attachment 121031 [details]
This black border occurs on all 4 corners.

SUMMARY

There is an ugly black border around the rounded edges when blur is enabled with any theme that isn't Breeze (Tested with Materia KDE and Arc KDE). Disabling blur makes this bug go away. Have seen other reports of this bug so its legit. This bug didn't exist on Plasma prior to version 5.16. Also, this border occurs on GTK applications as well. I read somewhere that this was as a result of blur being rendered for window shadows but I'm not sure.

STEPS TO REPRODUCE
1. Enable blur 

OBSERVED RESULT
Black border at rounded corners

EXPECTED RESULT
Rounded corners

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
Comment 2 Vlad Zahorodnii 2019-06-20 12:25:53 UTC
This is a duplicate of two bugs: bug 408594 and bug 395725.

*** This bug has been marked as a duplicate of bug 408594 ***