Bug 408915 - Blur effect: too much darkness with dark translucent backgrounds
Summary: Blur effect: too much darkness with dark translucent backgrounds
Status: RESOLVED DUPLICATE of bug 408594
Alias: None
Product: kwin
Classification: Plasma
Component: effects-various (show other bugs)
Version: 5.16.0
Platform: Manjaro Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-19 16:19 UTC by Tsu Jan
Modified: 2019-06-19 16:38 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Comparison with older KWin (1.42 MB, image/png)
2019-06-19 16:19 UTC, Tsu Jan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tsu Jan 2019-06-19 16:19:37 UTC
Created attachment 121001 [details]
Comparison with older KWin

The new KWin blur effect (dual blur algorithm?) is much better than the older one but, after upgrading to KWin 5.16, something has changed, so that dark translucent backgrounds look too dark with blurring.

I've attached a screenshot for comparison: the darkness of a black terminal with an opacity of 60% (40% translucent) seems quite unnatural against the wallpaper, whether it's compared to older KWin versions or to Compiz.

There's no difference in darkness when the same terminal is put against a completely white background.

There's also another issue, which I should have reported sooner: The new blur effect is too strong, so that even a value of 4 in the blur settings dialog is more than enough in most cases, while the slider supports greater values. Perhaps the blur settings needed to be updated after the new blur effect was implemented.

I have Intel graphics and use KWin with X11.


SOFTWARE/OS VERSIONS
Linux/KDE Plasma
(available in About System)
KDE Plasma Version: 5.16.0
Qt Version: 5.12.3
Comment 1 Vlad Zahorodnii 2019-06-19 16:38:50 UTC

*** This bug has been marked as a duplicate of bug 408594 ***