Bug 408736 - Message Window no longer shows URL of link.
Summary: Message Window no longer shows URL of link.
Status: RESOLVED NOT A BUG
Alias: None
Product: kontact
Classification: Applications
Component: mail (show other bugs)
Version: 5.7.3
Platform: Neon Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-15 12:56 UTC by lnxusr
Modified: 2019-06-15 20:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Kontact Mail Window (203.83 KB, image/png)
2019-06-15 17:34 UTC, lnxusr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lnxusr 2019-06-15 12:56:08 UTC
SUMMARY

The URL of a link in an email is no longer displayed in the status bar of either the message window nor main Kontact window.  They used to display when the cursor was hovered over the link, now, as of a couple of months of updates, the no longer are.


STEPS TO REPRODUCE
1. Open email containing links.
2. Hover over link


OBSERVED RESULT

No URL displayed in the Status Bar

EXPECTED RESULT

URL displayed in Status Bar
SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION

This should be considered a security issue.  In order to view the link now, one must copy it to the clipboard, open a text editor like Kate or KWrite, then paste it in the document.  This is a ridiculous amount of work to view what was once right on the screen, and can result in many people just clicking on the link.
Comment 1 Laurent Montel 2019-06-15 14:27:37 UTC
5.7.3 is very old.
I can't reproduce in last version 5.11.x
Comment 2 lnxusr 2019-06-15 14:50:59 UTC
I didn't notice the version number when I reported this, but I used the 'Submit Bug Report' in the help menu.  Both About Kontact and the Submit Bug Report dialogs show my version as 5.10.1, which doesn't show in the version drop down.

Updated Info:  This only happens when viewing the message in a separate window.  When viewed in the preview pane, the URL shows up in the status bar.  Sorry, don't use the preview pane so normally have it turned off.  I didn't think to check it.
Comment 3 Laurent Montel 2019-06-15 17:00:27 UTC
Do you have a statusbar ?
I retested it and I can't see pb
could you paste a screenshot here ?

Do you have an info when you move mouse under a email address ?
Comment 4 lnxusr 2019-06-15 17:34:22 UTC
Created attachment 120893 [details]
Kontact Mail Window

There is no status bar on the email window.  Is this perhaps the problem?  Is there a new setting somewhere that defaulted to there not being a status bar in the email window?

Here's a screenshot of the window over the Kontact window, you can see the status bar of the main Kontact window just under the email window.
Comment 5 Laurent Montel 2019-06-15 18:56:57 UTC
(In reply to lnxusr from comment #4)
> Created attachment 120893 [details]
> Kontact Mail Window
> 
> There is no status bar on the email window.  Is this perhaps the problem? 
> Is there a new setting somewhere that defaulted to there not being a status
> bar in the email window?
> 
> Here's a screenshot of the window over the Kontact window, you can see the
> status bar of the main Kontact window just under the email window.

Yep it's the problem.
I don't implemented "hide/show statusbar" perhaps an old settings
Try to look at in ~/.config/kmail2rc or kontactrc

"ShowStatusBar=false"

Perhaps it's the problem.
Comment 6 lnxusr 2019-06-15 20:04:45 UTC
(In reply to Laurent Montel from comment #5)
> (In reply to lnxusr from comment #4)
> > Created attachment 120893 [details]
> > Kontact Mail Window
> > 
> > There is no status bar on the email window.  Is this perhaps the problem? 
> > Is there a new setting somewhere that defaulted to there not being a status
> > bar in the email window?
> > 
> > Here's a screenshot of the window over the Kontact window, you can see the
> > status bar of the main Kontact window just under the email window.
> 
> Yep it's the problem.
> I don't implemented "hide/show statusbar" perhaps an old settings
> Try to look at in ~/.config/kmail2rc or kontactrc
> 
> "ShowStatusBar=false"
> 
> Perhaps it's the problem.

That fixed it.  kmail2rc has a [Separate Reader Window] section with StatusBar.  It was set to Disabled so I changed it to Enabled and now have the URL back in the window.

Thank you Laurent, much appreciated.