Bug 408700 - plasma-pa kcm does not show which output an app is using
Summary: plasma-pa kcm does not show which output an app is using
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_pulseaudio (show other bugs)
Version: 5.18.1
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: David Rosca
URL:
Keywords:
: 427770 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-06-14 17:14 UTC by Patrick Silva
Modified: 2020-10-16 13:10 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.20.1


Attachments
screenshot (77.64 KB, image/png)
2019-06-14 17:14 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2019-06-14 17:14:36 UTC
Created attachment 120871 [details]
screenshot

STEPS TO REPRODUCE
1. start to play an audio or video (I tested with vlc and smplayer players)
2. while the audio/video is played, right click on the sound icon in systray,
select "Configure audio volume...'
3. click "Audio volume" section, click "Applications" tab

OBSERVED RESULT
As we can see in the attached screenshot, the dropdown that normally show the output used by your player is empty. If you start to play another file while the plasma-pa kcm is open, the dropdown shows the output used by the player, as expected.

EXPECTED RESULT
plasma-pa kcm always shows which output an app is using

SOFTWARE/OS VERSIONS
Operating System: Arch Linux 
KDE Plasma Version: 5.16.0
KDE Frameworks Version: 5.59.0
Qt Version: 5.12.3
Comment 1 gvgeo 2020-02-25 13:34:22 UTC
Confirm, see an empty box.
Comment 2 Patrick Silva 2020-05-16 17:34:27 UTC
humm, I can't reproduce on Plasma 5.19 beta.

Operating System: Arch Linux 
KDE Plasma Version: 5.18.90
KDE Frameworks Version: 5.70.0
Qt Version: 5.15.0 rc2
Comment 3 Patrick Silva 2020-10-14 15:45:58 UTC
it's happening again.

STEPS TO REPRODUCE
1. start to play an audio or video (I tested with vlc player)
2. while the audio/video is played, right click on the sound icon in systray and
choose "Configure audio volume..."
3. click on "Audio" section, click on "Applications" tab

Operating System: Arch Linux
KDE Plasma Version: 5.20.0
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1
Comment 4 Patrick Silva 2020-10-15 20:06:31 UTC
*** Bug 427770 has been marked as a duplicate of this bug. ***
Comment 5 Bug Janitor Service 2020-10-16 08:29:24 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-pa/-/merge_requests/17
Comment 6 David Redondo 2020-10-16 13:09:40 UTC
Git commit 9eb8d3d688242d3154c88fa86b6b824442e04d1c by David Redondo.
Committed on 16/10/2020 at 08:28.
Pushed by davidre into branch 'master'.

Simplify DeviceComboBox

The combobox can be simplified massively which means also fewer chances for
bugs to occur. The check that the index was not 0 was the cause for the combobox
being broken.
FIXED-IN:5.20.1

M  +5    -37   src/kcm/package/contents/ui/DeviceComboBox.qml

https://invent.kde.org/plasma/plasma-pa/commit/9eb8d3d688242d3154c88fa86b6b824442e04d1c
Comment 7 David Redondo 2020-10-16 13:10:47 UTC
Git commit 347f598ec75c0f4605f54a0eb104f37b110bdf00 by David Redondo.
Committed on 16/10/2020 at 13:10.
Pushed by davidre into branch 'Plasma/5.20'.

Simplify DeviceComboBox

The combobox can be simplified massively which means also fewer chances for
bugs to occur. The check that the index was not 0 was the cause for the combobox
being broken.
FIXED-IN:5.20.1


(cherry picked from commit 9eb8d3d688242d3154c88fa86b6b824442e04d1c)

M  +5    -37   src/kcm/package/contents/ui/DeviceComboBox.qml

https://invent.kde.org/plasma/plasma-pa/commit/347f598ec75c0f4605f54a0eb104f37b110bdf00