Bug 408551 - Simple drawing/annotation tools
Summary: Simple drawing/annotation tools
Status: RESOLVED FIXED
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: HI wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: usability
: 431384 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-06-10 20:58 UTC by Nate Graham
Modified: 2022-07-07 21:37 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 22.08


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2019-06-10 20:58:17 UTC
This should come from https://cgit.kde.org/libkimageannotator.git or whatever backend that Kolourpaint uses (if it's in a library).
Comment 1 2wxsy58236r3 2021-01-10 11:14:24 UTC
*** Bug 431384 has been marked as a duplicate of this bug. ***
Comment 2 Nate Graham 2022-06-30 14:35:22 UTC
In progress with https://invent.kde.org/graphics/gwenview/-/merge_requests/147!
Comment 3 Nate Graham 2022-07-07 21:37:38 UTC
Git commit 8f3bf87bcda2f678a15a48a5cefdca912d80dff8 by Nate Graham, on behalf of Ilya Pominov.
Committed on 07/07/2022 at 21:37.
Pushed by ngraham into branch 'master'.

Add simple image editor using KImageAnnotator

This makes KImageAnnotator a new required dependency.
FIXED-IN: 22.08

M  +9    -0    CMakeLists.txt
M  +2    -0    app/CMakeLists.txt
M  +2    -1    app/gwenviewui.rc
M  +22   -3    app/imageopscontextmanageritem.cpp
M  +8    -0    app/main.cpp
M  +1    -0    config-gwenview.h.cmake
M  +4    -0    lib/CMakeLists.txt
A  +61   -0    lib/annotate/annotatedialog.cpp     [License: GPL]
A  +51   -0    lib/annotate/annotatedialog.h     [License: GPL]
A  +82   -0    lib/annotate/annotateoperation.cpp     [License: GPL]
A  +47   -0    lib/annotate/annotateoperation.h     [License: GPL]

https://invent.kde.org/graphics/gwenview/commit/8f3bf87bcda2f678a15a48a5cefdca912d80dff8