Bug 408378 - System Monitor crashed when closing during GNU Octave hang
Summary: System Monitor crashed when closing during GNU Octave hang
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.12.8
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-06-06 10:38 UTC by Peter
Modified: 2019-06-25 14:36 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter 2019-06-06 10:38:45 UTC
Application: ksysguard (5.12.8)

Qt Version: 5.12.0
Frameworks Version: 5.58.0
Operating System: Linux 4.15.0-51-generic x86_64
Distribution: KDE neon Plasma LTS Edition 5.12

-- Information about the crash:
GNU Octave hung when I edited a file which was stopped at a debug breakpoint.  I then closed System Monitor (which had been running since before I started GNU Octave) which crashed rather than closing normally.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7efda4e7ce00 (LWP 9105))]

Thread 5 (Thread 0x7efd7514e700 (LWP 9110)):
#0  0x00007efd988509f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x556dbcc276e8) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  0x00007efd988509f3 in __pthread_cond_wait_common (abstime=0x0, mutex=0x556dbcc27698, cond=0x556dbcc276c0) at pthread_cond_wait.c:502
#2  0x00007efd988509f3 in __pthread_cond_wait (cond=0x556dbcc276c0, mutex=0x556dbcc27698) at pthread_cond_wait.c:655
#3  0x00007efd7662edcb in  () at /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007efd7662eaf7 in  () at /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007efd9884a6db in start_thread (arg=0x7efd7514e700) at pthread_create.c:463
#6  0x00007efda475688f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7efd82ff9700 (LWP 9108)):
#0  0x00007efda47450b4 in __GI___libc_read (fd=7, buf=0x7efd82ff8a20, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:27
#1  0x00007efd9690f2d0 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007efd968ca0b7 in g_main_context_check () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007efd968ca570 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007efd968ca6dc in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007efd9fe9315b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007efd9fe3464a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007efd9fc5c41a in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007efda059b015 in  () at /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#9  0x00007efd9fc5dbc2 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007efd9884a6db in start_thread (arg=0x7efd82ff9700) at pthread_create.c:463
#11 0x00007efda475688f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7efd89a66700 (LWP 9107)):
#0  0x00007efda4749bf9 in __GI___poll (fds=0x7efd89a65b78, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007efd992bb747 in  () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007efd992bd36a in xcb_wait_for_event () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007efd8adda32a in  () at /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007efd9fc5dbc2 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007efd9884a6db in start_thread (arg=0x7efd89a66700) at pthread_create.c:463
#6  0x00007efda475688f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7efd8c0b1700 (LWP 9106)):
#0  0x00007efd988509f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x7efd9ee29130) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  0x00007efd988509f3 in __pthread_cond_wait_common (abstime=0x0, mutex=0x556dbca50580, cond=0x7efd9ee29108) at pthread_cond_wait.c:502
#2  0x00007efd988509f3 in __pthread_cond_wait (cond=0x7efd9ee29108, mutex=0x556dbca50580) at pthread_cond_wait.c:655
#3  0x00007efd9f8e486c in std::condition_variable::wait(std::unique_lock<std::mutex>&) () at /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#4  0x00007efd9e16aae7 in  () at /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#5  0x00007efd9e16ac29 in  () at /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#6  0x00007efd9f8ea66f in  () at /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#7  0x00007efd9884a6db in start_thread (arg=0x7efd8c0b1700) at pthread_create.c:463
#8  0x00007efda475688f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7efda4e7ce00 (LWP 9105)):
[KCrash Handler]
#6  0x00007efd9fce668a in operator==(QString const&, QString const&) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007efda1283787 in QLabel::setText(QString const&) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#8  0x00007efda4a995f5 in  () at /usr/lib/x86_64-linux-gnu/libkdeinit5_ksysguard.so
#9  0x00007efda3ae8ca2 in KSGRD::SensorAgent::processAnswer(char const*, int) () at /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#10 0x00007efda3aefdf4 in  () at /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#11 0x00007efd9fe65f3f in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007efd9fdc0ffa in QProcess::readyReadStandardOutput(QProcess::QPrivateSignal) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#13 0x00007efd9fdc7a11 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007efd9fdc7ee0 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#15 0x00007efd9fe65e25 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#16 0x00007efd9fe72678 in QSocketNotifier::activated(int, QSocketNotifier::QPrivateSignal) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#17 0x00007efd9fe72a32 in QSocketNotifier::event(QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#18 0x00007efda11558ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#19 0x00007efda115ce40 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#20 0x00007efd9fe36328 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#21 0x00007efd9fe93da8 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#22 0x00007efd968ca417 in g_main_context_dispatch () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007efd968ca650 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007efd968ca6dc in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007efd9fe9313f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#26 0x00007efd9fe3464a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#27 0x00007efd9fe3d800 in QCoreApplication::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#28 0x00007efda4a9b27b in kdemain () at /usr/lib/x86_64-linux-gnu/libkdeinit5_ksysguard.so
#29 0x00007efda4656b97 in __libc_start_main (main=0x556dba95a720, argc=1, argv=0x7fff9bdcffe8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff9bdcffd8) at ../csu/libc-start.c:310
#30 0x0000556dba95a75a in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2019-06-25 14:36:04 UTC

*** This bug has been marked as a duplicate of bug 350140 ***