Bug 408273 - Scaling mode "Print original size" is confusing
Summary: Scaling mode "Print original size" is confusing
Status: RESOLVED DUPLICATE of bug 330820
Alias: None
Product: okular
Classification: Applications
Component: printing (show other bugs)
Version: 1.7.1
Platform: Arch Linux Linux
: NOR normal
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-04 02:30 UTC by Matthew Trescott
Modified: 2019-06-14 17:02 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Sample PDF for testing (9.03 KB, application/pdf)
2019-06-04 02:30 UTC, Matthew Trescott
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Trescott 2019-06-04 02:30:47 UTC
Created attachment 120544 [details]
Sample PDF for testing

Split from https://bugs.kde.org/show_bug.cgi?id=406237

SUMMARY
When selecting "Print original size" as the scaling setting, the document is shifted down and left, rather than being cropped.

STEPS TO REPRODUCE
1. Open any PDF (such as the one attached)
2. Open the Print menu, choose a paper size smaller than the one of the original document, and select "Print original size" as the scaling mode.
3. Click "Print."

OBSERVED RESULT
The document's contents are shifted down and left to fit the printer's margins.

EXPECTED RESULT
The document's contents are overlayed with a blank margin prior to being sent tot the print driver.

SOFTWARE/OS VERSIONS
KDE Frameworks Version: 5.58.0
Qt Version: 5.12.3

ADDITIONAL INFORMATION
The current system for this kind of printing may even have problems for RTL languages (I do not know since I have not tested this). I think a simpler, more elegant solution would be to replace this scaling mode with one called "Crop to fit printable area." This new scaling mode would add blank margins to the PDF before sending it to the print driver, rather than allowing the printer to figure out that it can't print part of the document. I'm not sure how useful that would be in practice compared to the "Fit to full page" scale mode.
Comment 1 Laura David Hurka 2019-06-04 17:33:29 UTC
See also the discussion about these new scaling options. (Pointing to one comment explaining the issue.)

https://phabricator.kde.org/D7962#339567
Comment 2 Nate Graham 2019-06-14 17:02:54 UTC

*** This bug has been marked as a duplicate of bug 330820 ***