Bug 408112 - Many apps' licenses are badly parsed or not shown
Summary: Many apps' licenses are badly parsed or not shown
Status: VERIFIED FIXED
Alias: None
Product: Discover
Classification: Unclassified
Component: discover (show other bugs)
Version: unspecified
Platform: Neon Packages Linux
: HI normal
Target Milestone: ---
Assignee: Dan Leinir Turthra Jensen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-30 12:27 UTC by Patrick Silva
Modified: 2019-10-07 16:42 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.17.0


Attachments
screenshot (174.43 KB, image/jpeg)
2019-05-30 12:27 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2019-05-30 12:27:47 UTC
Created attachment 120396 [details]
screenshot

STEPS TO REPRODUCE
1. search for kmag and open its description page
2. 
3. 

OBSERVED RESULT
Scroll bar overlaps text in the description page

EXPECTED RESULT
Scroll bar does not overlap text in the description page

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.16.80
KDE Frameworks Version: 5.59.0
Qt Version: 5.12.0
Comment 1 Nate Graham 2019-06-05 14:14:19 UTC
This appears to be caused by a malformed or badly-parsed license tag. However it looks like Discover is having some problems parsing licenses in general as several other apps I've tried show have an empty license tag but the "License:" label is still there.
Comment 2 Aleix Pol 2019-10-07 16:34:48 UTC
Git commit 997762e3e31f44ca44a1e393cbba1d968861fca5 by Aleix Pol.
Committed on 07/10/2019 at 16:34.
Pushed by apol into branch 'Plasma/5.17'.

Use the right API for retrieving SPDX licences

M  +5    -0    libdiscover/CMakeLists.txt
M  +4    -1    libdiscover/appstream/AppStreamUtils.cpp

https://commits.kde.org/discover/997762e3e31f44ca44a1e393cbba1d968861fca5