Bug 408105 - Ext4 partition created on usb medium is always read only
Summary: Ext4 partition created on usb medium is always read only
Status: RESOLVED DUPLICATE of bug 407192
Alias: None
Product: partitionmanager
Classification: Unclassified
Component: general (show other bugs)
Version: 4.0.0
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Andrius Štikonas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-30 11:31 UTC by PK
Modified: 2019-05-30 12:09 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description PK 2019-05-30 11:31:31 UTC
SUMMARY
Every time I format a usb drive to ext4 using kde partition manager this partition ends up being read only. When I create a fat32 partition I can write on it as well. 
I experienced this bug in previous versions of partition manager but I waited for the version 4.0 before filing this bug. I now do so because the behaviour of kde partition manager has not changed for the good.

STEPS TO REPRODUCE
1. insert usb medium in computer and start kde partition manager
2. create ext4 partition on it
3. partition will be read only

OBSERVED RESULT
partition is read only

EXPECTED RESULT
partition is read/write (as it is when I use gnome disks)

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 

(available in About System)
KDE Plasma Version: 5.15.5
KDE Frameworks Version: 5.58.0
Qt Version: 5.12.0

ADDITIONAL INFORMATION
now using kde partition manager 4.0.0 but previous versions behave the same
Comment 1 Andrius Štikonas 2019-05-30 12:09:04 UTC

*** This bug has been marked as a duplicate of bug 407192 ***