Bug 408042 - Calendar cannot be fetched from server because the login credentials string is too long
Summary: Calendar cannot be fetched from server because the login credentials string i...
Status: RESOLVED DUPLICATE of bug 394839
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: server (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-28 19:33 UTC by Daniel
Modified: 2019-06-01 14:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Text file with error message (2.74 KB, text/plain)
2019-05-28 19:33 UTC, Daniel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2019-05-28 19:33:04 UTC
Created attachment 120361 [details]
Text file with error message

The calendar entries cannot be fetched from server because the login credentials string is too long. I can see all calendars in KOrganizer, but the calendar display filed remains empty.

Reason seems to be that the domain name of the server is very long.

It is a Horde server.
The client system running Akonadi is an OpenSUSE Leap 15.1.

All other calendars from this horde system can be displayed without problems (domain name much shorter).

Reason seems to be a database table, column remoteId is to short, see the following error message (for data protection reasons I have replaced some letters by x letters, but I did not change the number of letters):


2019-05-25T23:59:16.891848+02:00 loa1 akonadiserver[3907]: org.kde.pim.akonadiserver: Error while handling command FetchItems on connection akonadi_davgroupware_resource_3 (0x55628b8621c0)
2019-05-25T23:59:16.895902+02:00 loa1 akonadiserver[3907]: message repeated 3 times: [ org.kde.pim.akonadiserver: Error while handling command FetchItems on connection akonadi_davgroupware_resource_3 (0x55628b8621c0)]
2019-05-25T23:59:19.334931+02:00 loa1 akonadiserver[3907]: org.kde.pim.akonadiserver: DATABASE ERROR:
2019-05-25T23:59:19.335251+02:00 loa1 akonadiserver[3907]: org.kde.pim.akonadiserver:   Error code: "1406"
2019-05-25T23:59:19.335417+02:00 loa1 akonadiserver[3907]: org.kde.pim.akonadiserver:   DB error:  "Data too long for column 'remoteId' at row 1"
2019-05-25T23:59:19.335599+02:00 loa1 akonadiserver[3907]: org.kde.pim.akonadiserver:   Error text: "Data too long for column 'remoteId' at row 1 QMYSQL3: Der Befehl konnte nicht ausgeführt werden"
2019-05-25T23:59:19.335735+02:00 loa1 akonadiserver[3907]: org.kde.pim.akonadiserver:   Values: QMap((":0", QVariant(int, 0))(":1", QVariant(QString, "https://www.xxxxx.de/h/rpc.php/calendars/xxxxxx.xxxxxxxxxn@xxxxxxxxx-xxx-xxxxxxxxxxxxxxx.de/calendar~OV5Iqp6YmUNuhCyok2UpkJN/Ham4UixcxFU3Ft6PRqFr9X2.ics#040000008200E00074C5B7101A82E0080000000090B6EB6A4B4BD401000000000000000010000000544F59A1A0F4D341A8CF12EB09461AE62018-10-25T13:00:00+00:00"))(":2", QVariant(QString, "\"065c4f8744e0ae5a4e2d3ea03efe3b88\""))(":3", QVariant(QString, ""))(":4", QVariant(qlonglong, 85))(":5", QVariant(qlonglong, 3))(":6", QVariant(QDateTime, QDateTime(2019-05-25 21:59:19.334 UTC Qt::TimeSpec(UTC))))(":7", QVariant(QDateTime, QDateTime(2019-05-25 21:59:19.334 UTC Qt::TimeSpec(UTC))))(":8", QVariant(bool, false))(":9", QVariant(qlonglong, 0)))
2019-05-25T23:59:19.335874+02:00 loa1 akonadiserver[3907]: org.kde.pim.akonadiserver:   Query: "INSERT INTO PimItemTable (rev, remoteId, remoteRevision, gid, collectionId, mimeTypeId, datetime, atime, dirty, size) VALUES (:0, :1, :2, :3, :4, :5, :6, :7, :8, :9)"
2019-05-25T23:59:19.336000+02:00 loa1 akonadiserver[3907]: org.kde.pim.akonadiserver: Error during insertion into table "PimItemTable" "Data too long for column 'remoteId' at row 1 QMYSQL3: Der Befehl konnte nicht ausgeführt werden"
2019-05-25T23:59:19.336129+02:00 loa1 akonadiserver[3907]: org.kde.pim.akonadiserver: Error while handling command CreateItem on connection akonadi_davgroupware_resource_3 (0x55628b8621c0)
2019-05-25T23:59:19.336255+02:00 loa1 akonadi_davgroupware_resource[6897]: org.kde.pim.akonadicore: Creating/updating items from the akonadi database failed: "Failed to append item"
2019-05-25T23:59:19.339166+02:00 loa1 akonadi_davgroupware_resource[6897]: org.kde.pim.akonadicore: Error during ItemSync:  "Failed to append item"

I would be very thankfull if you could have a look at this.

Regards,
Daniel
Comment 1 Daniel 2019-06-01 11:17:41 UTC
SOLUTION:

I solved the described problem by issuing the following command in my lokal akonadi MariaDB:

use akonadi; ALTER TABLE PimItemTable MODIFY remoteId varbinary(1000);
Comment 2 Christophe Giboudeaux 2019-06-01 14:43:56 UTC

*** This bug has been marked as a duplicate of bug 406106 ***
Comment 3 Christophe Giboudeaux 2019-06-01 14:44:40 UTC

*** This bug has been marked as a duplicate of bug 394839 ***