Bug 407797 - Unseting act un new/unread crashes kmail
Summary: Unseting act un new/unread crashes kmail
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: folders (show other bugs)
Version: 5.10.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 408249 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-05-21 12:52 UTC by Martin van Es
Modified: 2019-10-23 14:28 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin van Es 2019-05-21 12:52:38 UTC
SUMMARY
I noticed the Drafts folder on one of my IMAP resources was triggering the new mail notification, so I decided to turn it off but it makes kmail crash and the setting is still on afterwards. This only happens on my IMAP resources, I can toggle the checkbox and save on my local draft folder without problems.

STEPS TO REPRODUCE
1. Open folder properties for any folder on any IMAP service
2. Uncheck "act on new/unread" checkbox
3. Click OK

OBSERVED RESULT
Kmail crashes

EXPECTED RESULT
Disabled "act on new/unread" checkbox, normal operation

SOFTWARE/OS VERSIONS
Operating System: Kubuntu 19.04
KDE Plasma Version: 5.15.5
KDE Frameworks Version: 5.57.0
Qt Version: 5.12.2
Kernel Version: 5.1.3
OS Type: 64-bit
Comment 1 Martin van Es 2019-05-21 12:55:30 UTC
Hmm... even pressing "Ok" on the folder properties dialog without making changes crashes kmail?
Comment 2 Laurent Montel 2019-05-22 04:56:27 UTC
Backtrace please
Comment 3 Martin van Es 2019-05-22 06:17:32 UTC
Do you have a hint on what dbg packages to install for a useable backtrace then?
Until then, this is the (unusable) trace of the segfaulting thread:


hread 1 (Thread 0x7ff7aa718f00 (LWP 12242)):
[KCrash Handler]
#6  0x00007ff7c04b1f0c in PimCommon::CollectionAclPage::save(Akonadi::Collection&) () from /usr/lib/x86_64-linux-gnu/libKF5PimCommonAkonadi.so.5
#7  0x00007ff7c0149e0d in ?? () from /usr/lib/x86_64-linux-gnu/libKF5AkonadiWidgets.so.5abi1
#8  0x00007ff7c1d58563 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007ff7c27dd032 in QAbstractButton::clicked(bool) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#10 0x00007ff7c27dd24a in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#11 0x00007ff7c27de60f in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#12 0x00007ff7c27de7e5 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#13 0x00007ff7c2733b58 in QWidget::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#14 0x00007ff7c26f4551 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#15 0x00007ff7c26fbb77 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#16 0x00007ff7c1d2e8e9 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#17 0x00007ff7c26faebf in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool, bool) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#18 0x00007ff7c274e57b in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#19 0x00007ff7c275153f in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#20 0x00007ff7c26f4551 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#21 0x00007ff7c26fb930 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#22 0x00007ff7c1d2e8e9 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#23 0x00007ff7c2104c6c in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#24 0x00007ff7c2106075 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#25 0x00007ff7c20e005b in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#26 0x00007ff7aa02f67a in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#27 0x00007ff7be6a6aae in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007ff7be6a6d48 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007ff7be6a6ddc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007ff7c1d82047 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#31 0x00007ff7c1d2d5bb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#32 0x00007ff7c1d355e2 in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#33 0x000055ae95c0834a in ?? ()
#34 0x00007ff7c1716b6b in __libc_start_main (main=0x55ae95c07430, argc=3, argv=0x7ffee9fb9d68, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffee9fb9d58) at ../csu/libc-start.c:308
#35 0x000055ae95c084fa in _start ()
[Inferior 1 (process 12242) detached]
Comment 4 Christoph Feck 2019-06-25 14:26:53 UTC
*** Bug 408249 has been marked as a duplicate of this bug. ***
Comment 5 Kamil Dudka 2019-07-15 15:35:25 UTC
I get a crash with similar backtrace on the same occasion but for me it happens only with 1 IMAP account out of 3.  It does not seem to be folder-specific but account-specific.  It happens consistently.  Is there any workaround to change the property?
Comment 6 Kamil Dudka 2019-08-12 16:09:26 UTC
(In reply to Kamil Dudka from comment #5)
The same scenario worked fine for me now with kmail 5.11.3 but I am not sure whether it was upgrade of kmail or something else that fixed it for me...
Comment 7 Martin van Es 2019-10-23 14:28:43 UTC
I can confirm that 5.11.3 doesn't exhibit the problem anymore, for me.