Bug 407668 - hidpi scaling problem
Summary: hidpi scaling problem
Status: RESOLVED DOWNSTREAM
Alias: None
Product: kolourpaint
Classification: Unclassified
Component: general (show other bugs)
Version: 18.04
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kolourpaint-support
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-17 21:48 UTC by TiTAN
Modified: 2019-06-26 11:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: https://commits.kde.org/kolourpaint/8c356069a9df12db676a268ff85b2cb83fa18bf0


Attachments
screenshot (95.48 KB, image/png)
2019-05-17 21:48 UTC, TiTAN
Details

Note You need to log in before you can comment on or make changes to this bug.
Description TiTAN 2019-05-17 21:48:33 UTC
Created attachment 120148 [details]
screenshot

Hi
in hi-dpi 4k scaling every things is small
scaling setting on 200%

Linux : Ubuntu 18.04
Comment 1 Nate Graham 2019-05-21 18:54:22 UTC
How did you set 200% scaling? By using System Settings > Display & Monitor > Scale Display (correct) or System Settings > Fonts > Force Fonts DPI (incorrect)?
Comment 2 TiTAN 2019-05-21 20:15:37 UTC
(In reply to Nate Graham from comment #1)
> How did you set 200% scaling? By using System Settings > Display & Monitor >
> Scale Display (correct) or System Settings > Fonts > Force Fonts DPI
> (incorrect)?

System Settings > Display & Monitor > Scale Display
Comment 3 Nate Graham 2019-05-21 20:23:24 UTC
Thanks, that's the correct method. Cannot reproduce with  Kolourpaint 19.04.0. The version you're using (17.12.3 ) is quite old at this point.
Comment 4 Christoph Feck 2019-05-21 21:46:52 UTC
Yep, fixed since 18.08 version.
Comment 5 TiTAN 2019-05-22 05:40:51 UTC
How update to 17 or 18?
I have Ubuntu 18.04 last version its 16
Comment 6 Nate Graham 2019-05-23 19:18:09 UTC
Update to a newer Ubuntu version or use a newer Snap- or Flatpak-provided version of Kolourpaint. If you need any further details, please ask in an Ubuntu-specific venue, as Ubuntu's release schedule and packaging decisions is something that KDE has no impact on. Thanks!
Comment 7 TiTAN 2019-06-06 15:51:10 UTC
i install version 19.04 from snap but not fix scaling and every things is small
Comment 8 Christoph Feck 2019-06-25 17:26:18 UTC
How did you configure scaling in systemsettings? Via font size, or via font DPI or via kscreen scaling factor?
Comment 9 Christoph Feck 2019-06-25 17:27:47 UTC
Could you please test this in Konsole:

QT_SCALE_FACTOR=2 kolourpaint

If this changes scaling, it means you didn't setup scaling correctly.
Comment 10 TiTAN 2019-06-26 04:57:07 UTC
(In reply to Christoph Feck from comment #8)
> How did you configure scaling in systemsettings? Via font size, or via font
> DPI or via kscreen scaling factor?

This is my setting 
http://uupload.ir/files/6hyp_screenshot_from_2019-06-26_09-25-04.png
http://uupload.ir/files/468_screenshot_from_2019-06-26_09-25-19.png
Comment 11 TiTAN 2019-06-26 05:00:30 UTC
(In reply to Christoph Feck from comment #9)
> Could you please test this in Konsole:
> 
> QT_SCALE_FACTOR=2 kolourpaint
> 
> If this changes scaling, it means you didn't setup scaling correctly.

This is fix scaling for kolourpaint
Comment 12 Nate Graham 2019-06-26 11:41:25 UTC
It looks like the problem here is that GNOME doesn't set the appropriate environment variables to make Qt apps get scaled along with GTK apps.

Please file a bug against GNOME Control Center telling them to set QT_SCALE_FACTOR when the user chooses a high DPI scale factor so that Qt apps get scaled as well.

(BTW, GTK apps run in Plasma do get correctly scaled. :) )