Bug 407577 - Passwords containing certain non-ASCII characters not communicated correctly
Summary: Passwords containing certain non-ASCII characters not communicated correctly
Status: CONFIRMED
Alias: None
Product: korganizer
Classification: Applications
Component: groupware (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-16 02:22 UTC by mydarkstar
Modified: 2021-09-18 20:13 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Error message upon testing the connection (37.63 KB, image/png)
2019-05-16 02:22 UTC, mydarkstar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mydarkstar 2019-05-16 02:22:53 UTC
Created attachment 120099 [details]
Error message upon testing the connection

SUMMARY
KOrganizer does not seem to communicate passwords containing certain non-ASCII characters correctly when communicating to a CalDAV server. In this case, a stable Nextcloud instance was used.

STEPS TO REPRODUCE
1. Add Calendar
2. Select "DAV groupware resource"
3. Fill in the username
4. Type in a password with certain non-ASCII characters, like 'ö', select "Next"
5. In "Use one of those servers" select "Nextcloud"
6. Fill in the correct host data
7. On the next dialog, click the "Test Connection" button

OBSERVED RESULT
Upon testing the connection, the error with the following error message occurs: "An error occurred: There was a problem with the request. Invalid username/password (401)."

EXPECTED RESULT
The login data should be accepted.

SOFTWARE/OS VERSIONS
Linux kernel: 5.1.2
KOrganizer: 5.11.1
KDE Plasma Version: 5.15-1
KDE Frameworks Version: 5.58.0
Qt Version: 5.12.3 (built against 5.12.3)
Nextcloud: 15.0.7
All versions are the latest available versions.

ADDITIONAL INFORMATION
Using a password only containing ASCII characters works as expected. The password has been copied, pasted, and checked for errors.
Comment 1 Laurent Montel 2019-05-16 05:07:30 UTC
Sorry for the moment I can't test it as I don't have server support
Comment 2 Laurent Montel 2019-05-16 05:08:01 UTC
I don't have a caldav server for testing it...
Comment 3 daniel köbsch 2021-05-16 10:00:10 UTC
Hi.
I had the exact same error and struggled a lot to find the cause. Pure luck led me to this bug report. i'll add some words here so that future strugglers might find the solution via search engines.

So i tried to use Nextcloud 21 dav with KDE Kontact, but it got Error 401 while testing connection. 
Indeed, i had non-ASCII characters in password. 
Changing the password to standar only worked around the problem. not optimal, but finaly it works!
Comment 4 mydarkstar 2021-06-17 10:19:04 UTC
Thank you for confirming the issue, Daniel!
As other people can reproduce the issue, I'll be setting this bug report to confirmed now.
Comment 5 Allen Winter 2021-09-18 20:13:57 UTC
Laurent, David,

since the password is encoded in the caldav url, maybe we need some special coding magic with QUrl::setPassword?

kdepim-runtime/resources/dav/resource/setupwizard.cpp

I think I'm having a similar problem with a special character