Bug 407394 - ksysguard started via System Load Viewer widget crashed on close
Summary: ksysguard started via System Load Viewer widget crashed on close
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Neon Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-10 15:13 UTC by Patrick Silva
Modified: 2019-05-30 19:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2019-05-10 15:13:20 UTC
SUMMARY
I added System Loader Viewer to desktop, I clicked on it to open ksysguard,
plasma shown a crash notification when I closed ksysguard.

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.15.80
KDE Frameworks Version: 5.58.0
Qt Version: 5.12.0

Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8a0bfd0b80 (LWP 13737))]

Thread 4 (Thread 0x7f89d2d30700 (LWP 13740)):
#0  QListData::end (this=0x7f89cc004cf0) at ../../include/QtCore/../../src/corelib/tools/qlist.h:117
#1  QList<QTimerInfo*>::constEnd (this=0x7f89cc004cf0) at ../../include/QtCore/../../src/corelib/tools/qlist.h:331
#2  QTimerInfoList::timerWait (this=0x7f89cc004cf0, tm=...) at kernel/qtimerinfo_unix.cpp:393
#3  0x00007f8a06fe8e9e in timerSourcePrepareHelper (timeout=0x7f89d2d2f824, src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:132
#4  timerSourcePrepare (source=<optimized out>, timeout=0x7f89d2d2f824) at kernel/qeventdispatcher_glib.cpp:165
#5  0x00007f89f9c46b28 in g_main_context_prepare () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f89f9c474fb in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f89f9c476dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f8a06fe915b in QEventDispatcherGlib::processEvents (this=0x7f89cc000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#9  0x00007f8a06f8a64a in QEventLoop::exec (this=this@entry=0x7f89d2d2f9f0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#10 0x00007f8a06db241a in QThread::exec (this=this@entry=0x7f8a0796bd80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:531
#11 0x00007f8a076f4015 in QDBusConnectionManager::run (this=0x7f8a0796bd80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:178
#12 0x00007f8a06db3bc2 in QThreadPrivate::start (arg=0x7f8a0796bd80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:361
#13 0x00007f89fbbc76db in start_thread (arg=0x7f89d2d30700) at pthread_create.c:463
#14 0x00007f8a0b8b488f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f89d9080700 (LWP 13739)):
#0  0x00007f89fbbcd9f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55c8be7df928) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  __pthread_cond_wait_common (abstime=0x0, mutex=0x55c8be7df8d8, cond=0x55c8be7df900) at pthread_cond_wait.c:502
#2  __pthread_cond_wait (cond=0x55c8be7df900, mutex=0x55c8be7df8d8) at pthread_cond_wait.c:655
#3  0x00007f89da41fdcb in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f89da41faf7 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f89fbbc76db in start_thread (arg=0x7f89d9080700) at pthread_create.c:463
#6  0x00007f8a0b8b488f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f89e2936700 (LWP 13738)):
#0  0x00007f8a0b8a7bf9 in __GI___poll (fds=0x7f89e2935938, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f89fc424747 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f89fc42636a in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f89e362932a in QXcbEventQueue::run (this=0x55c8be7a5350) at qxcbeventqueue.cpp:225
#4  0x00007f8a06db3bc2 in QThreadPrivate::start (arg=0x55c8be7a5350) at thread/qthread_unix.cpp:361
#5  0x00007f89fbbc76db in start_thread (arg=0x7f89e2936700) at pthread_create.c:463
#6  0x00007f8a0b8b488f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f8a0bfd0b80 (LWP 13737)):
[KCrash Handler]
#6  0x00007f8a083dbc8c in QLabelPrivate::clearContents (this=this@entry=0x55c8beb922d0) at widgets/qlabel.cpp:1302
#7  0x00007f8a083dc7cc in QLabel::setText (this=0x55c8beb63570, text=...) at widgets/qlabel.cpp:293
#8  0x00007f8a0bbf7290 in TopLevel::answerReceived (this=0x55c8beb601a0, id=<optimized out>, answerList=...) at ./gui/ksysguard.cpp:468
#9  0x00007f8a0ac42b72 in KSGRD::SensorAgent::processAnswer(char const*, int) () from /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#10 0x00007f8a0ac49c54 in ?? () from /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#11 0x00007f8a06fbbf3f in QtPrivate::QSlotObjectBase::call (a=0x7ffdd66f5060, r=0x55c8bec00740, this=0x55c8bebc9620) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#12 QMetaObject::activate (sender=sender@entry=0x55c8bebdef00, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=6, argv=argv@entry=0x7ffdd66f5060) at kernel/qobject.cpp:3759
#13 0x00007f8a06fbc4f7 in QMetaObject::activate (sender=sender@entry=0x55c8bebdef00, m=m@entry=0x7f8a07436e40 <QProcess::staticMetaObject>, local_signal_index=local_signal_index@entry=6, argv=argv@entry=0x7ffdd66f5060) at kernel/qobject.cpp:3631
#14 0x00007f8a06f16ffa in QProcess::readyReadStandardOutput (this=this@entry=0x55c8bebdef00, _t1=...) at .moc/moc_qprocess.cpp:366
#15 0x00007f8a06f1da11 in QProcessPrivate::tryReadFromChannel (this=0x7f89dc005a80, channel=0x7f89dc005ba8) at io/qprocess.cpp:1070
#16 0x00007f8a06f1dee0 in QProcessPrivate::_q_canReadStandardOutput (this=<optimized out>) at io/qprocess.cpp:1081
#17 QProcess::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7ffdd66f5230) at .moc/moc_qprocess.cpp:207
#18 0x00007f8a06fbbe25 in QMetaObject::activate (sender=sender@entry=0x55c8bebc4a30, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffdd66f5230) at kernel/qobject.cpp:3778
#19 0x00007f8a06fbc4f7 in QMetaObject::activate (sender=sender@entry=0x55c8bebc4a30, m=m@entry=0x7f8a07438c60 <QSocketNotifier::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffdd66f5230) at kernel/qobject.cpp:3631
#20 0x00007f8a06fc8678 in QSocketNotifier::activated (this=this@entry=0x55c8bebc4a30, _t1=<optimized out>, _t2=...) at .moc/moc_qsocketnotifier.cpp:140
#21 0x00007f8a06fc8a32 in QSocketNotifier::event (this=0x55c8bebc4a30, e=0x7ffdd66f5510) at kernel/qsocketnotifier.cpp:266
#22 0x00007f8a082ae8ac in QApplicationPrivate::notify_helper (this=this@entry=0x55c8be74be80, receiver=receiver@entry=0x55c8bebc4a30, e=e@entry=0x7ffdd66f5510) at kernel/qapplication.cpp:3752
#23 0x00007f8a082b5e40 in QApplication::notify (this=0x7ffdd66f5800, receiver=0x55c8bebc4a30, e=0x7ffdd66f5510) at kernel/qapplication.cpp:3499
#24 0x00007f8a06f8c328 in QCoreApplication::notifyInternal2 (receiver=0x55c8bebc4a30, event=0x7ffdd66f5510) at kernel/qcoreapplication.cpp:1061
#25 0x00007f8a06f8c4fe in QCoreApplication::sendEvent (receiver=<optimized out>, event=event@entry=0x7ffdd66f5510) at kernel/qcoreapplication.cpp:1451
#26 0x00007f8a06fe9da8 in socketNotifierSourceDispatch (source=0x55c8be7d9c70) at kernel/qeventdispatcher_glib.cpp:106
#27 0x00007f89f9c47417 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f89f9c47650 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f89f9c476dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f8a06fe913f in QEventDispatcherGlib::processEvents (this=0x55c8be7d3bc0, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#31 0x00007f8a06f8a64a in QEventLoop::exec (this=this@entry=0x7ffdd66f5730, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#32 0x00007f8a06f93800 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1364
#33 0x00007f8a07a75edc in QGuiApplication::exec () at kernel/qguiapplication.cpp:1779
#34 0x00007f8a082ae805 in QApplication::exec () at kernel/qapplication.cpp:2909
#35 0x00007f8a0bbf918b in kdemain (argc=<optimized out>, argv=<optimized out>) at ./gui/ksysguard.cpp:627
#36 0x00007f8a0b7b4b97 in __libc_start_main (main=0x55c8bd405720 <main>, argc=1, argv=0x7ffdd66f5948, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffdd66f5938) at ../csu/libc-start.c:310
#37 0x000055c8bd40575a in _start ()
Comment 1 Christoph Feck 2019-05-30 19:16:59 UTC

*** This bug has been marked as a duplicate of bug 350140 ***