Bug 407189 - KMail/Kontact sometimes shows the wrong message (email), another than the selected one
Summary: KMail/Kontact sometimes shows the wrong message (email), another than the sel...
Status: REPORTED
Alias: None
Product: kmail2
Classification: Applications
Component: message list (show other bugs)
Version: 5.11.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-03 18:48 UTC by David Hurka
Modified: 2019-05-05 18:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Hurka 2019-05-03 18:48:57 UTC
SUMMARY

KMail frequently shows the wrong message. That is, it doesn’t show the message which is selected in the mailing list, but the message directly above or below, or preceeding in the thread. Sometimes, two messages are swapped, selecting one message shows the other.

When hitting Reply, always the correct message is quoted.

This happens since I’ve set up my notebook last month. Didn’t happen on my desktop PC (same KDE Neon) before, where I had no Kontact.

It’s possible that this is only in the KMail component in Kontact (behaviour is unpredictable). Also, it seems like only messages with threads have this problem.

I don’t think that this might be a duplicate of BUG 69976

APOLOGIZING

I know about the ongoing problems with KDE PIM / Akonady / data base systems, and just want to report my observations. Beside this, my mail client works fine.

SOFTWARE/OS VERSIONS
KDE Neon 5.15.4
KDE Plasma Version: 5.15.4
KDE Frameworks Version: 5.57.0
Qt Version: 5.12.0
(Kontact 5.10.1)

ADDITIONAL INFORMATION

I’ve installed KDE Neon on my Lenovo Ideapad s205, which is usually not possible. Installation might be errorneous. More information on the mailing list: https://mail.kde.org/pipermail/neon/2019-April/000622.html
Comment 1 David Hurka 2019-05-05 18:38:47 UTC
(In reply to David Hurka from comment #0)
> This happens since I’ve set up my notebook last month. Didn’t happen on my
> desktop PC (same KDE Neon) before, where I had no Kontact.
> 
> It’s possible that this is only in the KMail component in Kontact (behaviour
> is unpredictable). Also, it seems like only messages with threads have this
> problem.

Tested by using KMail instead of Kontact: Happens in KMail too.

Also, happened only with threaded messages so far. Some messages in some threads  simply do not update the message view area, or show wrong messages. Also happens in flat (not threaded) view (aggregation) modes.
Comment 2 David Hurka 2019-05-05 18:51:00 UTC
Investigating further...

These messages, which update the view area incorrectly, also open an empty viewer window when double clicked.

Usually, double clicking a message in the message list opens a window, which looks like the message view area. In this case, the entire window is grey, except the toolbars etc.

When R (Reply) is hit, the message is inserted with correct content, and quoted correctly. When Shift+F (Forward as Attachment) is hit, the message is attached as message correctly. But when double clicking it in the attachment list, a grey window is opened again. Saving the attachment and opening it, also shows a grey window.

Seems like some messages can’t be loaded, and KMail does not care about that.

But this still does not explain, why some messages show some other message.