Bug 407119 - Wraparound mode refers to non-existent keyboard shortcut
Summary: Wraparound mode refers to non-existent keyboard shortcut
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: General (show other bugs)
Version: git master (please specify the git hash!)
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-01 08:03 UTC by Karl Ove Hufthammer
Modified: 2019-05-01 08:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karl Ove Hufthammer 2019-05-01 08:03:54 UTC
SUMMARY
When one enters wraparound mode, the following message is shown:

  Entering Wraparound mode. Press '%1' to leave Wraparound mode.

(where %1 is the keyboard shortcut). But when no keyboard shortcut is defined, the message says:

  Entering Wraparound mode. Press '' to leave Wraparound mode.

(and the '' looks like the " symbol), which is confusing. The second sentence should only be shown when there actually is a keyboard shortcut defined.


STEPS TO REPRODUCE
1. Open an image.
2. Ensure you don’t have a keyboard shortcut for wraparound defined (I didn’t have one by default).
3. Go to ‘View → Wrap Around Mode’.


OBSERVED RESULT
The string ‘Entering Wraparound mode. Press '' to leave Wraparound mode.’ is shown.

EXPECTED RESULT
The string ‘Entering wraparound mode.’ (note the lowercase w) should be shown.

(Or perhaps ‘tile view’ would be a better name than ‘wraparound mode?)
Comment 1 Halla Rempt 2019-05-01 08:32:13 UTC
Git commit 732f4ae4c0a2963eaf9f8fce08335cd0e9f7f53c by Boudewijn Rempt.
Committed on 01/05/2019 at 08:32.
Pushed by rempt into branch 'master'.

Remove wraparound warning message

Since a) nobody who got confused by wraparound mode ever seems to
have noticed the message and b) we removed the default shortcut
because people got confused too much by it, we might just as well
remove the warning completely. It takes deliberate action to
activate wraparound mode, let's assume that people who do so, know
what they are doing.

M  +0    -6    libs/ui/canvas/kis_canvas_controller.cpp

https://invent.kde.org/kde/krita/commit/732f4ae4c0a2963eaf9f8fce08335cd0e9f7f53c