Bug 407070 - akonadi_control hangs on execution of korganizer
Summary: akonadi_control hangs on execution of korganizer
Status: RESOLVED DUPLICATE of bug 392092
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: 5.8.3
Platform: Other Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-29 21:08 UTC by pkjdje
Modified: 2019-05-14 20:09 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pkjdje 2019-04-29 21:08:56 UTC
SUMMARY


STEPS TO REPRODUCE
1. Open Korganiser
2. report bugs dialog fails to allow report
3. requesting backtrace gives that pasted below

OBSERVED RESULT
backtrace
Application: akonadi_control (akonadi_control), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fd892f02c80 (LWP 3182))]

Thread 2 (Thread 0x7fd891476700 (LWP 3185)):
#0  0x00007fd897f986d9 in __GI___poll (fds=0x7fd891475cb8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fd8960cf917 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fd8960d153a in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fd892836159 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007fd8982dac87 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fd897e71164 in start_thread (arg=<optimized out>) at pthread_create.c:486
#6  0x00007fd897fa4def in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7fd892f02c80 (LWP 3182)):
[KCrash Handler]
#6  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:50
#7  0x00007fd897eac535 in __GI_abort () at abort.c:79
#8  0x00007fd8982998d7 in QMessageLogger::fatal(char const*, ...) const () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x000055eedeb4cbd1 in ?? ()
#10 0x000055eedeb6f5c2 in ?? ()
#11 0x000055eedeb4cc78 in ?? ()
#12 0x00007fd897eae09b in __libc_start_main (main=0x55eedeb4cbe0, argc=1, argv=0x7ffda400dde8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffda400ddd8) at ../csu/libc-start.c:308
#13 0x000055eedeb4d37a in _start ()
[Inferior 1 (process 3182) detached]


EXPECTED RESULT


SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
Comment 1 pkjdje 2019-04-29 21:16:49 UTC
running Kubuntu-cosmic
korganizer 4:18.04.3-0ubuntu1
akonadi 4:18.04.3-0ubuntu2

may be an Akonadi Bug; unknown
Comment 2 Christoph Feck 2019-05-14 20:09:04 UTC

*** This bug has been marked as a duplicate of bug 392092 ***