Bug 406991 - Plasma crashes when I try to use "Jump to strip..." feature of Comic Strip widget while internet is offline
Summary: Plasma crashes when I try to use "Jump to strip..." feature of Comic Strip wi...
Status: RESOLVED FIXED
Alias: None
Product: kdeplasma-addons
Classification: Unclassified
Component: Comic (show other bugs)
Version: master
Platform: Neon Packages Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 409066 416195 435976 456940 457062 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-04-27 21:26 UTC by Patrick Silva
Modified: 2022-07-24 12:23 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24.6


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2019-04-27 21:26:31 UTC
STEPS TO REPRODUCE
1. add Comic widget to your desktop
2. open Comic widget settings, click "Get new comics..." button
3. search for "dilbert" comic and install it
4. disconnect your computer from the internet (I turned off my router) and reboot
5. start plasma while the computer is still offline (Comic widget only shows a spinner)
6. right click on Comic widget, select "Jump to strip..."

OBSERVED RESULT
plasma crashes

EXPECTED RESULT
no crash

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.15.80
KDE Frameworks Version: 5.58.0
Qt Version: 5.12.0

ADDITIONAL INFORMATION
Also reproducible on Arch Linux


Thread 9 (Thread 0x7f934689f700 (LWP 1424)):
#0  0x00007f9391914bf9 in __GI___poll (fds=0x55886e1ef090, nfds=2, timeout=-1)
    at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f938b77c539 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f938b77c8d2 in g_main_loop_run ()
   from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9353adc026 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f938b7a4105 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f938eb366db in start_thread (arg=0x7f934689f700) at pthread_create.c:463
#6  0x00007f939192188f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 8 (Thread 0x7f93470a0700 (LWP 1423)):
#0  0x00007f9391914bf9 in __GI___poll (fds=0x55886e1dc2b0, nfds=2, timeout=-1)
    at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f938b77c539 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f938b77c64c in g_main_context_iteration ()
   from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f938b77c691 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f938b7a4105 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f938eb366db in start_thread (arg=0x7f93470a0700) at pthread_create.c:463
#6  0x00007f939192188f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 7 (Thread 0x7f935a767700 (LWP 1417)):
#0  0x00007f9391914bf9 in __GI___poll (fds=0x7f93540054c0, nfds=1, timeout=-1)
    at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f938b77c539 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f938b77c64c in g_main_context_iteration ()
   from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f939225713f in QEventDispatcherGlib::processEvents (this=0x7f9354000b20, 
    flags=...) at kernel/qeventdispatcher_glib.cpp:422
#4  0x00007f93921f864a in QEventLoop::exec (this=this@entry=0x7f935a766cb0, flags=..., 
    flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007f939202041a in QThread::exec (this=this@entry=0x55886c1fa0b0)
    at thread/qthread.cpp:531
#6  0x00007f93962e31c6 in QQuickPixmapReader::run (this=0x55886c1fa0b0)
    at util/qquickpixmapcache.cpp:949
#7  0x00007f9392021bc2 in QThreadPrivate::start (arg=0x55886c1fa0b0)
    at thread/qthread_unix.cpp:361
#8  0x00007f938eb366db in start_thread (arg=0x7f935a767700) at pthread_create.c:463
#9  0x00007f939192188f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7f9363e19700 (LWP 1415)):
#0  0x00007f938eb3c9f3 in futex_wait_cancelable (private=<optimized out>, expected=0, 
    futex_word=0x55886bef9cd8) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  __pthread_cond_wait_common (abstime=0x0, mutex=0x55886bef9c88, cond=0x55886bef9cb0)
    at pthread_cond_wait.c:502
#2  __pthread_cond_wait (cond=0x55886bef9cb0, mutex=0x55886bef9c88)
    at pthread_cond_wait.c:655
#3  0x00007f9364ab7dcb in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f9364ab7af7 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f938eb366db in start_thread (arg=0x7f9363e19700) at pthread_create.c:463
#6  0x00007f939192188f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7f9370627700 (LWP 1413)):
#0  0x00007f9391914bf9 in __GI___poll (fds=0x7f9368003ce0, nfds=1, timeout=9841)
    at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f938b77c539 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f938b77c64c in g_main_context_iteration ()
   from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f939225713f in QEventDispatcherGlib::processEvents (this=0x7f9368000b20, 
    flags=...) at kernel/qeventdispatcher_glib.cpp:422
#4  0x00007f93921f864a in QEventLoop::exec (this=this@entry=0x7f9370626d20, flags=..., 
    flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007f939202041a in QThread::exec (this=<optimized out>) at thread/qthread.cpp:531
#6  0x00007f9392021bc2 in QThreadPrivate::start (arg=0x55886beede00)
    at thread/qthread_unix.cpp:361
#7  0x00007f938eb366db in start_thread (arg=0x7f9370627700) at pthread_create.c:463
#8  0x00007f939192188f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f93808d2700 (LWP 1411)):
#0  0x00007f9391914bf9 in __GI___poll (fds=0x7f9378004a00, nfds=1, timeout=-1)
    at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f938b77c539 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f938b77c64c in g_main_context_iteration ()
   from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f939225713f in QEventDispatcherGlib::processEvents (this=0x7f9378000b20, 
    flags=...) at kernel/qeventdispatcher_glib.cpp:422
#4  0x00007f93921f864a in QEventLoop::exec (this=this@entry=0x7f93808d1d00, flags=..., 
    flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007f939202041a in QThread::exec (this=this@entry=0x55886bbd8c80)
    at thread/qthread.cpp:531
#6  0x00007f9395e1e2e5 in QQmlThreadPrivate::run (this=0x55886bbd8c80)
    at qml/ftw/qqmlthread.cpp:148
#7  0x00007f9392021bc2 in QThreadPrivate::start (arg=0x55886bbd8c80)
    at thread/qthread_unix.cpp:361
#8  0x00007f938eb366db in start_thread (arg=0x7f93808d2700) at pthread_create.c:463
#9  0x00007f939192188f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f9382316700 (LWP 1409)):
#0  0x00007f9391914bf9 in __GI___poll (fds=0x7f9374012160, nfds=4, timeout=-1)
    at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f938b77c539 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f938b77c64c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f939225713f in QEventDispatcherGlib::processEvents (this=0x7f9374000b20, flags=...)
    at kernel/qeventdispatcher_glib.cpp:422
#4  0x00007f93921f864a in QEventLoop::exec (this=this@entry=0x7f9382315cf0, flags=..., 
    flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007f939202041a in QThread::exec (
    this=this@entry=0x7f9393575d80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>)
    at thread/qthread.cpp:531
#6  0x00007f93932fe015 in QDBusConnectionManager::run (
    this=0x7f9393575d80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>)
    at qdbusconnection.cpp:178
#7  0x00007f9392021bc2 in QThreadPrivate::start (
    arg=0x7f9393575d80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>)
    at thread/qthread_unix.cpp:361
#8  0x00007f938eb366db in start_thread (arg=0x7f9382316700) at pthread_create.c:463
#9  0x00007f939192188f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f93844ec700 (LWP 1408)):
#0  0x00007f9391914bf9 in __GI___poll (fds=0x7f93844ebc38, nfds=1, timeout=-1)
    at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f9396f38747 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f9396f3a36a in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f938543d32a in QXcbEventQueue::run (this=0x55886bafeaa0) at qxcbeventqueue.cpp:225
#4  0x00007f9392021bc2 in QThreadPrivate::start (arg=0x55886bafeaa0) at thread/qthread_unix.cpp:361
#5  0x00007f938eb366db in start_thread (arg=0x7f93844ec700) at pthread_create.c:463
#6  0x00007f939192188f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f93984f2880 (LWP 1406)):
#0  0x00007f937161439a in ?? ()
   from /usr/lib/x86_64-linux-gnu/qt5/plugins/plasma/applets/plasma_applet_comic.so
#1  0x00007f9392229f3f in QtPrivate::QSlotObjectBase::call (a=0x7ffde8687630, r=0x55886bd50080, 
    this=0x55886beed7e0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#2  QMetaObject::activate (sender=sender@entry=0x55886badc860, signalOffset=<optimized out>, 
    local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7ffde8687630)
    at kernel/qobject.cpp:3759
#3  0x00007f939222a4f7 in QMetaObject::activate (sender=sender@entry=0x55886badc860, 
    m=m@entry=0x7f9394226820 <QAction::staticMetaObject>, 
    local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7ffde8687630)
    at kernel/qobject.cpp:3631
#4  0x00007f9393b4e162 in QAction::triggered (this=this@entry=0x55886badc860, _t1=<optimized out>)
    at .moc/moc_qaction.cpp:380
#5  0x00007f9393b5077c in QAction::activate (this=0x55886badc860, event=<optimized out>)
    at kernel/qaction.cpp:1166
#6  0x00007f9393cc55fc in QMenuPrivate::activateCausedStack (this=this@entry=0x55887016e520, 
    causedStack=..., action=action@entry=0x55886badc860, action_e=action_e@entry=QAction::Trigger, 
    self=self@entry=true) at widgets/qmenu.cpp:1371
#7  0x00007f9393cccb6b in QMenuPrivate::activateAction (this=this@entry=0x55887016e520, 
    action=action@entry=0x55886badc860, action_e=action_e@entry=QAction::Trigger, 
    self=self@entry=true) at widgets/qmenu.cpp:1448
#8  0x00007f9393ccd9e3 in QMenu::mouseReleaseEvent (this=<optimized out>, e=0x7ffde8687d10)
    at widgets/qmenu.cpp:2940
#9  0x00007f9393b948a8 in QWidget::event (this=this@entry=0x7f937c016970, 
    event=event@entry=0x7ffde8687d10) at kernel/qwidget.cpp:9268
#10 0x00007f9393ccfd0b in QMenu::event (this=0x7f937c016970, e=0x7ffde8687d10)
    at widgets/qmenu.cpp:3062
#11 0x00007f9393b548ac in QApplicationPrivate::notify_helper (this=this@entry=0x55886bae5020, 
    receiver=receiver@entry=0x7f937c016970, e=e@entry=0x7ffde8687d10) at kernel/qapplication.cpp:3752
#12 0x00007f9393b5cd18 in QApplication::notify (this=<optimized out>, receiver=0x7f937c016970, 
    e=0x7ffde8687d10) at kernel/qapplication.cpp:3213
#13 0x00007f93921fa328 in QCoreApplication::notifyInternal2 (receiver=0x7f937c016970, 
    event=0x7ffde8687d10) at kernel/qcoreapplication.cpp:1061
#14 0x00007f93921fa50e in QCoreApplication::sendSpontaneousEvent (
    receiver=receiver@entry=0x7f937c016970, event=event@entry=0x7ffde8687d10)
    at kernel/qcoreapplication.cpp:1463
#15 0x00007f9393b5b30f in QApplicationPrivate::sendMouseEvent (
    receiver=receiver@entry=0x7f937c016970, event=event@entry=0x7ffde8687d10, alienWidget=0x0, 
    alienWidget@entry=0x7f937c016970, nativeWidget=0x7f937c016970, 
    buttonDown=buttonDown@entry=0x7f93942558b0 <qt_button_down>, lastMouseReceiver=..., 
    spontaneous=true, onlyDispatchEnterLeave=false) at kernel/qapplication.cpp:2699
#16 0x00007f9393baf80d in QWidgetWindow::handleMouseEvent (this=this@entry=0x7f937c014f40, 
    event=event@entry=0x7ffde86881a0) at kernel/qwidgetwindow.cpp:558
#17 0x00007f9393bb257a in QWidgetWindow::event (this=0x7f937c014f40, event=0x7ffde86881a0)
    at kernel/qwidgetwindow.cpp:281
#18 0x00007f9393b548ac in QApplicationPrivate::notify_helper (this=this@entry=0x55886bae5020, 
    receiver=receiver@entry=0x7f937c014f40, e=e@entry=0x7ffde86881a0) at kernel/qapplication.cpp:3752
#19 0x00007f9393b5be40 in QApplication::notify (this=0x7ffde8688660, receiver=0x7f937c014f40, 
    e=0x7ffde86881a0) at kernel/qapplication.cpp:3499
#20 0x00007f93921fa328 in QCoreApplication::notifyInternal2 (receiver=0x7f937c014f40, 
    event=0x7ffde86881a0) at kernel/qcoreapplication.cpp:1061
#21 0x00007f93921fa50e in QCoreApplication::sendSpontaneousEvent (
    receiver=receiver@entry=0x7f937c014f40, event=event@entry=0x7ffde86881a0)
    at kernel/qcoreapplication.cpp:1463
#22 0x00007f93927c252b in QGuiApplicationPrivate::processMouseEvent (e=0x558870259e60)
    at kernel/qguiapplication.cpp:2102
#23 0x00007f93927c3695 in QGuiApplicationPrivate::processWindowSystemEvent (e=e@entry=0x558870259e60)
    at kernel/qguiapplication.cpp:1837
#24 0x00007f939279c14b in QWindowSystemInterface::sendWindowSystemEvents (flags=flags@entry=...)
    at kernel/qwindowsysteminterface.cpp:1068
#25 0x00007f938543e30a in xcbSourceDispatch (source=<optimized out>) at qxcbeventdispatcher.cpp:105
#26 0x00007f938b77c387 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f938b77c5c0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f938b77c64c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f939225713f in QEventDispatcherGlib::processEvents (this=0x55886bb3c910, flags=...)
    at kernel/qeventdispatcher_glib.cpp:422
#30 0x00007f93921f864a in QEventLoop::exec (this=this@entry=0x7ffde8688540, flags=..., 
    flags@entry=...) at kernel/qeventloop.cpp:225
#31 0x00007f9392201800 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1364
#32 0x0000558869ffa0a5 in main (argc=<optimized out>, argv=<optimized out>) at ./shell/main.cpp:212
Desanexando do programa: /usr/bin/plasmashell, process 1406
Comment 1 Patrick Silva 2019-07-14 16:41:53 UTC
*** Bug 409066 has been marked as a duplicate of this bug. ***
Comment 2 Patrick Silva 2022-01-20 13:08:34 UTC
still reproducible on Arch (Plasma 5.24 beta) and neon unstable.

STEPS TO REPRODUCE
1. add Comic widget to desktop
2. open Comic widget settings and click on "Get new comics..." button
3. search for "dilbert" comic and install it
4. close 'Get new comics..." window
5. activate Dilbert comic (if it is not available for selection in the widget settings, restart Plasma with 'plasmashell --replace' and re-open the widget settings) and click on 'OK' button
6. disconnect your computer from the internet (I turned my router off)
7. logout
8. login (Comic widget only shows a spinner)
9. right click on Comic widget and choose "Jump to strip..."

backtrace gotten on neon unstable:


Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.24.80
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.3
Graphics Platform: Wayland


Thread 17 (Thread 0x7fd97a5b6700 (LWP 28894)):
#0  0x00007fd9b31f55ce in epoll_wait (epfd=32, events=events@entry=0x7fd97a5b57f0, maxevents=32, timeout=-1) at ../sysdeps/unix/sysv/linux/epoll_wait.c:30
#1  0x00007fd9784b527b in impl_pollfd_wait (object=<optimized out>, pfd=<optimized out>, ev=0x7fd97a5b59a0, n_ev=<optimized out>, timeout=<optimized out>) at ../spa/plugins/support/system.c:155
#2  0x00007fd9784a76f4 in loop_iterate (object=0x5561e351be98, timeout=-1) at ../spa/plugins/support/loop.c:316
#3  0x00007fd9785020e0 in do_loop (user_data=0x5561da140e80) at ../src/pipewire/data-loop.c:80
#4  0x00007fd9b3059609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#5  0x00007fd9b31f5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 16 (Thread 0x7fd956785700 (LWP 28859)):
#0  0x00007fd9b31e8aff in __GI___poll (fds=fds@entry=0x7fd934001ce0, nfds=nfds@entry=3, timeout=timeout@entry=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fd962c151d6 in poll (__timeout=-1, __nfds=3, __fds=0x7fd934001ce0) at /usr/include/x86_64-linux-gnu/bits/poll2.h:46
#2  poll_func (ufds=0x7fd934001ce0, nfds=3, timeout=-1, userdata=0x5561da56fa30) at pulse/thread-mainloop.c:70
#3  0x00007fd962c06841 in pa_mainloop_poll (m=m@entry=0x5561e32e04a0) at pulse/mainloop.c:824
#4  0x00007fd962c06ec3 in pa_mainloop_iterate (m=0x5561e32e04a0, block=<optimized out>, retval=0x0) at pulse/mainloop.c:926
#5  0x00007fd962c06f70 in pa_mainloop_run (m=0x5561e32e04a0, retval=retval@entry=0x0) at pulse/mainloop.c:945
#6  0x00007fd962c1511d in thread (userdata=0x5561e32e0450) at pulse/thread-mainloop.c:101
#7  0x00007fd962bb172c in internal_thread_func (userdata=0x5561dec037d0) at pulsecore/thread-posix.c:81
#8  0x00007fd9b3059609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#9  0x00007fd9b31f5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 15 (Thread 0x7fd95758d700 (LWP 28819)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5561e0562cf4) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5561e0562ca0, cond=0x5561e0562cc8) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5561e0562cc8, mutex=0x5561e0562ca0) at pthread_cond_wait.c:647
#3  0x00007fd9b357b6db in QWaitConditionPrivate::wait (deadline=..., this=0x5561e0562ca0) at thread/qwaitcondition_unix.cpp:146
#4  QWaitCondition::wait (this=this@entry=0x5561dec99dc8, mutex=mutex@entry=0x5561dec99dc0, deadline=...) at thread/qwaitcondition_unix.cpp:225
#5  0x00007fd9b51ecc24 in QSGRenderThreadEventQueue::takeEvent (wait=true, this=0x5561dec99db8) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qdeadlinetimer.h:68
#6  QSGRenderThread::processEventsAndWaitForMore (this=this@entry=0x5561dec99d20) at scenegraph/qsgthreadedrenderloop.cpp:936
#7  0x00007fd9b51ed099 in QSGRenderThread::run (this=0x5561dec99d20) at scenegraph/qsgthreadedrenderloop.cpp:1053
#8  0x00007fd9b3575543 in QThreadPrivate::start (arg=0x5561dec99d20) at thread/qthread_unix.cpp:331
#9  0x00007fd9b3059609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007fd9b31f5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 14 (Thread 0x7fd95cc6c700 (LWP 28796)):
#0  futex_abstimed_wait_cancelable (private=<optimized out>, abstime=0x7fd95cc6b8d0, clockid=<optimized out>, expected=0, futex_word=0x5561d90d6874) at ../sysdeps/nptl/futex-internal.h:320
#1  __pthread_cond_wait_common (abstime=0x7fd95cc6b8d0, clockid=<optimized out>, mutex=0x5561d90d6820, cond=0x5561d90d6848) at pthread_cond_wait.c:520
#2  __pthread_cond_timedwait (cond=0x5561d90d6848, mutex=0x5561d90d6820, abstime=0x7fd95cc6b8d0) at pthread_cond_wait.c:665
#3  0x00007fd9b357b668 in QWaitConditionPrivate::wait_relative (this=0x5561d90d6820, deadline=...) at thread/qwaitcondition_unix.cpp:136
#4  QWaitConditionPrivate::wait (deadline=..., this=0x5561d90d6820) at thread/qwaitcondition_unix.cpp:144
#5  QWaitCondition::wait (this=this@entry=0x5561d9bfb690, mutex=mutex@entry=0x5561d9bfb688, deadline=...) at thread/qwaitcondition_unix.cpp:225
#6  0x00007fd9b15e406d in QtWaylandClient::QWaylandWindow::waitForFrameSync (this=0x5561d9bfb600, timeout=<optimized out>) at qwaylandwindow.cpp:666
#7  0x00007fd9ac548dfa in QtWaylandClient::QWaylandGLContext::swapBuffers (this=0x5561dbf649c0, surface=<optimized out>) at ../../../../hardwareintegration/client/wayland-egl/qwaylandglcontext.cpp:501
#8  0x00007fd9b3b84b21 in QOpenGLContext::swapBuffers (this=0x5561da0cfc60, surface=<optimized out>) at kernel/qopenglcontext.cpp:1120
#9  0x00007fd9b51e929c in QSGRenderThread::syncAndRender (this=0x7fd9a4081cf0, grabImage=0x0) at scenegraph/qsgthreadedrenderloop.cpp:870
#10 0x00007fd9b51ed057 in QSGRenderThread::run (this=0x7fd9a4081cf0) at scenegraph/qsgthreadedrenderloop.cpp:1043
#11 0x00007fd9b3575543 in QThreadPrivate::start (arg=0x7fd9a4081cf0) at thread/qthread_unix.cpp:331
#12 0x00007fd9b3059609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#13 0x00007fd9b31f5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 13 (Thread 0x7fd95e3ca700 (LWP 28789)):
#0  0x00007fd9b31e8aff in __GI___poll (fds=0x7fd958005d20, nfds=1, timeout=3498959) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fd9b1a7d36e in g_main_context_poll (priority=<optimized out>, n_fds=1, fds=0x7fd958005d20, timeout=<optimized out>, context=0x7fd958000c20) at ../../../glib/gmain.c:4346
#2  g_main_context_iterate (context=context@entry=0x7fd958000c20, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4042
#3  0x00007fd9b1a7d4a3 in g_main_context_iteration (context=0x7fd958000c20, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#4  0x00007fd9b37b69d2 in QEventDispatcherGlib::processEvents (this=0x7fd958000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#5  0x00007fd9b375ac7b in QEventLoop::exec (this=this@entry=0x7fd95e3c9ba0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#6  0x00007fd9b3574362 in QThread::exec (this=this@entry=0x5561d90d2da0) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#7  0x00007fd95e4aa07c in KCupsConnection::run (this=0x5561d90d2da0) at ./libkcups/KCupsConnection.cpp:289
#8  0x00007fd9b3575543 in QThreadPrivate::start (arg=0x5561d90d2da0) at thread/qthread_unix.cpp:331
#9  0x00007fd9b3059609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007fd9b31f5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 12 (Thread 0x7fd979db3700 (LWP 28778)):
#0  futex_abstimed_wait_cancelable (private=<optimized out>, abstime=0x7fd979db28d0, clockid=<optimized out>, expected=0, futex_word=0x5561d763ee80) at ../sysdeps/nptl/futex-internal.h:320
#1  __pthread_cond_wait_common (abstime=0x7fd979db28d0, clockid=<optimized out>, mutex=0x5561d763ee30, cond=0x5561d763ee58) at pthread_cond_wait.c:520
#2  __pthread_cond_timedwait (cond=0x5561d763ee58, mutex=0x5561d763ee30, abstime=0x7fd979db28d0) at pthread_cond_wait.c:665
#3  0x00007fd9b357b668 in QWaitConditionPrivate::wait_relative (this=0x5561d763ee30, deadline=...) at thread/qwaitcondition_unix.cpp:136
#4  QWaitConditionPrivate::wait (deadline=..., this=0x5561d763ee30) at thread/qwaitcondition_unix.cpp:144
#5  QWaitCondition::wait (this=this@entry=0x5561d75db0a0, mutex=mutex@entry=0x5561d75db098, deadline=...) at thread/qwaitcondition_unix.cpp:225
#6  0x00007fd9b15e406d in QtWaylandClient::QWaylandWindow::waitForFrameSync (this=0x5561d75db010, timeout=<optimized out>) at qwaylandwindow.cpp:666
#7  0x00007fd9ac548dfa in QtWaylandClient::QWaylandGLContext::swapBuffers (this=0x5561d91ed2e0, surface=<optimized out>) at ../../../../hardwareintegration/client/wayland-egl/qwaylandglcontext.cpp:501
#8  0x00007fd9b3b84b21 in QOpenGLContext::swapBuffers (this=0x5561d7431560, surface=<optimized out>) at kernel/qopenglcontext.cpp:1120
#9  0x00007fd9b51e929c in QSGRenderThread::syncAndRender (this=0x5561d91ed650, grabImage=0x0) at scenegraph/qsgthreadedrenderloop.cpp:870
#10 0x00007fd9b51ed057 in QSGRenderThread::run (this=0x5561d91ed650) at scenegraph/qsgthreadedrenderloop.cpp:1043
#11 0x00007fd9b3575543 in QThreadPrivate::start (arg=0x5561d91ed650) at thread/qthread_unix.cpp:331
#12 0x00007fd9b3059609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#13 0x00007fd9b31f5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 11 (Thread 0x7fd9989cb700 (LWP 28770)):
#0  0x00007fd9b31e8aff in __GI___poll (fds=0x7fd980013d00, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fd9b1a7d36e in g_main_context_poll (priority=<optimized out>, n_fds=1, fds=0x7fd980013d00, timeout=<optimized out>, context=0x7fd9800051f0) at ../../../glib/gmain.c:4346
#2  g_main_context_iterate (context=context@entry=0x7fd9800051f0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4042
#3  0x00007fd9b1a7d4a3 in g_main_context_iteration (context=0x7fd9800051f0, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#4  0x00007fd9b37b69d2 in QEventDispatcherGlib::processEvents (this=0x7fd980005df0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#5  0x00007fd9b375ac7b in QEventLoop::exec (this=this@entry=0x7fd9989caba0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#6  0x00007fd9b3574362 in QThread::exec (this=this@entry=0x5561d9116ea0) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#7  0x00007fd9b51273fa in QQuickPixmapReader::run (this=0x5561d9116ea0) at util/qquickpixmapcache.cpp:1024
#8  0x00007fd9b3575543 in QThreadPrivate::start (arg=0x5561d9116ea0) at thread/qthread_unix.cpp:331
#9  0x00007fd9b3059609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007fd9b31f5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 10 (Thread 0x7fd99bbf5700 (LWP 28745)):
#0  0x00007fd9b31e8aff in __GI___poll (fds=0x7fd97c004e60, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fd9b1a7d36e in g_main_context_poll (priority=<optimized out>, n_fds=1, fds=0x7fd97c004e60, timeout=<optimized out>, context=0x7fd97c000c20) at ../../../glib/gmain.c:4346
#2  g_main_context_iterate (context=context@entry=0x7fd97c000c20, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4042
#3  0x00007fd9b1a7d4a3 in g_main_context_iteration (context=0x7fd97c000c20, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#4  0x00007fd9b37b69d2 in QEventDispatcherGlib::processEvents (this=0x7fd97c000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#5  0x00007fd9b375ac7b in QEventLoop::exec (this=this@entry=0x7fd99bbf4be0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#6  0x00007fd9b3574362 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#7  0x00007fd9b3575543 in QThreadPrivate::start (arg=0x5561d73a3520) at thread/qthread_unix.cpp:331
#8  0x00007fd9b3059609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#9  0x00007fd9b31f5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 9 (Thread 0x7fd99d132700 (LWP 28716)):
#0  0x00007fd9b31e8aff in __GI___poll (fds=0x7fd988004e60, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fd9b1a7d36e in g_main_context_poll (priority=<optimized out>, n_fds=1, fds=0x7fd988004e60, timeout=<optimized out>, context=0x7fd988000c20) at ../../../glib/gmain.c:4346
#2  g_main_context_iterate (context=context@entry=0x7fd988000c20, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4042
#3  0x00007fd9b1a7d4a3 in g_main_context_iteration (context=0x7fd988000c20, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#4  0x00007fd9b37b69d2 in QEventDispatcherGlib::processEvents (this=0x7fd988000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#5  0x00007fd9b375ac7b in QEventLoop::exec (this=this@entry=0x7fd99d131bc0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#6  0x00007fd9b3574362 in QThread::exec (this=this@entry=0x5561d71cd2b0) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#7  0x00007fd9b4d8d559 in QQmlThreadPrivate::run (this=0x5561d71cd2b0) at qml/ftw/qqmlthread.cpp:155
#8  0x00007fd9b3575543 in QThreadPrivate::start (arg=0x5561d71cd2b0) at thread/qthread_unix.cpp:331
#9  0x00007fd9b3059609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007fd9b31f5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 8 (Thread 0x7fd99d97b700 (LWP 28628)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5561d7016a08) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5561d70169b8, cond=0x5561d70169e0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5561d70169e0, mutex=0x5561d70169b8) at pthread_cond_wait.c:647
#3  0x00007fd99f34cb1b in cnd_wait (mtx=0x5561d70169b8, cond=0x5561d70169e0) at ../include/c11/threads_posix.h:155
#4  util_queue_thread_func (input=input@entry=0x5561d7017e20) at ../src/util/u_queue.c:294
#5  0x00007fd99f34c71b in impl_thrd_routine (p=<optimized out>) at ../include/c11/threads_posix.h:87
#6  0x00007fd9b3059609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#7  0x00007fd9b31f5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 7 (Thread 0x7fd99e17c700 (LWP 28627)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5561d7016a08) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5561d70169b8, cond=0x5561d70169e0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5561d70169e0, mutex=0x5561d70169b8) at pthread_cond_wait.c:647
#3  0x00007fd99f34cb1b in cnd_wait (mtx=0x5561d70169b8, cond=0x5561d70169e0) at ../include/c11/threads_posix.h:155
#4  util_queue_thread_func (input=input@entry=0x5561d7017de0) at ../src/util/u_queue.c:294
#5  0x00007fd99f34c71b in impl_thrd_routine (p=<optimized out>) at ../include/c11/threads_posix.h:87
#6  0x00007fd9b3059609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#7  0x00007fd9b31f5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7fd99e97d700 (LWP 28626)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5561d7016a08) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5561d70169b8, cond=0x5561d70169e0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5561d70169e0, mutex=0x5561d70169b8) at pthread_cond_wait.c:647
#3  0x00007fd99f34cb1b in cnd_wait (mtx=0x5561d70169b8, cond=0x5561d70169e0) at ../include/c11/threads_posix.h:155
#4  util_queue_thread_func (input=input@entry=0x5561d7017da0) at ../src/util/u_queue.c:294
#5  0x00007fd99f34c71b in impl_thrd_routine (p=<optimized out>) at ../include/c11/threads_posix.h:87
#6  0x00007fd9b3059609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#7  0x00007fd9b31f5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7fd99f17e700 (LWP 28625)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5561d7016a08) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5561d70169b8, cond=0x5561d70169e0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5561d70169e0, mutex=0x5561d70169b8) at pthread_cond_wait.c:647
#3  0x00007fd99f34cb1b in cnd_wait (mtx=0x5561d70169b8, cond=0x5561d70169e0) at ../include/c11/threads_posix.h:155
#4  util_queue_thread_func (input=input@entry=0x5561d7017b60) at ../src/util/u_queue.c:294
#5  0x00007fd99f34c71b in impl_thrd_routine (p=<optimized out>) at ../include/c11/threads_posix.h:87
#6  0x00007fd9b3059609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#7  0x00007fd9b31f5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7fd9ad7f9700 (LWP 28587)):
#0  0x00007fd9b31e8aff in __GI___poll (fds=0x7fd9a4004a60, nfds=3, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fd9b1a7d36e in g_main_context_poll (priority=<optimized out>, n_fds=3, fds=0x7fd9a4004a60, timeout=<optimized out>, context=0x7fd9a4000c20) at ../../../glib/gmain.c:4346
#2  g_main_context_iterate (context=context@entry=0x7fd9a4000c20, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4042
#3  0x00007fd9b1a7d4a3 in g_main_context_iteration (context=0x7fd9a4000c20, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#4  0x00007fd9b37b69d2 in QEventDispatcherGlib::processEvents (this=0x7fd9a4000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#5  0x00007fd9b375ac7b in QEventLoop::exec (this=this@entry=0x7fd9ad7f8bb0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#6  0x00007fd9b3574362 in QThread::exec (this=this@entry=0x7fd9b416fd80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#7  0x00007fd9b40ebf4b in QDBusConnectionManager::run (this=0x7fd9b416fd80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:179
#8  0x00007fd9b3575543 in QThreadPrivate::start (arg=0x7fd9b416fd80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:331
#9  0x00007fd9b3059609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007fd9b31f5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7fd9adffa700 (LWP 28578)):
#0  0x00007fd9b31e8aff in __GI___poll (fds=fds@entry=0x7fd9adff9be0, nfds=nfds@entry=2, timeout=timeout@entry=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fd9b15dfa16 in poll (__timeout=-1, __nfds=2, __fds=0x7fd9adff9be0) at /usr/include/x86_64-linux-gnu/bits/poll2.h:46
#2  QtWaylandClient::EventThread::run (this=0x5561d6e20760) at qwaylanddisplay.cpp:208
#3  0x00007fd9b3575543 in QThreadPrivate::start (arg=0x5561d6e20760) at thread/qthread_unix.cpp:331
#4  0x00007fd9b3059609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#5  0x00007fd9b31f5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7fd9ae7fb700 (LWP 28577)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5561d6e0d694) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5561d6e0d640, cond=0x5561d6e0d668) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5561d6e0d668, mutex=0x5561d6e0d640) at pthread_cond_wait.c:647
#3  0x00007fd9b357b6db in QWaitConditionPrivate::wait (deadline=..., this=0x5561d6e0d640) at thread/qwaitcondition_unix.cpp:146
#4  QWaitCondition::wait (this=this@entry=0x5561d6e1df30, mutex=mutex@entry=0x5561d6e1df28, deadline=...) at thread/qwaitcondition_unix.cpp:225
#5  0x00007fd9b15df9bd in QtWaylandClient::EventThread::waitForReading (this=0x5561d6e1def0) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qdeadlinetimer.h:68
#6  QtWaylandClient::EventThread::run (this=0x5561d6e1def0) at qwaylanddisplay.cpp:206
#7  0x00007fd9b3575543 in QThreadPrivate::start (arg=0x5561d6e1def0) at thread/qthread_unix.cpp:331
#8  0x00007fd9b3059609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#9  0x00007fd9b31f5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7fd9af3364c0 (LWP 28567)):
#0  ComicApplet::slotGoJump (this=0x5561d7391c40) at ./applets/comic/comic.cpp:401
#1  0x00007fd9b379319e in QtPrivate::QSlotObjectBase::call (a=0x7fff9948c8b0, r=0x5561d7391c40, this=0x5561d7475400) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#2  doActivate<false> (sender=0x5561d7475520, signal_index=4, argv=0x7fff9948c8b0) at kernel/qobject.cpp:3886
#3  0x00007fd9b378c567 in QMetaObject::activate (sender=sender@entry=0x5561d7475520, m=m@entry=0x7fd9b49841c0 <QAction::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7fff9948c8b0) at kernel/qobject.cpp:3946
#4  0x00007fd9b446b8e6 in QAction::triggered (this=this@entry=0x5561d7475520, _t1=<optimized out>) at .moc/moc_qaction.cpp:376
#5  0x00007fd9b446dfb8 in QAction::activate (this=0x5561d7475520, event=<optimized out>) at kernel/qaction.cpp:1161
#6  0x00007fd9b45f8bc2 in QMenuPrivate::activateCausedStack (this=this@entry=0x5561df64d3b0, causedStack=..., action=action@entry=0x5561d7475520, action_e=action_e@entry=QAction::Trigger, self=self@entry=true) at widgets/qmenu.cpp:1384
#7  0x00007fd9b460030e in QMenuPrivate::activateAction (this=this@entry=0x5561df64d3b0, action=action@entry=0x5561d7475520, action_e=action_e@entry=QAction::Trigger, self=self@entry=true) at widgets/qmenu.cpp:1461
#8  0x00007fd9b46015a2 in QMenu::mouseReleaseEvent (this=0x5561d7b0e770, e=0x7fff9948cf90) at widgets/qmenu.cpp:2967
#9  0x00007fd9b44b4cf6 in QWidget::event (this=this@entry=0x5561d7b0e770, event=event@entry=0x7fff9948cf90) at kernel/qwidget.cpp:8664
#10 0x00007fd9b4603bab in QMenu::event (this=0x5561d7b0e770, e=0x7fff9948cf90) at widgets/qmenu.cpp:3089
#11 0x00007fd9b4471dc3 in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x5561d7b0e770, e=0x7fff9948cf90) at kernel/qapplication.cpp:3632
#12 0x00007fd9b447ae77 in QApplication::notify(QObject*, QEvent*) () at kernel/qapplication.cpp:3076
#13 0x00007fd9b375c17a in QCoreApplication::notifyInternal2 (receiver=0x5561d7b0e770, event=0x7fff9948cf90) at ../../include/QtCore/5.15.3/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:332
#14 0x00007fd9b447a0a7 in QApplicationPrivate::sendMouseEvent (receiver=0x5561d7b0e770, event=event@entry=0x7fff9948cf90, alienWidget=0x0, nativeWidget=0x5561d7b0e770, buttonDown=<optimized out>, lastMouseReceiver=..., spontaneous=true, onlyDispatchEnterLeave=false) at kernel/qapplication.cpp:2614
#15 0x00007fd9b44d096e in QWidgetWindow::handleMouseEvent (this=0x5561da9570e0, event=0x7fff9948d410) at /usr/include/c++/9/bits/atomic_base.h:413
#16 0x00007fd9b44d31f4 in QWidgetWindow::event (event=0x7fff9948d410, this=0x5561da9570e0) at kernel/qwidgetwindow.cpp:300
#17 QWidgetWindow::event (this=0x5561da9570e0, event=0x7fff9948d410) at kernel/qwidgetwindow.cpp:239
#18 0x00007fd9b4471dc3 in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x5561da9570e0, e=0x7fff9948d410) at kernel/qapplication.cpp:3632
#19 0x00007fd9b447abb8 in QApplication::notify(QObject*, QEvent*) () at kernel/qapplication.cpp:3156
#20 0x00007fd9b375c17a in QCoreApplication::notifyInternal2 (receiver=0x5561da9570e0, event=0x7fff9948d410) at ../../include/QtCore/5.15.3/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:332
#21 0x00007fd9b3b424d8 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) () at kernel/qguiapplication.cpp:2282
#22 0x00007fd9b3b43b45 in QGuiApplicationPrivate::processWindowSystemEvent (e=0x7fd9a000ab20) at kernel/qguiapplication.cpp:2002
#23 0x00007fd9b3b1b7ac in QWindowSystemInterface::sendWindowSystemEvents (flags=...) at kernel/qwindowsysteminterface.cpp:1169
#24 0x00007fd9b161ed44 in userEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib/x86_64-linux-gnu/libQt5WaylandClient.so.5
#25 0x00007fd9b1a7d17d in g_main_dispatch (context=0x5561d6e24d50) at ../../../glib/gmain.c:3309
#26 g_main_context_dispatch (context=context@entry=0x5561d6e24d50) at ../../../glib/gmain.c:3974
#27 0x00007fd9b1a7d400 in g_main_context_iterate (context=context@entry=0x5561d6e24d50, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4047
#28 0x00007fd9b1a7d4a3 in g_main_context_iteration (context=0x5561d6e24d50, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#29 0x00007fd9b37b69d2 in QEventDispatcherGlib::processEvents (this=0x5561d6e21b90, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#30 0x00007fd9b375ac7b in QEventLoop::exec (this=this@entry=0x7fff9948d7b0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#31 0x00007fd9b3762e24 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#32 0x00005561d5a80db5 in main (argc=<optimized out>, argv=<optimized out>) at ./shell/main.cpp:238
Detaching from program: /usr/bin/plasmashell, process 28567
[Inferior 1 (process 28567) detached]
Comment 3 Nicolas Fella 2022-07-20 12:57:39 UTC
*** Bug 416195 has been marked as a duplicate of this bug. ***
Comment 4 Nicolas Fella 2022-07-20 12:58:20 UTC
*** Bug 456940 has been marked as a duplicate of this bug. ***
Comment 5 Bug Janitor Service 2022-07-20 13:00:18 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/kdeplasma-addons/-/merge_requests/194
Comment 6 Nate Graham 2022-07-20 13:25:52 UTC
*** Bug 435976 has been marked as a duplicate of this bug. ***
Comment 7 Nicolas Fella 2022-07-20 15:02:38 UTC
Git commit 6a0aec81074135c210a2ed11127ef9cfb138dbca by Nicolas Fella.
Committed on 20/07/2022 at 13:00.
Pushed by nicolasfella into branch 'master'.

[applets/comic] Disable most context menu actions when comic is not ready

This can be either because the loading failed or is not done yet

In those cases the actions don't make sense and can lead to crashes

M  +3    -0    applets/comic/comic.cpp
M  +1    -0    applets/comic/comicdata.cpp
M  +6    -0    applets/comic/comicdata.h

https://invent.kde.org/plasma/kdeplasma-addons/commit/6a0aec81074135c210a2ed11127ef9cfb138dbca
Comment 8 Nicolas Fella 2022-07-20 15:03:34 UTC
Git commit 8ef610fb4ea2a5d45dbb573ac48adc569a1a5d21 by Nicolas Fella.
Committed on 20/07/2022 at 15:03.
Pushed by nicolasfella into branch 'Plasma/5.25'.

[applets/comic] Disable most context menu actions when comic is not ready

This can be either because the loading failed or is not done yet

In those cases the actions don't make sense and can lead to crashes
(cherry picked from commit 6a0aec81074135c210a2ed11127ef9cfb138dbca)

M  +3    -0    applets/comic/comic.cpp
M  +1    -0    applets/comic/comicdata.cpp
M  +6    -0    applets/comic/comicdata.h

https://invent.kde.org/plasma/kdeplasma-addons/commit/8ef610fb4ea2a5d45dbb573ac48adc569a1a5d21
Comment 9 Nicolas Fella 2022-07-20 15:04:53 UTC
Git commit 352ecf9aa151e842f5304b8f4dc1fa7c7689b32f by Nicolas Fella.
Committed on 20/07/2022 at 15:04.
Pushed by nicolasfella into branch 'Plasma/5.24'.

[applets/comic] Disable most context menu actions when comic is not ready

This can be either because the loading failed or is not done yet

In those cases the actions don't make sense and can lead to crashes
(cherry picked from commit 6a0aec81074135c210a2ed11127ef9cfb138dbca)

M  +3    -0    applets/comic/comic.cpp
M  +1    -0    applets/comic/comicdata.cpp
M  +6    -0    applets/comic/comicdata.h

https://invent.kde.org/plasma/kdeplasma-addons/commit/352ecf9aa151e842f5304b8f4dc1fa7c7689b32f
Comment 10 Nicolas Fella 2022-07-24 12:23:56 UTC
*** Bug 457062 has been marked as a duplicate of this bug. ***