Bug 406882 - Popup plasmoids flicker and disappear when a remote application (via X2Go) is in focus
Summary: Popup plasmoids flicker and disappear when a remote application (via X2Go) is...
Status: RESOLVED WORKSFORME
Alias: None
Product: plasmashell
Classification: Unclassified
Component: general (show other bugs)
Version: 5.12.8
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-25 08:59 UTC by Tristan Miller
Modified: 2021-03-23 09:09 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Video showing bug (77.83 KB, video/x-matroska)
2019-04-25 08:59 UTC, Tristan Miller
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tristan Miller 2019-04-25 08:59:56 UTC
Created attachment 119625 [details]
Video showing bug

SUMMARY

I use X2Go to run applications remotely and have them appear on my local Plasma desktop.  When such a remote application window has focus, it prevents me from opening most pop-up plasmoids on my local machine.  The plasmoids flicker and then disappear.

STEPS TO REPRODUCE
1. Use X2Go to launch a single application remotely.
2. Give the remote application focus (for example, by Alt-Tabbing to it or clicking on it).
3. Do some action that causes a local plasmoid window to pop up.  For example, click on the Application Launcher to try to show the application list, or click on the Digital Clock to try to show the calendar, or click on a group entry in the Task Manager to try to show the list of windows, or press Alt+F2 to try to bring up KRunner.

OBSERVED RESULT

4. The popup window appears for a few milliseconds and then disappears.

EXPECTED RESULT

4. The popup window should appear and then persist.

SOFTWARE/OS VERSIONS
KDE Plasma Version: 5.12.8
KDE Frameworks Version: 5.45.0
Qt Version: 5.9.4
OS: openSUSE Leap 15.0
x2goclient: 4.1.1.1

ADDITIONAL INFORMATION

The attached video shows the bug.  It shows a portion of my Plasma panel that includes the Application Launcher, the Pager, and part of the Task Manager.  Claws Mail is running remotely via X2Go and one of its composer windows has focus.  I am clicking repeatedly on the Application Launcher.  You can see the pop-up window briefly flickering and disappearing.

As far as I can tell, the problem happens only when an application run via X2Go has focus.  The problem is not reproducible with applications run remotely via plain SSH.  Not sure if this is a KDE/Plasma problem or an X2Go problem.
Comment 1 Tristan Miller 2019-04-25 09:18:32 UTC
In case this is a problem with X2Go, I have reported it also on the X2Go issue tracker: https://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=1386
Comment 2 Marco Martin 2021-03-10 11:50:57 UTC
can it be somewhat related to #407024 ?
Comment 3 Nate Graham 2021-03-20 01:45:03 UTC
If you pin open a popup that's pinnable (e.g. the System Tray or Digital Clock popups) does it stay open when you run the X2Go-streamed app?
Comment 4 Tristan Miller 2021-03-23 09:09:47 UTC
The problem is no longer reproducible for me.  I'm now using the following:

KDE Plasma Version: 5.21.1
KDE Frameworks Version: 5.79.0
Qt Version: 5.15.2
OS: openSUSE Tumbleweed
x2goclient: 4.1.2.3~git21+ga1a2f62