Bug 406844 - Track composition does not work correctly
Summary: Track composition does not work correctly
Status: RESOLVED FIXED
Alias: None
Product: kdenlive
Classification: Unclassified
Component: User Interface (show other bugs)
Version: 19.04.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Jean-Baptiste Mardelle
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-24 12:21 UTC by rafamar.mm.ig
Modified: 2020-07-14 17:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 20.08.0
fritzibaby: Brainstorm+


Attachments
The resulting view with the order of the clues should always be the one in the second block, which does not have effects or transitions (14.03 KB, application/x-kdenlive)
2019-04-24 12:21 UTC, rafamar.mm.ig
Details
comma point error (14.89 KB, image/png)
2019-04-24 19:08 UTC, emohr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rafamar.mm.ig 2019-04-24 12:21:34 UTC
Created attachment 119604 [details]
The resulting view with the order of the clues should always be the one in the second block, which does not have effects or transitions

SUMMARY
When I change from high quality to none I do not obtain the correct result and to be able to return to the high quality state I must restart the application. The order of the tracks is not respected. The error becomes more noticeable when 3 or more tracks are used.

STEPS TO REPRODUCE
1. Create a project with 3 or more title clips placed one on each track one on top of the other
2. Insert the transition of composing + transforming
3. Put the composition on none Shit !!!!

OBSERVED RESULT
An erroneous result, the effects of composition are ignored and above you can only see the track below

EXPECTED RESULT
At least the one that corresponds and works perfectly in previous versions, tested in 17.04.3 and in 18.12.1

SOFTWARE/OS VERSIONS
Linux Mint 18.3
Linux MInt 19
Ubuntu 18.04
Ubuntu 16.04
all 64-bit

ADDITIONAL INFORMATION
Create a project with 3 or more title clips placed one on each track on top of another and try to export this with alpha channel. This in versions like 18.12.1 works perfectly, here is a way to go crazy and hate the application.
Comment 1 emohr 2019-04-24 19:08:50 UTC
Created attachment 119617 [details]
comma point error

Thank you for reporting the issue. 

When I load your project file I get the comma point error. 

Issue https://invent.kde.org/kde/kdenlive/issues/78 is opened for that with effect as well.

The root cause is not found so far.
Comment 2 rafamar.mm.ig 2019-04-25 20:40:46 UTC
(In reply to emohr from comment #1)
> Created attachment 119617 [details]
> comma point error
> 
> Thank you for reporting the issue. 
> 
> When I load your project file I get the comma point error. 
> 
> Issue https://invent.kde.org/kde/kdenlive/issues/78 is opened for that with
> effect as well.
> 
> The root cause is not found so far.

My knowledge of programming is very basic, I am an audiovisual technician, professionally I do not use kdenlive, but I was asked to do a series of tutorials in Spanish about a free application that works in gnu / linux and try several options to choose kdenlive ... but this new version does not respond as it should and suffers from many sudden closures. I will continue using the 17.04 or 18.12 that although they also have many errors more or less you can work with them, but the 19.04 no doubt is not yet ready to recommend it to end users.

At the moment, the only thing I liked about the new version is the possibility of simply inverting or changing the speed of a clip. However the new distribution of effects I do not like anything, was much more effective and intuitive than previous versions.
Comment 3 emohr 2020-07-14 17:52:46 UTC
Comma point issue is fixed with version 20.08.0.