Bug 406806 - Folder View widget is not an icon on vertical panels
Summary: Folder View widget is not an icon on vertical panels
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Folder (show other bugs)
Version: master
Platform: OpenSUSE Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-23 10:43 UTC by Noah Davis
Modified: 2021-01-07 16:50 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.18.7


Attachments
Folder View on a vertical panel (169.61 KB, image/png)
2019-04-23 10:43 UTC, Noah Davis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Noah Davis 2019-04-23 10:43:46 UTC
Created attachment 119585 [details]
Folder View on a vertical panel

SUMMARY
The folder view widget is not an icon on vertical panels like it is on horizontal panels. This makes it unusable on vertical panels.

STEPS TO REPRODUCE
1. Create a vertical panel
2. Add a Folder View widget to it

OBSERVED RESULT
Rather than being an icon, Folder View shows a list of files and folders in the space of the vertical panel.

EXPECTED RESULT
The Folder View should be an icon on the panel that pops out a list of files and folders when opened.

SOFTWARE/OS VERSIONS
Linux Kernel:  5.0.8
KDE Plasma Version: 5.15.80 (git master)
KDE Frameworks Version: 5.58 (git master)
Qt Version: 5.12.3
Comment 1 Kai Uwe Broulik 2019-04-23 10:52:33 UTC
It's supposed to be a list in vertical panels but the minimum size seems broken/way too small.
Comment 2 Nate Graham 2019-11-05 18:24:15 UTC
*** Bug 364410 has been marked as a duplicate of this bug. ***
Comment 3 Aldoo 2020-05-15 09:44:08 UTC
There is clearly some issue with automatic choice of mode between icon and list.
Notwithstanding, adding a simple checkbox, in the widget settings, to let the user choose would solve many problems. Even in cases where there is room for a list view, some users may prefer a simple icon anyway.
Comment 4 Bug Janitor Service 2020-12-23 20:53:18 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/278
Comment 5 Nate Graham 2021-01-07 16:45:37 UTC
Git commit 607675367baab275c2faab255ca85df0b9a5e3f1 by Nate Graham.
Committed on 07/01/2021 at 16:45.
Pushed by ngraham into branch 'master'.

[folder view] Fix display on not-skinny vertical panels

Folder view has some logic to switch between its compact and full
representations for vertical panels, but it is faulty, and causes the
switch to happen at approximately 50px width. At this width, the display
is completely unusable as the text is elided away into nothingness.

This commit remedies the situation by imposing a more sane minimum width
based on gridUnit. With the default 10pt font, the minimum thickness is
now 144px, which leaves enough room for the labels to be at least
partially visible. At lower panel widths, the applet displays its compact
representation.
FIXED-IN: 5.18.7

M  +2    -2    containments/desktop/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-desktop/commit/607675367baab275c2faab255ca85df0b9a5e3f1
Comment 6 Nate Graham 2021-01-07 16:50:08 UTC
Git commit dec75f0da52562b719b4d259b9061a3665b6c16b by Nate Graham.
Committed on 07/01/2021 at 16:49.
Pushed by ngraham into branch 'Plasma/5.18'.

[folder view] Fix display on not-skinny vertical panels

Folder view has some logic to switch between its compact and full
representations for vertical panels, but it is faulty, and causes the
switch to happen at approximately 50px width. At this width, the display
is completely unusable as the text is elided away into nothingness.

This commit remedies the situation by imposing a more sane minimum width
based on gridUnit. With the default 10pt font, the minimum thickness is
now 144px, which leaves enough room for the labels to be at least
partially visible. At lower panel widths, the applet displays its compact
representation.
FIXED-IN: 5.18.7

M  +2    -2    containments/desktop/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-desktop/commit/dec75f0da52562b719b4d259b9061a3665b6c16b