Bug 406756 - Update KDE Apps 19.04 announcement to link to Flathub as well
Summary: Update KDE Apps 19.04 announcement to link to Flathub as well
Status: RESOLVED INTENTIONAL
Alias: None
Product: www.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-22 10:17 UTC by markuss
Modified: 2019-04-23 02:20 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description markuss 2019-04-22 10:17:40 UTC
KDE Applications 19.04 announcement only links to Canonical's proprietary Snap Store despite the fact that 19.04 applications are also available from Flathub.

https://www.flathub.org/assets/themes/flathub/flathub-logo-toolbar.svg is the necessary graphic.
Comment 1 Albert Astals Cid 2019-04-22 10:42:09 UTC
I guess we could like to https://flathub.org/apps/search/org.kde ?

It's not really great though...
Comment 2 markuss 2019-04-22 10:53:31 UTC
So what. The Snap box links to https://snapcraft.io/search?q=kde
Comment 3 Albert Astals Cid 2019-04-22 11:17:31 UTC
> So what.

Let's not be aggressive, ok? I'm *not* disagreeing with you

> The Snap box links to https://snapcraft.io/search?q=kde

The weird part is that the image links to https://snapcraft.io/publisher/kde which is defenitely much nicer i've no idea why the text links to the search page that i agree is also quite ugly and doesn't guarantee whatever is there is actually made by us.
Comment 4 Jonathan Riddell 2019-04-22 11:42:32 UTC
The discussion for this happened here on the kde promo phab task
https://phabricator.kde.org/T10636

Snaps has 50+ snaps from KDE Applications updated and available on release day.  The snap store team made a publisher page https://snapcraft.io/publisher/kde although alas because of translation deadlines only 1 of the two links could be updated to that on the announce.

It would be great to add similar links for Flatpaks and Appimages.   In the discussion on Phabricator you can see we looked for the same thing in Flatpaks and Appstream and couldn't find it.  There's no version numers on he flathub packages so it's unclear if they are updated or not.  This may be caused by appstream not including the version number which is a political decision being discussed here https://phabricator.kde.org/T10812  The page is a generic search string and so not too reliable for finding the KDE apps, it would be better to have a dedicated page for the KDE project.
Comment 5 markuss 2019-04-22 12:27:00 UTC
(In reply to Jonathan Riddell from comment #4)
> There's no version numers on he flathub packages so it's unclear if they are updated or not.

Commits on Github are very clear on that.

Closed as intentional. This was you chance to disprove that you're giving preferential treatment to Canonical's proprietary store. You didn't take you chance. Says enough…
Comment 6 Jonathan Riddell 2019-04-22 12:40:03 UTC
(In reply to kmi from comment #5)
> (In reply to Jonathan Riddell from comment #4)
> > There's no version numers on he flathub packages so it's unclear if they are updated or not.
> 
> Commits on Github are very clear on that.
> 
> Closed as intentional. This was you chance to disprove that you're giving
> preferential treatment to Canonical's proprietary store. You didn't take you
> chance. Says enough…

You seem to have a pre-conceived opinion and are looking for reinforce that.  

Let me say again: we wanted to include Flatpaks, we looked at how to do that, we did not find any way.  

Neither me nor the users who will install this software will know how to search through github for whatever is needed.

It is now too late to include it as the announcement was written over a week ago and has been translated and published.

We would love to include flathub in future announcements.

Note the proprietary nature of the store is largely irrelevant, we work with several centralised and proprietary stores.  I am unaware of the licence or development model of flathub.
Comment 7 markuss 2019-04-22 15:46:51 UTC
(In reply to Jonathan Riddell from comment #6)


> Neither me nor the users who will install this software will know how to
> search through github for whatever is needed.

You're unable to look up e.g. https://github.com/flathub/org.kde.okular/commits/master ? Seriously?
Well, you've got the info now. Correct your mistake, please.


> It is now too late to include it as the announcement was written over a week
> ago and has been translated and published.

No, it's not too late.


> Note the proprietary nature of the store is largely irrelevant

https://manifesto.kde.org/ happens do disagree with you.


> I am unaware of the licence or development model of flathub.

And yet you claim to care for Snap and Flatpak equally?
Flathub is 100% Free Software, therefore 100% aligned with KDE ideals.
It should get prioritized treatment over any proprietary alternative.

The announcement links to https://snapcraft.io/search?q=kde. Linking https://flathub.org/apps/search/org.kde as well is the very least KDE should do.
Comment 8 Jonathan Riddell 2019-04-22 15:49:24 UTC
I look forward to you helping out with future announcements
Comment 9 markuss 2019-04-22 15:59:34 UTC
(In reply to Jonathan Riddell from comment #8)
> I look forward to you helping out with future announcements

Fix this one first.
Comment 10 Jonathan Riddell 2019-04-22 16:07:16 UTC
As discussed, the announcement has now been published.
Comment 11 Albert Astals Cid 2019-04-22 22:27:57 UTC
> In the discussion on Phabricator you can see we looked for the same thing in Flatpaks and Appstream and couldn't find it.  

Did you ask the flathub people about it? Did you ask any of KDE people involved with flatpak packaging? I mean i found https://flathub.org/apps/search/org.kde which is similar to the snaps page that is being linked in 5 minutes

> There's no version numers on he flathub packages so it's unclear if they are updated or not.

Did you ask any of KDE people involved with flatpak packaging? If you asked me i'd told you that i was planning to update the packages on release day as i did.

>  The page is a generic search string and so not too reliable for finding the KDE apps

Well, i kind of doubt that anyone that is not kde has an org.kde. namespace, but sure may happen, but as said, it's not worse than the other page linked for snap.

> it would be better to have a dedicated page for the KDE project.

Agreed, it would did you contact the flathub people as you contacted the snap people to get that page created?
Comment 12 Albert Astals Cid 2019-04-22 22:29:33 UTC
> Let me say again: we wanted to include Flatpaks, we looked at how to do that, we did not find any way.  

As mentioned in the other comment, it doesn't look like you looked hard enough to be honest. 

> Neither me nor the users who will install this software will know how to search through github for whatever is needed.

Why would user have to use github for whatever is needed? I don't understand what you want to say with this sentence
Comment 13 Albert Astals Cid 2019-04-22 22:31:24 UTC
> https://manifesto.kde.org/ happens do disagree with you.

Not really, manifesto is for things we do. Nowhere in there it says "KDE won't ever use non free software", if it said that we couldn't even do our taxes since german law kind-of-forces to use a non free software application for that.
Comment 14 Jonathan Riddell 2019-04-22 22:37:55 UTC
(In reply to Albert Astals Cid from comment #11)
> > In the discussion on Phabricator you can see we looked for the same thing in Flatpaks and Appstream and couldn't find it.  
> 
> Did you ask the flathub people about it? Did you ask any of KDE people
> involved with flatpak packaging?

https://phabricator.kde.org/T10636#179382
'flathub repo has a random selection of apps updated to a random version that someone remembered to update.'
Comment 15 Albert Astals Cid 2019-04-22 22:51:03 UTC
(In reply to Jonathan Riddell from comment #14)
> (In reply to Albert Astals Cid from comment #11)
> > > In the discussion on Phabricator you can see we looked for the same thing in Flatpaks and Appstream and couldn't find it.  
> > 
> > Did you ask the flathub people about it? Did you ask any of KDE people
> > involved with flatpak packaging?
> 
> https://phabricator.kde.org/T10636#179382
> 'flathub repo has a random selection of apps updated to a random version
> that someone remembered to update.'

He, that was a whole month ago, i since then decided to update them all, i guess it's my fault for having such a terrible memory.
Comment 16 Nate Graham 2019-04-23 02:20:21 UTC
 ---- On Mon, 22 Apr 2019 16:27:57 -0600 Albert Astals Cid <bugzilla_noreply@kde.org> wrote ----
 > > There's no version numers on he flathub packages so it's unclear if they are updated or not.
 > 
 > Did you ask any of KDE people involved with flatpak packaging? If you asked me
 > i'd told you that i was planning to update the packages on release day as i
 > did.

BTW, the reason for the lack of version numbers on Flathub is because they read the release key from the app's AppStream data. So we need to find some way to programmatically populate this information in each app's AppData file. See https://www.freedesktop.org/software/appstream/docs/chap-Metadata.html

Nate