Bug 406524 - Playlist display issue when removing first track of the playlist
Summary: Playlist display issue when removing first track of the playlist
Status: RESOLVED FIXED
Alias: None
Product: Elisa
Classification: Unclassified
Component: general (show other bugs)
Version: 0.4.2
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Matthieu Gallien
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2019-04-14 10:45 UTC by Jerome Guidon
Modified: 2020-01-27 05:08 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 19.12.2


Attachments
the first track is not visible (183.72 KB, image/png)
2019-04-14 10:45 UTC, Jerome Guidon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jerome Guidon 2019-04-14 10:45:51 UTC
Created attachment 119408 [details]
the first track is not visible

SUMMARY
When I remove the first track of the playlist, the new first track is not visible, like if the opacity of the row was 0.


STEPS TO REPRODUCE
1. Have some tracks in the playlist
2. remove the first track

OBSERVED RESULT
The new first track is not visible, like if the opacity of the row was 0. See the attachement after the action (the first track in the playlist)

EXPECTED RESULT
The first row in the playlist should look the same as the others below

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: Kde Neon
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 5.57.0
Qt Version: 5.12.0
Elisa Version : current master branch (April 2019)

ADDITIONAL INFORMATION
I discovered the issue while testing for another task (https://phabricator.kde.org/D19610 ). I could investigate a little bit and found the bug originated from the commit fc9736e1d124f40002d835890af82a6103a0c322 . I tried to figure out why the section caused the issue for I cannot explain it yet.

I will try to keep on looking but any help is welcomed :)
Comment 1 Matthieu Gallien 2019-04-14 13:42:57 UTC
I can reproduce the issue. I had not understood that the issue happened only with the first entry.
Comment 2 Matthieu Gallien 2020-01-22 21:13:17 UTC
Due to Qt bug https://bugreports.qt.io/browse/QTBUG-49868
Comment 3 Alexander Stippich 2020-01-26 20:17:01 UTC
Git commit 1691274e52b8a76f760bad1333746fde4f5973c7 by Alexander Stippich.
Committed on 26/01/2020 at 20:16.
Pushed by astippich into branch 'release/19.12'.

disable playlist animations to fix display corruption
Related: bug 398093

M  +5    -0    src/qml/PlayListBasicView.qml

https://invent.kde.org/kde/elisa/commit/1691274e52b8a76f760bad1333746fde4f5973c7