Bug 40647 - KMail: Unable to move mail into IMAP subfolders with filters
Summary: KMail: Unable to move mail into IMAP subfolders with filters
Status: CLOSED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.4
Platform: openSUSE Linux
: NOR wishlist with 141 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 51377 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-04-10 13:18 UTC by kde
Modified: 2007-09-14 12:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kde 2002-04-10 13:06:41 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           kmail
Version:           1.4 (using KDE 3.0.0 )
Severity:          wishlist
Installed from:    SuSE
Compiler:          gcc version 2.95.3 20010315 (SuSE)
OS:                Linux (i686) release 2.4.18-4GB
OS/Compiler notes: 

I have several subfolders on an IMAP server and I want to sort incoming mail into these folders. But I can only select top-level folders within the filter i.e. no subfolders on the IMAP-server.

(Submitted via bugs.kde.org)
(Called from KBugReport dialog)
Comment 1 Marc Mutz 2002-04-10 16:11:41 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Wednesday 10 April 2002 15:06 kde@huwig.de wrote:
<snip>
> I have several subfolders on an IMAP server and I want to sort incoming
> mail into these folders. But I can only select top-level folders within t=
he
> filter i.e. no subfolders on the IMAP-server.
<snip>

Use server-side filtering. Do you really want to download the whole message=
s=20
then upload them again then download them again for reading?

Marc

- --=20
Marc Mutz <mutz@kde.org>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE8tGQ93oWD+L2/6DgRAl+lAKCgo/tyHDP63t3vw3ClfVY0icHVWQCglWAc
+J+vEt/71d/eYk7qqvWVXFY=3D
=3DTOm6
-----END PGP SIGNATURE-----
Comment 2 Kurt Huwig 2002-04-10 16:24:50 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Am Mittwoch 10. April 2002 18:11 schrieb Marc Mutz:
> On Wednesday 10 April 2002 15:06 kde@huwig.de wrote:
> <snip>
>
> > I have several subfolders on an IMAP server and I want to sort incoming
> > mail into these folders. But I can only select top-level folders within
> > the filter i.e. no subfolders on the IMAP-server.
>
> <snip>
>
> Use server-side filtering. Do you really want to download the whole
> messages then upload them again then download them again for reading?

How do I set up server-side filtering with KMail? I never heard of this.

Kurt
- --=20
Kurt Huwig         iKu Netzwerkl=F6sungen   http://www.iku-netz.de/
Gesellschafter     Am R=F6merkastell 4      Telefon 0681/96751-0
kurt@iku-netz.de   66121 Saarbr=FCcken      Telefax 0681/96751-66
GnuPG  64B1 0C5B 82BC E16E 8940  EB6D 4C32 F908 99DD 9468
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE8tGdSTDL5CJndlGgRAv2CAJ9fcP1TJqUmhECEaCDDvpTUWPkJ0wCfUuLt
Wj852TaqZvCtlYxlE2tEHuE=3D
=3Di1+l
-----END PGP SIGNATURE-----
Comment 3 Marc Mutz 2002-04-10 17:36:36 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Wednesday 10 April 2002 18:24 Kurt Huwig wrote:
> Am Mittwoch 10. April 2002 18:11 schrieb Marc Mutz:
> > On Wednesday 10 April 2002 15:06 kde@huwig.de wrote:
> > <snip>
> >
> > > I have several subfolders on an IMAP server and I want to sort incomi=
ng
> > > mail into these folders. But I can only select top-level folders with=
in
> > > the filter i.e. no subfolders on the IMAP-server.
> >
> > <snip>
> >
> > Use server-side filtering. Do you really want to download the whole
> > messages then upload them again then download them again for reading?
>
> How do I set up server-side filtering with KMail? I never heard of this.

You can't. There's no standard for accessing the filter mechanism on the=20
server. It depends on the server. Some use Sieve scripts others use procma=
il=20
rules...

If there was a standard for accessing e.g. Sieve scripts on IMAP servers t=
hen=20
you could bet that the next version of KMail would have support for it ;-)

But currently only one server (Courier?) has defined a (proprietary) protoc=
ol=20
for that.

Marc

- --=20
Marc Mutz <mutz@kde.org>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE8tHgk3oWD+L2/6DgRAoQSAKD3JHSc2QRi+B7oOeZBFbZUJCUMRwCgzCsW
Q7Cy9P5zBpX2bJBB5sONKhE=3D
=3DzSmr
-----END PGP SIGNATURE-----
Comment 4 Kurt Huwig 2002-04-11 09:11:00 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Am Mittwoch 10. April 2002 19:36 schrieb Marc Mutz:
> On Wednesday 10 April 2002 18:24 Kurt Huwig wrote:
> > Am Mittwoch 10. April 2002 18:11 schrieb Marc Mutz:
> > > On Wednesday 10 April 2002 15:06 kde@huwig.de wrote:
> > > <snip>
> > >
> > > > I have several subfolders on an IMAP server and I want to sort
> > > > incoming mail into these folders. But I can only select top-level
> > > > folders within the filter i.e. no subfolders on the IMAP-server.
> > >
> > > <snip>
> > >
> > > Use server-side filtering. Do you really want to download the whole
> > > messages then upload them again then download them again for readin=
g?

AFAIK IMAP allows to move files on the server without downloading.

> > How do I set up server-side filtering with KMail? I never heard of this.
>
> You can't. There's no standard for accessing the filter mechanism on the
> server. It depends on the server. Some use Sieve scripts others use
> procmail rules...

So our users cannot set up server rules with KDE or KMail and KMail will n=
ot=20
support filters on IMAP servers. This is bad as we cannot use KMail without=
=20
mail filtering.

Kurt
- --=20
Kurt Huwig         iKu Netzwerkl=F6sungen   http://www.iku-netz.de/
Gesellschafter     Am R=F6merkastell 4      Telefon 0681/96751-0
kurt@iku-netz.de   66121 Saarbr=FCcken      Telefax 0681/96751-66
GnuPG  64B1 0C5B 82BC E16E 8940  EB6D 4C32 F908 99DD 9468
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE8tVMnTDL5CJndlGgRAu0eAKDeAFIbH5AO9DkRgvQuffqyeWcH3ACcCTZl
FhaO7Vtn+rWAuJfZAGtSxBA=3D
=3DLXe2
-----END PGP SIGNATURE-----
Comment 5 Marc Mutz 2002-04-11 10:00:47 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Thursday 11 April 2002 11:11 Kurt Huwig wrote:
<snip>
> AFAIK IMAP allows to move files on the server without downloading.

Ah yes. I forgot. And on what should we filter then?

<snip>
> > You can't. There's no standard for accessing the filter mechanism on the
> > server. It depends on the server. Some use Sieve scripts others use
> > procmail rules...
>
> So our users cannot set up server rules with KDE or KMail and KMail will
> not support filters on IMAP servers. This is bad as we cannot use KMail
> without mail filtering.
<snip>

Bug the IMAP server vendors not us. Without a standard filter language (Si=
eve=20
is there but without extensions it's a fairly poor langauge) _and_ a=20
standard access method for transferring and managing your Sieve script to t=
he=20
/ on the server there just isn't going to be a client implementation.

Also you simply have to look into the handbook of your IMAP server how=20
server-side filtering is implemented. You just can't use KMail to configure=
=20
the stuff.

Marc

- --=20
Marc Mutz <mutz@kde.org>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE8tV7P3oWD+L2/6DgRAo7eAKDdPKNhUDETru9tNCwy4vZ0qPsk2gCgw/YI
aJj2+UAkLTJBiFC6xQHOWhI=3D
=3DpBvR
-----END PGP SIGNATURE-----
Comment 6 Kurt Huwig 2002-04-11 10:12:57 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Am Donnerstag 11. April 2002 12:00 schrieb Marc Mutz:
> On Thursday 11 April 2002 11:11 Kurt Huwig wrote:
> <snip>
>
> > AFAIK IMAP allows to move files on the server without downloading.
>
> Ah yes. I forgot. And on what should we filter then?

I filter on message header e.g. Recipient or Header.

> > > You can't. There's no standard for accessing the filter mechanism on
> > > the server. It depends on the server. Some use Sieve scripts others
> > > use procmail rules...
> >
> > So our users cannot set up server rules with KDE or KMail and KMail wi=
ll
> > not support filters on IMAP servers. This is bad as we cannot use KMail
> > without mail filtering.
>
> Bug the IMAP server vendors not us. Without a standard filter language
> (Sieve is there but without extensions it's a fairly poor langauge) _and_
> a standard access method for transferring and managing your Sieve script =
to
> the / on the server there just isn't going to be a client implementation.
>
> Also you simply have to look into the handbook of your IMAP server how
> server-side filtering is implemented. You just can't use KMail to configu=
re
> the stuff.

I don't want you to implement this I just want to be able to filter mail i=
nto=20
subfolders whereever they are. As long as I cannot filter mail into=20
subfolders with KMail we will stay with Mozilla Messenger which supports th=
is=20
since I know this software. Maybe I should try to edit the configuration=20
files of KMail maybe it is already supported but only the GUI does not. BT=
W=20
I added a filter into a toplevel folder but it just works with CTRL-J and=
=20
not by default. I checked the 'Incoming folder' checkbox but it seems as IM=
AP=20
INBOXes do not belong to this.

Kurt
- --=20
Kurt Huwig         iKu Netzwerkl=F6sungen   http://www.iku-netz.de/
Gesellschafter     Am R=F6merkastell 4      Telefon 0681/96751-0
kurt@iku-netz.de   66121 Saarbr=FCcken      Telefax 0681/96751-66
GnuPG  64B1 0C5B 82BC E16E 8940  EB6D 4C32 F908 99DD 9468
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE8tWGpTDL5CJndlGgRAhGmAJ0fVS9nb0L4QPD+SUMikJXVRDjrAACgyGND
IGyoE9MCvOXzTTbeavkA8+w=3D
=3DOpLv
-----END PGP SIGNATURE-----
Comment 7 Volker Augustin 2002-04-11 10:17:07 UTC
> > > > Use server-side filtering. Do you really want to download the whole
> > > > messages then upload them again then download them again for
> > > > reading?
>
> AFAIK IMAP allows to move files on the server without downloading.

Yes of course but you wanted to filter the messages right? So either
you download filter and upload again or you filter and move on the
server.
While the first option could be implemented it wouldn't be a viable option
for most users since it would create a lot of traffic and you wouldn't want
that if you have to pay for it.

> > > How do I set up server-side filtering with KMail? I never heard of
> > > this.
> >
> > You can't. There's no standard for accessing the filter mechanism on the
> > server. It depends on the server. Some use Sieve scripts others use
> > procmail rules...
>
> So our users cannot set up server rules with KDE or KMail and KMail will
> not support filters on IMAP servers. This is bad as we cannot use KMail
> without mail filtering.

As we currently don't know of any standard way to access filter mechanisms
we simply can't implement something like that. If we knew you can be sure
that this feature would be implemented within days or weeks :-)) So if you
want to dig up information about that...

Of course this whole issue will be solved when KMail supports a local
message repository and synchronization. But that might take a while as
there are not so many KMail developers.

Maybe if you describe your setup in more detail someone can come up with
a possible work-around :-))

Greetings
Volker Augustin
Comment 8 Kurt Huwig 2002-04-11 10:36:43 UTC
Volker Augustin wrote:
>>>>>Use server-side filtering. Do you really want to download the whole
>>>>>messages then upload them again then download them again for
>>>>>reading?
>>>>
>>AFAIK IMAP allows to move files on the server without downloading.
> 
> 
> Yes of course but you wanted to filter the messages right? So either
> you download filter and upload again or you filter and move on the
> server.
> While the first option could be implemented it wouldn't be a viable option
> for most users since it would create a lot of traffic and you wouldn't want
> that if you have to pay for it.

IMHO IMAP is best suited for intranets and POP3 for internet. We have 
an internal IMAP server so traffic is not an issue.

>>>>How do I set up server-side filtering with KMail? I never heard of
>>>>this.
>>>
>>>You can't. There's no standard for accessing the filter mechanism on the
>>>server. It depends on the server. Some use Sieve scripts others use
>>>procmail rules...
>>
>>So our users cannot set up server rules with KDE or KMail and KMail will
>>not support filters on IMAP servers. This is bad as we cannot use KMail
>>without mail filtering.

[...]

> Maybe if you describe your setup in more detail someone can come up with
> a possible work-around :-))

12 workstations running SuSE 8.0 KDE 3 and one Cyrus IMAP server hooked 
up via 100Base-T switched.

Kurt--
Kurt Huwig         iKu Netzwerklösungen   http://www.iku-netz.de/
Gesellschafter     Am Römerkastell 4      Telefon 0681/96751-0
kurt@iku-netz.de   66121 Saarbrücken      Telefax 0681/96751-66
GnuPG  64B1 0C5B 82BC E16E 8940  EB6D 4C32 F908 99DD 9468
Comment 9 Marc Mutz 2002-04-11 16:32:38 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Thursday 11 April 2002 12:36 Kurt Huwig wrote:
<snip>
> > Maybe if you describe your setup in more detail someone can come up with
> > a possible work-around :-))
>
> 12 workstations running SuSE 8.0 KDE 3 and one Cyrus IMAP server hooked
> up via 100Base-T switched.
<snip>

Isn't Cyrus the ones who have that proprietary access protocol for Sieve 
scripts on the server? You may want to search the archive of the 
kmail@kde.org mailing list. IIRC there was one person who has implemented a 
KIOSlave for it and there was another one who wanted to write a Sieve editor 
on top of that.

Marc

- -- 
Marc Mutz <mutz@kde.org>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE8tbqm3oWD+L2/6DgRAo64AKCOQY5eS0HISFq6Ekjb2pA9mmPjcACfdQ9w
rQU+BfWAZW3vUvBJnq4MDeU=
=6Y80
-----END PGP SIGNATURE-----
Comment 10 Sean Jean 2002-12-01 01:27:04 UTC
 This is a feature that Ximian Evoltuion supports (as well as other MUAs) I 
would like to use it with KMail.  I currently use DBMail 
(http://www.dbmail.org) as my IMAP server and can create filters in Evolution 
and have the action move the messages from the INBOX of the IMAP account to 
sub-folders under my IMAP account.  I don't want anything fancy, just the 
ability for the filters to move the mail messages to the corresponding folder.  
So if the "move to folder" option including the list of folders from my IMAP 
server this would be great. 
Comment 11 kde 2002-12-01 03:28:42 UTC
This bug is marked as 'closed fixed' but it should be marked as 'closed
wontfix'. KMail and IMAP is just something that does not fit together. We are
using Mozilla here and everything is just fine.

I wanted to use KMail because of the good integration into our desktops, but it
is simply unusable with IMAP servers. My main concern was PGP integration, but
with Enigmail, I can do this with Mozilla, so no need for KMail any more.
Comment 12 Magnus von Koeller 2002-12-01 19:08:47 UTC
*** Bug 51377 has been marked as a duplicate of this bug. ***
Comment 13 Magnus von Koeller 2002-12-01 19:18:01 UTC
This bug is marked as 'CLOSED'-'FIXED' because it was imported into KDE's new 
bugzilla bug report system. When this bug report was closed, there was no way to mark 
it as 'WONTFIX', it could only be closed. During the import, all closed bug reports were 
simply imported as 'FIXED'. 
Comment 14 kde 2002-12-01 22:03:29 UTC
So what about implementing the feature? Marc was wrong when he said that moving
messages causes traffic. Besides this, IMAP's primary use is in intranets where
traffic is not an issue. As long as message filtering is missing, KMail is not
suitable as a MUA for a lot of people.
Comment 15 Sean Jean 2002-12-02 23:18:46 UTC
 For those that have connectivity to their IMAP servers via LANs, downloading 
the msg then uploading it again is not a problem.  This would would be very 
much appreciated if you allowed that functionality in the KMail filtering 
functionality.  Could you please reconsider this wishlist item, and at minimum 
allow the filter to do just that...download the msg, then upload the msg to 
the correct folder on the IMAP server based on the filtering rules. 
 
Your attention to this item is greatly appreciated. 
Comment 16 Dominik L. Borkowski 2003-01-28 16:26:24 UTC
So when I move e-mails between IMAP folders within Kmail, what happens? Judging by the  
speed, I could guess that the IMAP server takes care of the actual moving, and Kmail doesn't  
download those e-mails, then upload them.   
  
To make a point, I would love to see this feature implemented. I don't care to hit ctrl-j on a  
selected block of e-mails, as long as Kmail could move those e-mails. I don't mind traffic, etc.   
  
Thank you for your time  
Comment 17 Matthias Kleine 2003-02-03 17:43:09 UTC
I miss the discussed feature, too. This is a feature that is 
available in the Netscape 4.x Mail Client, i.e. NOT as 
a server side filter. 
 
If this is not possible in kmail, then IMAP usage in kmail 
is simply not possible for professional purposes. 
Comment 18 Paul Nicklin 2003-07-07 14:26:27 UTC
I'd like to see this featue too, even if it restricted filters on "header" 
fields rather than the body, or restricted the move imap-imap or local-local.

Seems half the job is done anyway as I can filter mail in the IMAP server 
folders and it moves to the local folder

My setup is much as described above, central server running (courier in my case) 
mail clients (kmail) doing evertything with the IMAP server, everything stays on 
IMAP so that the webmail system (squirrell mail) can see it- I don't want to 
have to filter to local folders because it will disappear from webmail.

Does anybody read this stuff against closed Bugs?


But why are we arguing whether we should do it?, it's open source, I can do C++, 
maybe this is my opportunity to scratch the itch...! 
Comment 19 Kaj Kandler 2003-10-21 20:41:38 UTC
Dear Marc,
reading this thread, gives me grieve.
- First end-users decide which mail front end to use, not sys admins and server admins. Therefore Server side filtering is not an option to them.
- Second how about filtering more than one account (a local, a POP and an IMAP) into one IMAP repository.
- Third how about outgoing filters, such as all outgoing e-mail from my "personality A" to "sent-from A" folder on my IMAP. The IMAP server is never going to do this as it goes strait to the SMTP server (yes I could send always a BCC, or can I in KDE? -- but how fast is this?)

I'd rather have a slow solution than no solution.

K<o>
Comment 20 Jonathan Hutchins 2005-01-14 01:24:39 UTC
I need this feature too.  Currently my mail is stored on a legacy Exchange 5.5 server on NT4, and the only way to do server side filtering is to buy a copy of XP, buy a copy of Office, and use Outlook (not express) to set the filters.

The user should be able to decide whether the traffic is too heavy when downloading, filtering, and uploading if you can't filter and move on headers.  

Please give the user the option.

As others have pointed out, this is implemented in most other IMAP capable mail clients that do filtering.  Why not Kmail too?
Comment 21 Carsten Burghardt 2005-01-14 09:21:53 UTC
> As others have pointed out, this is implemented in most other IMAP capable
> mail clients that do filtering.  Why not Kmail too?

Because our time is limited?
As there are so many people who want this I really wonder why nobody
stepped up and implemented this.
But AFAIK Don is working on this so hopefully we'll see this for kde 4.0.