Bug 406453 - Breeze dark: Mouse icon is barely visible
Summary: Breeze dark: Mouse icon is barely visible
Status: RESOLVED FIXED
Alias: None
Product: Breeze
Classification: Plasma
Component: Icons (show other bugs)
Version: 5.16.4
Platform: Archlinux Linux
: NOR normal
Target Milestone: ---
Assignee: visual-design
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-11 22:23 UTC by Patrick Silva
Modified: 2020-05-19 20:24 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.71


Attachments
screenshot (3.01 MB, image/png)
2019-04-11 22:23 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2019-04-11 22:23:26 UTC
Created attachment 119363 [details]
screenshot

SUMMARY
As we can see in attached screenshot, currently mouse icon is barely visible when breeze dark theme is used.

STEPS TO REPRODUCE
1. set breeze dark look and feel theme
2. open system settings > input devices
3. 


EXPECTED RESULT
mouse icon should have better visibility

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.15.80
KDE Frameworks Version: 5.57.0
Qt Version: 5.12.0
Comment 1 Nate Graham 2019-04-12 02:25:26 UTC
Looks like it's the same issue we had with the clock and gaming controller icons.
Comment 2 Rafael Brandmaier 2019-08-15 10:27:15 UTC
(In reply to Nate Graham from comment #1)
> Looks like it's the same issue we had with the clock and gaming controller
> icons.

I don't think that's the case here because with the icons you mentioned IIRC the problem was having a dark icon with no border, however the cursor shown here has a clear, white border to contrast with the dark environment.

However, I still see the problem as it's easy to overlook the cursor in the Breeze-dark environment. I think you might be better off using the Breeze-snow cursors, which are white with a dark border, and as such stand out more when using Breeze-dark.

Perhaps we should consider setting Breeze-snow as default in the Breeze-dark Look-and-feel (if we don't already do that).
Comment 3 Patrick Silva 2019-08-15 10:32:38 UTC
This report is about mouse icon, not mouse cursor.
Comment 4 Rafael Brandmaier 2019-08-15 11:35:28 UTC
(In reply to Patrick Silva from comment #3)
> This report is about mouse icon, not mouse cursor.

Oh, I see. Disregard my comment. This is definitely be fixable.
Comment 5 Noah Davis 2020-05-19 19:55:42 UTC
Git commit 305a7e5f31102f4aa19caf9cea3e96eb42d990fa by Noah Davis.
Committed on 19/05/2020 at 19:55.
Pushed by ndavis into branch 'master'.

Change mouse icon to have better dark theme contrast

Summary:
I'm symlinking `preferences-desktop-mouse` and `kmousetool` to `input-mouse` for now. The original mouse icons weren't very pixel aligned anyway.

Test Plan:
Before
======
`input-mouse`: {F8260460, size=full}
`preferences-desktop-mouse`: {F8260461, size=full}
`kmousetool`: {F8260462, size=full}

After
=====
`input-mouse`:
{F8260456, size=full}
{F8260457, size=full}

Reviewers: #vdg, saligari, ngraham

Reviewed By: #vdg, ngraham

Subscribers: bruns, ouwerkerk, ndavis, ngraham, kde-frameworks-devel

Tags: #frameworks

Differential Revision: https://phabricator.kde.org/D29095

T  +1    -42   icons-dark/apps/48/kmousetool.svg
M  +41   -45   icons-dark/devices/64/input-mouse.svg
T  +1    -50   icons-dark/preferences/32/preferences-desktop-mouse.svg
T  +1    -42   icons/apps/48/kmousetool.svg
M  +41   -45   icons/devices/64/input-mouse.svg
T  +1    -50   icons/preferences/32/preferences-desktop-mouse.svg

https://invent.kde.org/frameworks/breeze-icons/commit/305a7e5f31102f4aa19caf9cea3e96eb42d990fa