Bug 406280 - Don't auto select thumbnail 1 of n when first opening an album.
Summary: Don't auto select thumbnail 1 of n when first opening an album.
Status: RESOLVED DUPLICATE of bug 231528
Alias: None
Product: digikam
Classification: Unclassified
Component: Thumbs-Album (show other bugs)
Version: 6.0.0
Platform: openSUSE RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-06 16:00 UTC by Paul
Modified: 2019-07-30 21:00 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul 2019-04-06 16:00:02 UTC
SUMMARY

Currently when digikam launches thumbnail 1 of n is selected in the icon area, likewise when first selecting an album from the album tree in the left sidebar.

I know one should learn from one's mistakes, but I've lost count of the number of times I've inadvertently acted upon that auto-selected thumbnail as well as the manually selected ones I intended.

It would be better, IMHO, if no thumbnail was initially selected upon first opening an album, or when digikam first launches.  There should be some additional logic such that, in any one digikam session, if one selects one or more thumbnails and then navigates away from that album to another, upon return they are still selected.

Additionally perhaps there could be a preference setting for this, so users who like, or require the existing behaviour are not adversely affected.
Comment 1 Maik Qualmann 2019-04-06 20:51:18 UTC
The icon view already has an option for this behavior and can easily be deactivated (at compile time). I personally would not like it if the first item is not selected, because then the right sidebar will remain without information. This option should be made configurable in any case.

Maik
Comment 2 Paul 2019-04-07 07:40:01 UTC
(In reply to Maik Qualmann from comment #1)
> The icon view already has an option for this behavior and can easily be
> deactivated (at compile time). 

  OK, I wasn't aware of that.  Although of course for the average end user that's not really an option.

> I personally would not like it if the first
> item is not selected, because then the right sidebar will remain without
> information. 

  Yes, I see your reasoning there.

> This option should be made configurable in any case.

  Moving that option to the user interface would be an ideal solution.  I can only speak for myself of course, but I would very much like to not have the first item selected, for the simple reason I outlined in the first post :)


  Many thanks.
Comment 3 Maik Qualmann 2019-07-30 21:00:50 UTC

*** This bug has been marked as a duplicate of bug 231528 ***