Bug 406233 - Increase grab area on corner nodes: Hard to grab with the cursor (color adjustment curve)
Summary: Increase grab area on corner nodes: Hard to grab with the cursor (color adjus...
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Usability (show other bugs)
Version: 4.1.7
Platform: macOS (DMG) macOS
: NOR wishlist
Target Milestone: ---
Assignee: vanyossi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-04 21:52 UTC by zoltron
Modified: 2019-04-13 22:29 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Hard to catch with the cursor (169.26 KB, image/gif)
2019-04-04 21:52 UTC, zoltron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zoltron 2019-04-04 21:52:53 UTC
Created attachment 119248 [details]
Hard to catch with the cursor

STEPS TO REPRODUCE

filter -> ajust -> color adjustment curve
try the drag curve point

also there is a visual glitch when drag along edge.


SYSTEM

Macbook Pro 15" 2016 - macOs Mojave
Radeon Pro 455 2 GB
Intel HD Graphics 530 1536 MB
Comment 1 vanyossi 2019-04-08 05:06:10 UTC
Im sorry I couldn't reproduce the glich on this one.

The handle looses a bit of surface as it gets hidden under the visible area when it is at the corners. I did not find it particularly difficult to select however.

Maybe I can try to make the "hover area" stay active even if the point goes under the visible area.
Comment 2 zoltron 2019-04-08 06:39:00 UTC
(In reply to vanyossi from comment #1)
> Im sorry I couldn't reproduce the glich on this one.
> 
> The handle looses a bit of surface as it gets hidden under the visible area
> when it is at the corners. I did not find it particularly difficult to
> select however.
> 
> Maybe I can try to make the "hover area" stay active even if the point goes
> under the visible area.

Have you tried a 15 "retina screen with 1680 x 1050 resolution? Curve point active in just a few pixels.
Comment 3 zoltron 2019-04-08 06:41:52 UTC
vanyossi
it's just happening only in corners.
Comment 4 wolthera 2019-04-08 13:56:30 UTC
I couldn't reproduce either on KDE Neon on a 1980x1080 display...
Comment 5 vanyossi 2019-04-09 20:07:54 UTC
Tested on: Retina MBP 2560 x 1600, display settings set to "more space", Dialog was used with a wacom bamboo small.

The handle area in the corners is 3 pixels wide (probably), but I didn't find it challenging to grab. At least not more difficult than the rest of super small elements due to new resolution. (I normally work on "default")

No glitch on corners while dragging the node.

I will however set this bug to wish and try to come up with something (bigger select areas on points near the corners perhaps)

Thanks for your report :)
Comment 6 zoltron 2019-04-10 09:31:29 UTC
(In reply to vanyossi from comment #5)
> Tested on: Retina MBP 2560 x 1600, display settings set to "more space",
> Dialog was used with a wacom bamboo small.
> 
> The handle area in the corners is 3 pixels wide (probably), but I didn't
> find it challenging to grab. At least not more difficult than the rest of
> super small elements due to new resolution. (I normally work on "default")
> 
> No glitch on corners while dragging the node.
> 
> I will however set this bug to wish and try to come up with something
> (bigger select areas on points near the corners perhaps)
> 
> Thanks for your report :)

i think this is qt related, sometimes there are crashes related to qt, maybe related macos mojave.
Anyway thanks. goodbye.
Comment 7 Scott Petrovic 2019-04-13 22:29:58 UTC
Git commit 70ac5d1466cc286273e17186f91a13fa515c3e51 by Scott Petrovic.
Committed on 13/04/2019 at 22:29.
Pushed by scottpetrovic into branch 'master'.

M  +12   -5    libs/ui/widgets/kis_curve_widget.cpp

https://commits.kde.org/krita/70ac5d1466cc286273e17186f91a13fa515c3e51