Bug 406187 - The "Configure" window for system settings is too small.
Summary: The "Configure" window for system settings is too small.
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: 5.15.3
Platform: Neon Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 436604 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-04-03 15:35 UTC by tiger3018of02
Modified: 2021-05-05 20:24 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.22


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tiger3018of02 2019-04-03 15:35:50 UTC
SUMMARY

The "configure" window for system settings seems to be too small in Chinese simplifiled & traditional. I have tried other languages, and they are fine.

STEPS TO REPRODUCE
1. Open "System settings", click "Configure".

OBSERVED RESULT

attachment 119226 [details]

EXPECTED RESULT

attachment 119228 [details]

SOFTWARE/OS VERSIONS
Operating System: KDE neon 5.15
KDE Plasma Version: 5.15.3
KDE Frameworks Version: 5.56.0
Qt Version: 5.12.0
Kernel Version: 4.15.0-46-generic
OS Type: 64-bit
Comment 1 Nate Graham 2019-04-05 13:30:36 UTC
Is this the only window you can find on your system that exhibits this issue, or are there others?
Comment 2 tiger3018of02 2019-04-08 04:21:42 UTC
The only yet.
Comment 3 Nate Graham 2019-04-08 05:07:45 UTC
Thanks.
Comment 4 Thiago Sueto 2020-10-12 01:12:43 UTC
Can confirm on current master with Brazilian Portuguese, so this is not specific to Chinese.
This seems to be the case because the window does not adjust to localized text.
If you run LANG=C systemsettings5, the text fits the window.

E.g. in English you'd have
Icon View (9 chars)
Sidebar View (12 chars)

In pt_BR it would be
Exibição em ícones (18 chars)
Exibição em barra lateral (25 chars)

The latter is only shown as
Exibição em barra la
Comment 5 Nate Graham 2021-05-05 20:04:12 UTC
*** Bug 436604 has been marked as a duplicate of this bug. ***
Comment 6 Nate Graham 2021-05-05 20:24:22 UTC
Git commit 64dec99812ed42556dfab97ff27c1c6aab400f41 by Nate Graham.
Committed on 05/05/2021 at 20:23.
Pushed by ngraham into branch 'master'.

Set a sane default size for the settings window
FIXED-IN: 5.22

M  +3    -0    app/SettingsBase.cpp
M  +0    -8    app/configDialog.ui

https://invent.kde.org/plasma/systemsettings/commit/64dec99812ed42556dfab97ff27c1c6aab400f41