Bug 406036 - plantage au démarrage
Summary: plantage au démarrage
Status: RESOLVED NOT A BUG
Alias: None
Product: skrooge
Classification: Unclassified
Component: general (show other bugs)
Version: 2.18.0
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Stephane MANKOWSKI
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-03-30 09:38 UTC by Xavier
Modified: 2019-04-07 09:05 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
attachment-1984-0.html (1.50 KB, text/html)
2019-03-31 16:46 UTC, Xavier
Details
attachment-2732-0.html (1.69 KB, text/html)
2019-04-06 23:16 UTC, Xavier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xavier 2019-03-30 09:38:38 UTC
Application: skrooge (2.18.0)
 (Compiled from sources)
Qt Version: 5.12.1
Frameworks Version: 5.55.0
Operating System: Linux 4.19.26-1-CHAKRA x86_64
Distribution: "Chakra"

-- Information about the crash:
- What I was doing when the application crashed: I click to begin skrooge. J'ai cliqué sur Skrooge et cela a planté (distribution linux = chakra)

-- Backtrace:
Application: Skrooge (skrooge), signal: Aborted
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4bf1cf9e40 (LWP 901))]

Thread 5 (Thread 0x7f4bbfef9700 (LWP 905)):
#0  0x00007f4be964d77d in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f4bc0b9a8fb in  () at /usr/lib/dri/i965_dri.so
#2  0x00007f4bc0b9a667 in  () at /usr/lib/dri/i965_dri.so
#3  0x00007f4be9647523 in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f4beebf648f in clone () at /usr/lib/libc.so.6

Thread 4 (Thread 0x7f4bd0e7d700 (LWP 904)):
#0  0x00007f4be5915dc9 in g_mutex_lock () at /usr/lib/libglib-2.0.so.0
#1  0x00007f4be5965e55 in g_main_context_prepare () at /usr/lib/libglib-2.0.so.0
#2  0x00007f4be59664a3 in  () at /usr/lib/libglib-2.0.so.0
#3  0x00007f4be596664c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#4  0x00007f4bef50fb7b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007f4bef4b9f3b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#6  0x00007f4bef303ba6 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#7  0x00007f4bee886c05 in  () at /usr/lib/libQt5DBus.so.5
#8  0x00007f4bef304ef2 in  () at /usr/lib/libQt5Core.so.5
#9  0x00007f4be9647523 in start_thread () at /usr/lib/libpthread.so.0
#10 0x00007f4beebf648f in clone () at /usr/lib/libc.so.6

Thread 3 (Thread 0x7f4bd299a700 (LWP 903)):
#0  0x00007f4beebec00b in poll () at /usr/lib/libc.so.6
#1  0x00007f4bdcfe0922 in  () at /usr/lib/libxcb.so.1
#2  0x00007f4bdcfe2727 in xcb_wait_for_event () at /usr/lib/libxcb.so.1
#3  0x00007f4bd557e1a8 in  () at /usr/lib/libQt5XcbQpa.so.5
#4  0x00007f4bef304ef2 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007f4be9647523 in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007f4beebf648f in clone () at /usr/lib/libc.so.6

Thread 2 (Thread 0x7f4bd6720700 (LWP 902)):
#0  0x00007f4be964d77d in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f4beef704e0 in __gthread_cond_wait (__mutex=<optimized out>, __cond=<optimized out>) at /builds/packages/core/gcc/src/gcc-build/x86_64-pc-linux-gnu/libstdc++-v3/include/x86_64-pc-linux-gnu/bits/gthr-default.h:864
#2  0x00007f4beef704e0 in std::condition_variable::wait(std::unique_lock<std::mutex>&) (this=<optimized out>, __lock=...) at /builds/packages/core/gcc/src/gcc/libstdc++-v3/src/c++11/condition_variable.cc:53
#3  0x00007f4be2e33832 in  () at /usr/lib/libQt5WebKit.so.5
#4  0x00007f4be2e33949 in  () at /usr/lib/libQt5WebKit.so.5
#5  0x00007f4beef765f3 in execute_native_thread_routine (__p=0x55eeed1aed10) at /builds/packages/core/gcc/src/gcc/libstdc++-v3/src/c++11/thread.cc:80
#6  0x00007f4be9647523 in start_thread () at /usr/lib/libpthread.so.0
#7  0x00007f4beebf648f in clone () at /usr/lib/libc.so.6

Thread 1 (Thread 0x7f4bf1cf9e40 (LWP 901)):
[KCrash Handler]
#6  0x00007f4beeb35d10 in raise () at /usr/lib/libc.so.6
#7  0x00007f4beeb2099f in abort () at /usr/lib/libc.so.6
#8  0x000055eeecc7a9f9 in  ()
#9  0x00007f4bef2fbc45 in  () at /usr/lib/libQt5Core.so.5
#10 0x00007f4bef2fbff8 in  () at /usr/lib/libQt5Core.so.5
#11 0x00007f4bef2cce2e in QMessageLogger::fatal(char const*, ...) const () at /usr/lib/libQt5Core.so.5
#12 0x00007f4bef2dfb67 in  () at /usr/lib/libQt5Core.so.5
#13 0x00007f4bb4621bf8 in QSQLiteDriver::QSQLiteDriver(QObject*) () at /usr/lib/qt5/plugins/sqldrivers/libskgsqlcipher.so
#14 0x00007f4bb46206d5 in  () at /usr/lib/qt5/plugins/sqldrivers/libskgsqlcipher.so
#15 0x00007f4bea676859 in  () at /usr/lib/libQt5Sql.so.5
#16 0x00007f4bea676c51 in QSqlDatabase::addDatabase(QString const&, QString const&) () at /usr/lib/libQt5Sql.so.5
#17 0x00007f4bf1119ea4 in SKGDocument::load(QString const&, QString const&, bool, bool) () at /usr/lib/libskgbasemodeler.so.2
#18 0x00007f4bf1105279 in SKGDocument::initialize() () at /usr/lib/libskgbasemodeler.so.2
#19 0x00007f4bb4e7b968 in  () at /usr/lib/qt5/plugins/skg_file.so
#20 0x00007f4bb4e7c3f0 in  () at /usr/lib/qt5/plugins/skg_file.so
#21 0x00007f4bf16c9df7 in SKGMainPanel::processArguments(QStringList const&) () at /usr/lib/libskgbasegui.so.2
#22 0x000055eeecc7a71c in  ()
#23 0x00007f4beeb224be in __libc_start_main () at /usr/lib/libc.so.6
#24 0x000055eeecc7a82a in _start ()

Reported using DrKonqi
Comment 1 Stephane MANKOWSKI 2019-03-31 13:20:20 UTC
Hi, 

The issue seems to be due to the sqlcipher plugin.
What is you version of sqlcipher?
Comment 2 Xavier 2019-03-31 16:46:57 UTC
Created attachment 119182 [details]
attachment-1984-0.html

bonjour, 
sqlcipher 4.0.1-1 


----- Mail original -----

De: "Stephane MANKOWSKI" <bugzilla_noreply@kde.org> 
À: bxavier52@laposte.net 
Envoyé: Dimanche 31 Mars 2019 15:20:20 
Objet: [skrooge] [Bug 406036] plantage au démarrage 

https://bugs.kde.org/show_bug.cgi?id=406036 

Stephane MANKOWSKI <stephane@mankowski.fr> changed: 

What |Removed |Added 
---------------------------------------------------------------------------- 
Assignee|guillaume.debure@gmail.com |stephane@mankowski.fr 

--- Comment #1 from Stephane MANKOWSKI <stephane@mankowski.fr> --- 
Hi, 

The issue seems to be due to the sqlcipher plugin. 
What is you version of sqlcipher?
Comment 3 Scott Petrovic 2019-04-04 02:23:36 UTC
Git commit c05b3acde68f9dcc7bd2f0c5cf8b7c520cb3dc60 by Scott Petrovic.
Committed on 04/04/2019 at 02:23.
Pushed by scottpetrovic into branch 'master'.

M  +32   -36   plugins/tools/tool_transform2/kis_tool_transform.cc

https://commits.kde.org/krita/c05b3acde68f9dcc7bd2f0c5cf8b7c520cb3dc60
Comment 4 Christoph Feck 2019-04-04 06:44:49 UTC
Wrong bug number was closed; setting status correctly.
Comment 5 Stephane MANKOWSKI 2019-04-06 21:17:30 UTC
Could you build the code in DEBUG mode (see README) and generate new callstack?
Comment 6 Xavier 2019-04-06 23:16:09 UTC
Created attachment 119275 [details]
attachment-2732-0.html

hello, 
I have removed chakra and installed condres linux, no problem now. 
thanks you 

----- Mail original -----

De: "Stephane MANKOWSKI" <bugzilla_noreply@kde.org> 
À: bxavier52@laposte.net 
Envoyé: Samedi 6 Avril 2019 23:17:30 
Objet: [skrooge] [Bug 406036] plantage au démarrage 

https://bugs.kde.org/show_bug.cgi?id=406036 

Stephane MANKOWSKI <stephane@mankowski.fr> changed: 

What |Removed |Added 
---------------------------------------------------------------------------- 
Status|REPORTED |ASSIGNED 
Ever confirmed|0 |1 

--- Comment #5 from Stephane MANKOWSKI <stephane@mankowski.fr> --- 
Could you build the code in DEBUG mode (see README) and generate new callstack?