Bug 405851 - Akonadi maildir resources crashes on boot.
Summary: Akonadi maildir resources crashes on boot.
Status: RESOLVED DUPLICATE of bug 401692
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Maildir Resource (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-25 09:29 UTC by snipsnapsno
Modified: 2019-04-19 11:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description snipsnapsno 2019-03-25 09:29:08 UTC
SUMMARY
akonadi_maildir_resource (akonadi_maildir_resource) crashes at boot, most of the times.

STEPS TO REPRODUCE
1. Boot into system

OBSERVED RESULT
Crashed

EXPECTED RESULT
Doesn't crash

SOFTWARE/OS VERSIONS
Windows: none
macOS: none
Linux/KDE Plasma:  Arch linux 4.19.31-1-lts
(available in About System)
KDE Plasma Version: 5.15.3
KDE Frameworks Version: 5.56.0
Qt Version: 5.12.2

ADDITIONAL INFORMATION

Application: akonadi_maildir_resource (akonadi_maildir_resource), signal: Aborted
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f36fbe194c0 (LWP 1033))]

Thread 4 (Thread 0x7f36f365f700 (LWP 1054)):
#0  0x00007f37003b47a4 in read () from /usr/lib/libc.so.6
#1  0x00007f36fe8fe961 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f36fe94ee40 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#3  0x00007f36fe950636 in ?? () from /usr/lib/libglib-2.0.so.0
#4  0x00007f36fe95077e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0x00007f3700907cb4 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#6  0x00007f37008b0a8c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#7  0x00007f37006f4569 in QThread::exec() () from /usr/lib/libQt5Core.so.5
#8  0x00007f37017a4ba6 in ?? () from /usr/lib/libQt5DBus.so.5
#9  0x00007f37006f596c in ?? () from /usr/lib/libQt5Core.so.5
#10 0x00007f36ff42aa9d in start_thread () from /usr/lib/libpthread.so.0
#11 0x00007f37003c3b23 in clone () from /usr/lib/libc.so.6

Thread 3 (Thread 0x7f36f3e60700 (LWP 1053)):
[KCrash Handler]
#6  0x00007f37002ffd7f in raise () from /usr/lib/libc.so.6
#7  0x00007f37002ea672 in abort () from /usr/lib/libc.so.6
#8  0x00007f370052f58e in __gnu_cxx::__verbose_terminate_handler () at /build/gcc/src/gcc/libstdc++-v3/libsupc++/vterminate.cc:95
#9  0x00007f3700535dfa in __cxxabiv1::__terminate (handler=<optimized out>) at /build/gcc/src/gcc/libstdc++-v3/libsupc++/eh_terminate.cc:47
#10 0x00007f3700535e57 in std::terminate () at /build/gcc/src/gcc/libstdc++-v3/libsupc++/eh_terminate.cc:57
#11 0x00007f37006babd1 in qTerminate() () from /usr/lib/libQt5Core.so.5
#12 0x00007f37006bc6a7 in ?? () from /usr/lib/libQt5Core.so.5
#13 0x00007f36ff42aa9d in start_thread () from /usr/lib/libpthread.so.0
#14 0x00007f37003c3b23 in clone () from /usr/lib/libc.so.6

Thread 2 (Thread 0x7f36fadf8700 (LWP 1045)):
#0  0x00007f37003b8c21 in poll () from /usr/lib/libc.so.6
#1  0x00007f36ff6d3630 in ?? () from /usr/lib/libxcb.so.1
#2  0x00007f36ff6d52db in xcb_wait_for_event () from /usr/lib/libxcb.so.1
#3  0x00007f36fb9e3989 in ?? () from /usr/lib/libQt5XcbQpa.so.5
#4  0x00007f37006f596c in ?? () from /usr/lib/libQt5Core.so.5
#5  0x00007f36ff42aa9d in start_thread () from /usr/lib/libpthread.so.0
#6  0x00007f37003c3b23 in clone () from /usr/lib/libc.so.6

Thread 1 (Thread 0x7f36fbe194c0 (LWP 1033)):
#0  0x00007f370090756a in QElapsedTimer::isMonotonic() () from /usr/lib/libQt5Core.so.5
#1  0x00007f370090631f in QTimerInfoList::repairTimersIfNeeded() () from /usr/lib/libQt5Core.so.5
#2  0x00007f3700906395 in QTimerInfoList::timerWait(timespec&) () from /usr/lib/libQt5Core.so.5
#3  0x00007f37009079ff in ?? () from /usr/lib/libQt5Core.so.5
#4  0x00007f36fe94ff5a in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#5  0x00007f36fe9505b6 in ?? () from /usr/lib/libglib-2.0.so.0
#6  0x00007f36fe95077e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#7  0x00007f3700907cb4 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#8  0x00007f37008b0a8c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#9  0x00007f37008b8de6 in QCoreApplication::exec() () from /usr/lib/libQt5Core.so.5
#10 0x00007f3701cf9f6f in Akonadi::ResourceBase::init(Akonadi::ResourceBase*) () from /usr/lib/libKF5AkonadiAgentBase.so.5
#11 0x0000562317cf09e9 in ?? ()
#12 0x00007f37002ec223 in __libc_start_main () from /usr/lib/libc.so.6
#13 0x0000562317cf087e in _start ()
[Inferior 1 (process 1033) detached]
Comment 1 Daniel Vrátil 2019-03-25 10:16:50 UTC
It's an uncaught exception. Might be fixed by https://phabricator.kde.org/D19983
Comment 2 Christoph Feck 2019-04-19 11:18:01 UTC

*** This bug has been marked as a duplicate of bug 401692 ***