Bug 405373 - KInfoCenter is now following the current Click behavior
Summary: KInfoCenter is now following the current Click behavior
Status: RESOLVED FIXED
Alias: None
Product: kinfocenter
Classification: Applications
Component: general (show other bugs)
Version: 5.15.2
Platform: Neon Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: David Hubner
URL:
Keywords:
: 405499 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-03-11 23:21 UTC by thunder422
Modified: 2019-03-16 11:45 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.15.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description thunder422 2019-03-11 23:21:56 UTC
SUMMARY

When selecting each of the sections on the left, you are now required to double-click the item if you have the Click behavior set for double-click to open files and folders (single click to select).  This seems inappropriate for this program, single click does nothing and makes it look like the program doesn't work (which can confuse users).

STEPS TO REPRODUCE
1. System Settings/Workspace/Desktop Behavior/Click behavior, set for Double-click
2. Set KInfoCenter
3. Select (single-click) any section, nothing happens.
4. Double-click any section, and the section is shown.

OBSERVED RESULT
Selecting a section does nothing.

EXPECTED RESULT
The section should be shown.

SOFTWARE/OS VERSIONS
Windows: 
MacOS: 
Linux/KDE Plasma: KDE Neon 5.15 User Edition
(available in About System)
KDE Plasma Version: 5.15.2
KDE Frameworks Version: 5.55.0
Qt Version:  5.12.0

ADDITIONAL INFORMATION
Works as expected when Click behavior is set for Single-click to open files and folders.
The issue was probably introduced by Bug ID 399962.
Comment 1 Harald Sitter 2019-03-12 11:11:19 UTC
Git commit dbaf5ba7e8335f3a9c4577f137a7b1a23c6de33b by Harald Sitter.
Committed on 12/03/2019 at 11:11.
Pushed by sitter into branch 'Plasma/5.15'.

connect clicked signal of view (again)

Summary:
activated, when the system is in double click mode is only triggered
on double click. but even with in double click mode we want side panels to
trigger on single clicks. so we need both clicked and activated.

double-activation continues to be properly guarded in clickedSlot, so
this change looks to be save vis-a-vis state changes in the UI
FIXED-IN: 5.15.3
CHANGELOG: single-clicks correctly activate modules again when the system is in double-click mode

Test Plan:
single click system:
- clicking enables modules
- keyboard navigation enables modules
- double clicking has no unintended side effects

double-click system:
- same

Reviewers: mart

Reviewed By: mart

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D19703

M  +4    -0    sidepanel.cpp

https://commits.kde.org/kinfocenter/dbaf5ba7e8335f3a9c4577f137a7b1a23c6de33b
Comment 2 Kai Uwe Broulik 2019-03-16 11:45:35 UTC
*** Bug 405499 has been marked as a duplicate of this bug. ***