Bug 405336 - Color smudge brush with overlay turned on causes crash when paint in Scratchpad
Summary: Color smudge brush with overlay turned on causes crash when paint in Scratchpad
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Dockers (show other bugs)
Version: nightly build (please specify the git hash!)
Platform: Microsoft Windows Microsoft Windows
: NOR crash
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-11 05:10 UTC by nikola
Modified: 2019-03-11 10:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nikola 2019-03-11 05:10:44 UTC
STEPS TO REPRODUCE
1. make new Color Smudge brush
2. turn Overlay on 
3. paint something in Scratchpad
4. Krita freeze for second and close


SOFTWARE/OS VERSIONS
Windows: Windows 10 64bit pro


ADDITIONAL INFORMATION
Krita 4.2.0 pre-alpha d2edbba
Comment 1 Halla Rempt 2019-03-11 10:22:09 UTC
I can confirm:

ASSERT failure in KisWeakSharedPtr: "Weak pointer is not valid!", file /home/boud/dev/krita/libs/global/kis_shared_ptr.h, line 394
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = krita path = /home/boud/dev/i-krita/bin pid = 30299
KCrash: Arguments: /home/boud/dev/i-krita/bin/krita 
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi from kdeinit
sock_file=/run/user/1000/kdeinit5__0
QSocketNotifier: Invalid socket 10 and type 'Read', disabling...
QSocketNotifier: Invalid socket 23 and type 'Read', disabling...
The X11 connection broke (error 1). Did the X11 server die?
QFile::at: Cannot set file position 0
ASSERT failure in Q_GLOBAL_STATIC: "The global static was used after being destroyed", file /usr/include/x86_64-linux-gnu/qt5/QtCore/qglobalstatic.h, line 143
Unable to start Dr. Konqi
Re-raising signal for core dump handling.
Aborted (core dumped)
Comment 2 Halla Rempt 2019-03-11 10:30:16 UTC
The assert happens in

 KisSmudgeOp, line 111
 KisPainterBasedStrokeStrategy::initPainters 
 KisFreeHandStroke::initStrokeCallback, 135

It's not easy to get a proper backtrace because the crash happens when a popup is active, blocking X11.
Comment 3 Halla Rempt 2019-03-11 10:35:03 UTC
Git commit 3edf490493e02b2708e71ffb4c47ddacf696a90b by Boudewijn Rempt.
Committed on 11/03/2019 at 10:34.
Pushed by rempt into branch 'master'.

M  +1    -1    plugins/paintops/colorsmudge/kis_colorsmudgeop.cpp

https://commits.kde.org/krita/3edf490493e02b2708e71ffb4c47ddacf696a90b