Bug 405263 - Broken pseudo-graphics in Konsole on HiDPI displays after KF5 update to 5.55
Summary: Broken pseudo-graphics in Konsole on HiDPI displays after KF5 update to 5.55
Status: RESOLVED DUPLICATE of bug 402415
Alias: None
Product: konsole
Classification: Applications
Component: font (show other bugs)
Version: 18.12.2
Platform: Fedora RPMs Linux
: NOR normal
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-09 13:33 UTC by Unknown
Modified: 2019-03-10 12:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2019-03-09 13:33:09 UTC
Broken pseudo-graphics in Konsole on HiDPI displays after KF5 update to version 5.55.

STEPS TO REPRODUCE
1. Run Konsole with scale factor 1.5.
2. Start Midnight Commander in it.
3. 

OBSERVED RESULT
Broken pseudo-graphics: https://i.imgur.com/ZQ7923z.png

EXPECTED RESULT
Working pseudo-graphics.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Fedora 29
KDE Plasma Version: 5.14.5
KDE Frameworks Version: 5.55.0
Qt Version: 5.11.3
Kernel version: 4.20.13-200.fc29.x86_64


ADDITIONAL INFORMATION
Downgrading KF5 to version 5.54 resolve this issue.
Comment 1 Mariusz Glebocki 2019-03-10 12:41:29 UTC
Lines works on master with KF5 5.52, QT_SCALE_FACTOR=1.5, default Konsole configuration (intense colors in bold font turned on).

I guess downgrading KF5 downgraded Konsole, as I don't see how it could affect the lines (it was bug in Konsole itself).

Feel free to reopen and remove duplication status if this still happens on master for you.

*** This bug has been marked as a duplicate of bug 402415 ***