Bug 405230 - Recent 4.2.0 pre-alpha appimages are disabling the Layers Docker
Summary: Recent 4.2.0 pre-alpha appimages are disabling the Layers Docker
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Dockers (show other bugs)
Version: nightly build (please specify the git hash!)
Platform: Debian stable Linux
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-08 17:28 UTC by Ahab Greybeard
Modified: 2019-04-04 12:15 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ahab Greybeard 2019-03-08 17:28:56 UTC
SUMMARY

4.2.0 pre-alpha appimage (git d2edbba) and for a few days previously is deactivating the Layers docker (I forget when I first noticed it, I thought it was my own fault initially.)


STEPS TO REPRODUCE
1. Backup then delete the ~.config/kitarc file to give a fresh default configuration then run the latest 4.2.0 pre-alpha. It starts with the Default workspace and the Layers docker is showing.
2. Select any workspace (including Default) and the Layers docker is not there because it's been deactivated.
3. Reactivate the Layers docker, place as you wish then select any workspace and it is deactivated again. You can also Quit and delete the kritarc file to bring it back. If the Layers docker is active, it survives a Quit and restart but not use of the Workspace selector.

OBSERVED RESULT
As above

EXPECTED RESULT
The Layers Docker should not be deactivated like that.

SOFTWARE/OS VERSIONS
Windows: 
MacOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
This does not happen with 4.1.7 and did not happen until a few days ago with 4.2.0 pre-alpha (I forget exactly when).
I happen to have the 21st February appimage and that does not have the problem.
Comment 1 wolthera 2019-03-08 17:32:04 UTC
Yes, this is due to the layer docker being renamed in the code, and now the workspaces aren't referencing the right dockername. boud was remarking on it a few days ago, but it is always good to have a bugreport for these things.
Comment 2 Tiar 2019-03-22 16:54:23 UTC
Git commit ad1f27076d5df97326f9b07eb70bd93e75902d1b by Agata Cacko.
Committed on 22/03/2019 at 15:47.
Pushed by tymond into branch 'master'.

Fix Background Color change after flattening

Before this commit if you flatten the image using
Layer -> Flatten Image, the resulting image
had canvas background color set to transparent black.
Now the resulting image has the same canvas color
as before the flattening.

M  +1    -3    libs/image/kis_image.cc

https://commits.kde.org/krita/ad1f27076d5df97326f9b07eb70bd93e75902d1b
Comment 3 Tiar 2019-03-22 18:10:49 UTC
Looks like I closed a wrong bug :( Sorry!
Comment 4 Halla Rempt 2019-04-04 12:15:45 UTC
Fixed now.