Bug 405186 - Some Dolphin services installed from KDE Store are not available in Dolphin settings
Summary: Some Dolphin services installed from KDE Store are not available in Dolphin s...
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 20.04.2
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
: 410498 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-03-07 17:18 UTC by Patrick Silva
Modified: 2020-09-07 18:37 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot showing the error message (8.43 KB, image/jpeg)
2019-06-18 19:18 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2019-03-07 17:18:04 UTC
SUMMARY
It's impossible to use dolphin services installed from KDE Store because they are not listed in Dolphin settings.

STEPS TO REPRODUCE
1. open dolphin, "settings" menu > "Configure Dolphin..." > "Services" section
2. click "Download new services" button
3. install some service and close GHNS window

OBSERVED RESULT
The service was apparently installed correctly (it's listed when you click "Installed" radio button in GHNS window) but you can not use it because it's not listed in "Service" section of Dolphin settings.

EXPECTED RESULT
The service just installed is available in "Services" section of Dolphin settings.

SOFTWARE/OS VERSIONS
Sistema operacional: Arch Linux 
Versão do KDE Plasma: 5.15.2
Versão do KDE Frameworks: 5.55.0
Versão da Qt: 5.12.1
Comment 1 Alexander Potashev 2019-06-18 08:36:11 UTC
Individual Dolphin services may fail to install due to mistakes in their own installation scripts. Please name a few Dolphin services that don't work as expected.
Comment 2 Patrick Silva 2019-06-18 19:18:23 UTC
(In reply to Alexander Potashev from comment #1)
> Please name a few Dolphin services that don't work as
> expected.
Set as Wallpaper and Dolphin Folder Color services.
They are listed under "Installed" section of GHNS window but
they are not avaialable to selection in "Services" section of Dolphin settings.
Also I get an error message after the installation, as we can see in the attached screenshot. Tested on Neon unstable edition.

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.16.80
KDE Frameworks Version: 5.60.0
Qt Version: 5.12.3
Comment 3 Patrick Silva 2019-06-18 19:18:55 UTC
Created attachment 120984 [details]
screenshot showing the error message
Comment 4 Patrick Silva 2019-08-02 01:21:07 UTC
*** Bug 410498 has been marked as a duplicate of this bug. ***
Comment 5 Alexander Potashev 2019-08-03 20:39:28 UTC
(In reply to Patrick Silva from comment #3)
> Created attachment 120984 [details]
> screenshot showing the error message

Could be anything. Please run dolphin from shell (e.g. konsole), the kdialog notification will come in couple with a more specific error message on the command line.
Comment 6 Patrick Silva 2019-08-03 21:22:00 UTC
I get no error when I install services with Dolphin 19.08 RC on Arch Linux, but I get the
same plasma notification and the following error message in Konsole when I unsinstall a service:
"Failed to remove .desktop file 
/home/myusername/.local/share/kservices5/ServiceMenus/SetAsWallpaper.desktop: No such file or directory"
org.kde.knewstuff.core: Command failed "servicemenuinstaller uninstall /home/myusername/.local/share/servicemenu-download//SetAsWallpaper.desktop"

When I click on "Download new services..." button, I get this:

"org.kde.knewstuff.core: Using a deprecated location for the knsrc file "servicemenu.knsrc"  - please contact the author of the software which provides this file to get it updated to use the new location"

Now I can install some services (Set as Wallpaper and Rotate images, for example) and they are available in Dolphin settings. However "Dolphin folder color" service is still not available in Dolphin's settings despite it is listed in "Installed" section of GHNS window. Konsole shown no error message during the installation of "Dolphin folder color" service.

Furthermore, now I have two "Actions" entries in Dolphin's context menu when I right click
on a picture.
Comment 7 Patrick Silva 2019-08-03 21:31:14 UTC
Well, I installed and uninstalled the same services again and now plasma does not
shown an error messsage anymore.
And I noticed that uninstalled services are not immediatelly removed from "Services" section in Dolphin settings when they are uninstalled. The list of services only is updated when you reopen Dolphin settings.
Comment 8 Patrick Silva 2020-06-16 09:59:23 UTC
This bug persists.

https://bugs.kde.org/show_bug.cgi?id=420312#c14
Comment 9 Alexander Lohnau 2020-08-30 21:10:03 UTC
"Dolphin Folder Color" has an invalid install script, see the comments of https://store.kde.org/p/998453/. We should exclude this from the KDE Store.

And the SetAsWallpaper one works for me. Also a bit of work has been done on the dolphin KNS installer, please check if that improves anything :-)
Comment 10 Patrick Silva 2020-09-03 11:51:01 UTC
Tested these services on neon unstable:

Set as Wallpaper
KDE Services
KDE 5 Service Menu ReImage
getMediaInfo
Autoversion
Simple send as Attachment with Kmail
Mediainfo Service Menu

Mediainfo Service Menu and Set as Wallpaper are the only ones successfully installed, but Mediainfo Service Menu is not listed in Services section of Dolphin settings.

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.19.80
KDE Frameworks Version: 5.74.0
Qt Version: 5.14.2
Comment 11 Alexander Lohnau 2020-09-07 08:18:40 UTC
> KDE 5 Service Menu ReImage
I have contacted the author https://store.kde.org/p/1231579/.

>KDE Services
I have contacted the author and also proposed some other changes to improve the plugin https://store.kde.org/p/998464/

>getMediaInfo
The old plugin is excluded and I uploaded a working fork (Mediainfo Service Menu) and you confirmed that this one is working fine

>Autoversion
That is a KDE4 plugin and will be excluded

>Simple send as Attachment with Kmail
That is a KDE4 plugin and will be excluded
Comment 12 Alexander Lohnau 2020-09-07 08:20:32 UTC
Please note that most of the issues are caused by the plugin you want to install and KDE can't fix those. We can only ping the author about the problem or exclude it if it is unmaintained anyway.
Comment 13 Patrick Silva 2020-09-07 11:54:45 UTC
as I wrote in comment 10...

(In reply to Patrick Silva from comment #10)
> ...Mediainfo Service Menu is not listed in Services section of
> Dolphin settings.

I have even tested again.
Comment 14 Alexander Lohnau 2020-09-07 12:25:19 UTC
(In reply to Patrick Silva from comment #13)
> as I wrote in comment 10...
> 
> (In reply to Patrick Silva from comment #10)
> > ...Mediainfo Service Menu is not listed in Services section of
> > Dolphin settings.
> 
> I have even tested again.

Do you have the "mediainfo" package as in the description requested installed?
Comment 15 Patrick Silva 2020-09-07 18:37:58 UTC
(In reply to Alexander Lohnau from comment #14)
> (In reply to Patrick Silva from comment #13)
> > as I wrote in comment 10...
> > 
> > (In reply to Patrick Silva from comment #10)
> > > ...Mediainfo Service Menu is not listed in Services section of
> > > Dolphin settings.
> > 
> > I have even tested again.
> 
> Do you have the "mediainfo" package as in the description requested
> installed?

I have installed mediainfo package and reinstalled the addon. Now the addon is present in "Services" section of Dolphin settings as expected. :)