Bug 404953 - [Wayland] "Present windows" effect is not activated when icon-only task bar is used and you click on grouped windows
Summary: [Wayland] "Present windows" effect is not activated when icon-only task bar i...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: 5.21.4
Platform: Archlinux Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords: wayland
: 426904 (view as bug list)
Depends on: 397153
Blocks:
  Show dependency treegraph
 
Reported: 2019-03-01 16:47 UTC by Patrick Silva
Modified: 2021-04-12 13:42 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.22


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2019-03-01 16:47:19 UTC
STEPS TO REPRODUCE
1. start Wayland session
2. set icon-only task bar
3. open firefox and press ctrl+n to open another window (Firefox windows are grouped in the task bar)
4. click Firefox group in the task bar


OBSERVED RESULT
vertical menu shows up instead of "present windows" effect

EXPECTED RESULT
"present windows" effect is activated showing all grouped windows

SOFTWARE/OS VERSIONS
Operating System: Arch Linux 
KDE Plasma Version: 5.15.2
KDE Frameworks Version: 5.55.0
Qt Version: 5.12.1
Comment 1 David Edmundson 2019-03-01 17:01:05 UTC

*** This bug has been marked as a duplicate of bug 397153 ***
Comment 2 Nate Graham 2021-04-09 20:54:32 UTC
Apparently not a full duplicate of Bug 397153 since it's not working still. Marking it as a dependency instead.
Comment 3 Nate Graham 2021-04-09 20:55:33 UTC
*** Bug 426904 has been marked as a duplicate of this bug. ***
Comment 4 Bug Janitor Service 2021-04-12 12:58:57 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/417
Comment 5 David Redondo 2021-04-12 13:25:08 UTC
Git commit af93e38269779f34f8cc946520a0311f6f74cf78 by David Redondo.
Committed on 12/04/2021 at 12:55.
Pushed by davidre into branch 'master'.

Fix object path

GIT_SILENT

M  +1    -1    applets/taskmanager/plugin/backend.cpp

https://invent.kde.org/plasma/plasma-desktop/commit/af93e38269779f34f8cc946520a0311f6f74cf78