Bug 404836 - Can't resize weston-subsurfaces
Summary: Can't resize weston-subsurfaces
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: wayland-generic (show other bugs)
Version: 5.15.1
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-26 10:15 UTC by Vlad Zahorodnii
Modified: 2020-06-14 11:40 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
WAYLAN_DEBUG (KWin/Wayland) (181.18 KB, text/plain)
2019-02-26 13:28 UTC, Vlad Zahorodnii
Details
WAYLAND_DEBUG (weston) (808.69 KB, text/plain)
2019-02-26 13:29 UTC, Vlad Zahorodnii
Details
weston-subsurfaces appears after being closed (440.85 KB, image/png)
2019-05-21 13:18 UTC, Matej Mrenica
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vlad Zahorodnii 2019-02-26 10:15:59 UTC
STEPS TO REPRODUCE
1. Run weston-subsurfaces
2. Try to resize it.

OBSERVED RESULT
weston-subsurfaces terminates with
  shm_surface_prepare: all buffers are held by the server.

SOFTWARE/OS VERSIONS
KDE Plasma Version: 5.15.1
KDE Frameworks Version: 5.55
Qt Version: 5.12.1

ADDITIONAL INFORMATION
Can be related to the Firefox issue.
Comment 1 Vlad Zahorodnii 2019-02-26 13:28:56 UTC
Created attachment 118378 [details]
WAYLAN_DEBUG (KWin/Wayland)
Comment 2 Vlad Zahorodnii 2019-02-26 13:29:13 UTC
Created attachment 118379 [details]
WAYLAND_DEBUG (weston)
Comment 3 Matej Mrenica 2019-05-21 13:18:53 UTC
Created attachment 120220 [details]
weston-subsurfaces appears after being closed

Since this wasn't mentioned above, weston-subsurfaces window reapears after crashing, but not as a running app but just an "image" above the wallpaper.

Software:
Plasma 5.15.90
Frameworks 5.58
Qt 5.13.0 beta3
Arch Linux
Comment 4 Matej Mrenica 2020-06-14 06:49:14 UTC
This bug isn't present anymore on Plasma 5.19. Question: In the app, the cricle on green background only moving while the window is being resized is intentional?
Comment 5 David Edmundson 2020-06-14 11:40:59 UTC
>the cricle on green background only moving while the window is being resized is intentional?

That's how it behaves in weston, so I assume so.

Thanks for the update