Bug 404651 - Text in login/lock screen gets clipped at the edges of some of the individual characters
Summary: Text in login/lock screen gets clipped at the edges of some of the individual...
Status: RESOLVED WORKSFORME
Alias: None
Product: frameworks-plasma
Classification: Frameworks and Libraries
Component: components (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-21 17:28 UTC by Gianni
Modified: 2020-03-01 04:33 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.16


Attachments
screenshot of lock screen featuring cropped outlined text (283.31 KB, image/png)
2019-02-21 17:28 UTC, Gianni
Details
Same issue with shadows too (134.30 KB, image/png)
2019-02-23 03:57 UTC, Nate Graham
Details
screenshot of lock screen featuring cropped outlined text in plasma 5.16 (190.26 KB, image/png)
2019-07-03 17:57 UTC, Gianni
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gianni 2019-02-21 17:28:59 UTC
Created attachment 118255 [details]
screenshot of lock screen featuring cropped outlined text

SUMMARY
This happens when using software rendering.
The text seems to be cropped featuring an "incomplete outline". See attached image.

STEPS TO REPRODUCE
1. Set plasma renderer to software (you may have to restart the session to make it effective)
2. Lock screen 

OBSERVED RESULT
The text is oddly cropped.

EXPECTED RESULT
The text should feature a complete and clean outline.

SOFTWARE/OS VERSIONS

Linux/KDE Plasma: Manjaro Linux
KDE Plasma Version: 5.15.0
KDE Frameworks Version: 5.55.0
Qt Version: 5.12.1
Comment 1 Nate Graham 2019-02-23 03:57:45 UTC
Created attachment 118308 [details]
Same issue with shadows too

In fact I can reproduce this issue in even without the text having an outline. :(
Comment 2 Nate Graham 2019-02-23 04:05:40 UTC
Feels like it could be a Qt issue. We're not doing anything super weird with the QML. Here's the code that generates the clock test that can get clipped, for example:

Label {
    text: Qt.formatTime(timeSource.data["Local"]["DateTime"])
    style: softwareRendering ? Text.Outline : undefined
    styleColor: softwareRendering ? ColorScope.backgroundColor : undefined
    font.pointSize: 48
    Layout.alignment: Qt.AlignHCenter
}
Comment 3 Filip Fila 2019-03-09 20:10:29 UTC
Cause is the PlasmaComponents (both 2.0 and 3.0) label. If we use the QtQuickControls' label everything is fine.

See PC on the left and QQC2 on the right: https://i.imgur.com/4jbGZ6z.png
Comment 4 Nate Graham 2019-03-10 04:56:40 UTC
Is there any particular reason why we're not using the basic QQC2 label in the first place? If it's just historical because the PlasmaComponents label predated the creation of the QQC2 version, then I don't see any major issue with switching. Could be a quick win.
Comment 5 Krešimir Čohar 2019-03-16 18:01:15 UTC
Git commit d7654042677a1856daaf4cd71b1965368a44ef0e by Krešimir Čohar.
Committed on 16/03/2019 at 18:01.
Pushed by chopete into branch 'master'.

[sddm-theme/lock screen] Use QQC2 for the clock labels

Summary:
This patch replaces the PlasmaComponents labels in Clock.qml with QQC2 ones. This resolves the issue of the clock letters/numbers getting clipped.
FIXED-IN: 5.15.3

Test Plan:
Before and after
{F6680490}

Reviewers: #plasma, #vdg, filipf, ngraham, hein

Reviewed By: #plasma, #vdg, ngraham, hein

Subscribers: mart, davidedmundson, plasma-devel

Tags: #plasma

Maniphest Tasks: T10325

Differential Revision: https://phabricator.kde.org/D19647

M  +3    -2    lookandfeel/contents/components/Clock.qml

https://commits.kde.org/plasma-workspace/d7654042677a1856daaf4cd71b1965368a44ef0e
Comment 6 Krešimir Čohar 2019-03-16 18:35:24 UTC
My apologies, the fix for this will be arriving in 5.16 instead because of the QtQuickControls 2 import that would otherwise break Plasma 5.15
Comment 7 Gianni 2019-07-03 17:54:09 UTC
Today I could update to plasma 5.16 on my machine and while the patch mostly fixes the issue sadly the problem is not completely gone, as the new appended image shows.

SOFTWARE/OS VERSIONS

Linux/KDE Plasma: Manjaro Linux
KDE Plasma Version: 5.16.2
KDE Frameworks Version: 5.59.0
Qt Version: 5.12.4
Comment 8 Gianni 2019-07-03 17:57:15 UTC
Created attachment 121312 [details]
screenshot of lock screen featuring cropped outlined text in plasma 5.16

Missing outline is clearly visible at the rightmost digit '1', and slightly visible at the bottom of the letter 'g' of "luglio".
It's also visible at the top of the name "Gianni".
Comment 9 Nate Graham 2020-01-31 21:12:47 UTC
This really feels like a Qt issue.

Is anyone able to reproduce with Qt 5.13 or 5.14?
Comment 10 Bug Janitor Service 2020-02-15 04:33:19 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 11 Bug Janitor Service 2020-03-01 04:33:19 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!