Bug 404190 - Bad Visibility of checkboxes in brush settings menu
Summary: Bad Visibility of checkboxes in brush settings menu
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Usability (show other bugs)
Version: 4.1.7
Platform: Archlinux Packages Linux
: NOR minor
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-11 04:47 UTC by Derek Briggs
Modified: 2019-03-29 21:46 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of menu with low visibility checkboxes (256.64 KB, image/png)
2019-02-11 04:47 UTC, Derek Briggs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Derek Briggs 2019-02-11 04:47:29 UTC
Created attachment 117976 [details]
Screenshot of menu with low visibility checkboxes

Using the brush settings menu, I find the checkboxes very difficult to see. I was trying to add a texture to my brush, and couldn't figure out that I had to click the checkbox, because I couldn't see the checkbox. I've included a screenshot of the checkboxes I am talking about. In my opinion, these should be larger, and or the background color of the checkbox, should be a color, that contrasts the rest of the menu more than it currently does.



STEPS TO REPRODUCE
1. Open the brush settings dialog menu

SOFTWARE/OS VERSIONS
I've observed this issue in versions 4.0.4 and 4.1.7, running on Windows 7, and Arch Linux, respectively.
Comment 1 Nate Graham 2019-02-11 20:02:41 UTC
What theme are you using?
Comment 2 Derek Briggs 2019-02-11 20:08:48 UTC
(In reply to Nate Graham from comment #1)
> What theme are you using?

The default theme. It is visible in the screenshot I attached.
Comment 3 wolthera 2019-03-29 19:48:20 UTC
The default theme is Krita dark, I am not sure which widget style we use on Windows, though boud doesn't compile any.

https://phabricator.kde.org/source/krita/browse/master/krita/data/themes/KritaDark.colors
Comment 4 Scott Petrovic 2019-03-29 21:46:42 UTC
I just pushed out a couple fixes for this. It should appear in Krita 4.2, or the nightly builds if you want to check it out earlier.

This should improve the visibility for the checkboxes on the following areas:
1. Brush settings checkboxes
2. Pen sensors areas in brush editor
3. Blending mode areas (brush editor, toolbar, layers panel)