Bug 404151 - Time Format setting to en_SE results in unrecognized LC_TIME
Summary: Time Format setting to en_SE results in unrecognized LC_TIME
Status: RESOLVED DUPLICATE of bug 403580
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_formats (show other bugs)
Version: 5.14.90
Platform: Ubuntu Linux
: NOR normal
Target Milestone: ---
Assignee: Sebastian Kügler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-09 20:27 UTC by Clarence Risher
Modified: 2020-07-08 14:20 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Clarence Risher 2019-02-09 20:27:05 UTC
When I use the Formats module in System Settings to set the local Time format to en_SE this results in ~/.config/plasma-locale-settings.sh trying to set LC_TIME to en_SE.UTF-8 which is not a locale recognized by seemingly anything else. This leads to many programs spewing locale-related errors, including man and perl.

STEPS TO REPRODUCE
1. System Settings > Regional > Detailed Settings > Time > "Sweden - English (en_SE)
2. Apply
3. Log out
4. Log in
5. Open a terminal
6. `perl`
7. `man`

OBSERVED RESULT
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_US",
        LC_ALL = (unset),
        LC_MONETARY = "en_US.UTF-8",
        LC_TIME = "en_SE.UTF-8",
        LC_NUMERIC = "en_US.UTF-8",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").

man: can't set the locale; make sure $LC_* and $LANG are correct

EXPECTED RESULT
no errors

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 
KDE Plasma Version: 5.14.90
KDE Frameworks Version: 5.54.0
Qt Version: 5.11.3
Comment 1 Alexander Lohnau 2020-07-07 10:49:18 UTC
*** Bug 352030 has been marked as a duplicate of this bug. ***
Comment 2 Till Schäfer 2020-07-08 14:20:03 UTC

*** This bug has been marked as a duplicate of bug 403580 ***