Bug 403936 - Defish effect not working after adding clips
Summary: Defish effect not working after adding clips
Status: RESOLVED FIXED
Alias: None
Product: kdenlive
Classification: Unclassified
Component: Effects & Transitions (show other bugs)
Version: 19.04.0
Platform: Microsoft Windows Microsoft Windows
: NOR normal (vote)
Target Milestone: ---
Assignee: Vincent PINON
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-04 22:00 UTC by CzAndrew
Modified: 2020-07-14 16:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 20.08.0
fritzibaby: Brainstorm+
fritzibaby: timeline_corruption+


Attachments
test kdenlive project (15.82 KB, application/xml)
2019-02-26 17:38 UTC, CzAndrew
Details
kdenlive project with eng keyboard (15.78 KB, application/xml)
2019-02-26 20:30 UTC, CzAndrew
Details

Note You need to log in before you can comment on or make changes to this bug.
Description CzAndrew 2019-02-04 22:00:47 UTC
SUMMARY
The defish effect does not work after adding items to the timeline.

STEPS TO REPRODUCE
1. Create a new project, add a title clip to the project bin, then add it to the timeline.
2. Add a video clip to the project bin, then add the video to the timeline after the title clip.
3. Add defish effect to the video clip, then change the settings (in my case amount: 770, type: stereorgaphic).

OBSERVED RESULT
The defish effect is not added to the video clip on the timeline. If I turn on, and off the effect, it makes no difference.

EXPECTED RESULT
When I add the effect on the video clip, and change the values, the effect should defisheye the video. The result should be seen in the preview window.
If I just add only the video to the timeline, then the effect works.

SOFTWARE/OS VERSIONS
Windows: Win10
MacOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
Comment 1 emohr 2019-02-14 18:55:49 UTC
Tested on Linux and Windows according your steps. Video just behind the title clip. Defish works as expected with stereographic and other settings changed as well. 

Move a bit the playhead on the video to see if it works.
Comment 2 CzAndrew 2019-02-21 21:28:43 UTC
For me it is still not working. I tried on two different computers.

I uploaded a screenrec here, where I demonstrate it:
https://youtu.be/PEj6p4IlD7k
Comment 3 emohr 2019-02-23 13:14:39 UTC
I tested it with a title clip in front as you have done: defish works. 

In the “second” part of your video you add the clip only and there I see defish is working. 

Do you have installed Kdenlive via the exe-file?
Do you had an older version before installed? 
Check if the installation is OK: settings -> Run Config Wizard.
Comment 4 CzAndrew 2019-02-24 10:19:04 UTC
The second part of the video is a semonstration that if I add only the video then I add the defish effect, then it is working.
If I would add more videoclips, the defish effect would work.

BUT if I add the title clip first, then I add the video, it is not working.

It is very frustrationg when I add many videoclips, add the defish effect, then if I add title clips, the defish effect stops working on all the videos.

Workaround: 
1) create a new project, add only the videoclips + defish effect, then add the whole project to the library, then use the library item.
2) Use ffmpeg to create defished videos, then use those video clips in kdenlive
Comment 5 CzAndrew 2019-02-24 10:25:31 UTC
I used many kinds of kdenlive, and it is broken on all versions. I started to use kdenlive from version 17.12. The video-demonstration on youtube was made in 18.12.
When I switch from one version to another, I delete the config file in "c:\Users\_____\AppData\Local\", and kdenlive will generate it.
Currently I'm using the 18.12 version, and I had to install it with an installer. As I know, it is the only way to install it. (However, I would prefer to have the portable versions.)
If you would like to, I'll upload the program folders with my preferences files, then you can check them on your computer.
Comment 6 emohr 2019-02-24 10:46:58 UTC
Before uploading the file please do the following: 
- goto AppData\Local\ and delete the “kdenliverc” and the “kdeglobals” (if that file exist). 
- Then delete the AppData\Local\"Kdenlive" folder. If you have any saved effects or clips stored in your library, make a backup of the library folder.

There is something left over from an old installation.
Comment 7 CzAndrew 2019-02-24 22:49:32 UTC
Tried that... defish still not working.
Comment 8 emohr 2019-02-25 16:23:21 UTC
OK. Please upload here under comments your Kdenlive file with the title clip in front.
Comment 9 emohr 2019-02-25 16:24:27 UTC
Sorry, I meant with "add an attachment".
Comment 10 CzAndrew 2019-02-26 17:38:32 UTC
Created attachment 118385 [details]
test kdenlive project

This is a test file which contains the title clip and then the video file with the defish effect which has no effect on the video clip.
Comment 11 emohr 2019-02-26 20:14:33 UTC
Thank you for uploading the file. 

There is a type-/characterset conflict with “comma” where a “point” is expected. 

As soon as you have a title-clip and you type some text this happen. This is why clip only work. 

Can you test the following: change your keyboard language to English and test again. 

I open issue https://invent.kde.org/kde/kdenlive/issues/78
Comment 12 CzAndrew 2019-02-26 20:30:48 UTC
Created attachment 118388 [details]
kdenlive project with eng keyboard

The kdenlive project which was made with english keyboard settings has been attached!
Result: The defish effect still not working.
(First I closed kdenlive completely with unlocker because dbus-daemon.exe process was still open from the last start. Changed the keyboard from hungarian to english. Started kdenlive 18.12.1, added title, clip, effect...)
Comment 13 emohr 2019-03-03 18:51:59 UTC
Oh, my mistake. You have to change your language setting to English. Bottom right the icon “HU”. The uploaded file is still “LC_NUMERIC="hu_HU"”.
Comment 14 CzAndrew 2019-03-05 18:30:47 UTC
I guess you mean the language of the keyboard. I did that when I created the second kdenlive project: bottom right corner of the screen, on the taskbar I changed "HUN" to "ENG. In the title clip editor the keyboard was english.
However, I'll try to change the localization settings to US, and I'll create a kdenlive project that way.
Comment 15 CzAndrew 2019-03-08 17:38:26 UTC
I played with the settings little bit more, and here is what I found out:
The Region settings have to be changed in order to have the defish effect working (and not the keyboard). I guess the problem is that in some regions the decimal symbol is not "." but "," and that is the source of the problem. In Microsoft Windows 10 the region settings can be found in: Settings -> Time & Language -> Additional date, time, & regional settings -> Region -> Change location -> Formats tab -> Format.
In my case the region was set to Hungarian, and that was causing the problem. After I changed that to English (United States), the applied defish effect was working again (when I added the defish with "English (United States) region settings")! So, if I saved a project with for example Hungarian region settings, and open the project with US region settings, the defish effect was not working.
The region should be changed to US before the defish effect applied. So, if you set the region to US, then open a project, add title and videos, change the region back to Hungarian (or other region where the decimal symbol is not . but ,), and add the defish effect, then the effect will not work. So if you would think that "I will create an empty kdenlive project with US region settings, and use that to create new project when my region settings is set to my home country" will not work.
I hope this problem will be resolved soon.
Comment 16 emohr 2019-03-08 18:55:20 UTC
Thank you very much for this in detail explanation. I added your solution/workaround in the issue#78. It’s a general issue not only in the Windows version.
Comment 17 emohr 2020-07-14 16:47:03 UTC
Comma point issue is fixed with upcoming version 20.08.0.