Bug 403757 - Changing mail signature script cause korganizer to crash (akonadi?)
Summary: Changing mail signature script cause korganizer to crash (akonadi?)
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-01-30 07:16 UTC by Bruno Friedmann
Modified: 2019-08-19 16:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Friedmann 2019-01-30 07:16:28 UTC
Application: korganizer (5.10.1)

Qt Version: 5.12.0
Frameworks Version: 5.54.0
Operating System: Linux 4.20.2-1-default x86_64
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
- What I was doing when the application crashed: I was modifying one identities under kmail2 (changing the location of my signature script) once I click on apply, korganiser crashed immediately

-- Backtrace:
Application: KOrganizer (korganizer), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f984da01000 (LWP 7764))]

Thread 5 (Thread 0x7f983bfff700 (LWP 7770)):
#0  0x00007f98548c92c9 in __GI___poll (fds=0x7f9834003ce0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f98514bbfb6 in g_main_context_poll (priority=<optimized out>, n_fds=1, fds=0x7f9834003ce0, timeout=<optimized out>, context=0x7f9834000bf0) at gmain.c:4221
#2  g_main_context_iterate (context=context@entry=0x7f9834000bf0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3915
#3  0x00007f98514bc0dc in g_main_context_iteration (context=0x7f9834000bf0, may_block=may_block@entry=1) at gmain.c:3981
#4  0x00007f985501388b in QEventDispatcherGlib::processEvents (this=0x7f9834000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f9854fbe02b in QEventLoop::exec (this=this@entry=0x7f983bffec60, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#6  0x00007f9854e083b6 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#7  0x00007f9854e09702 in QThreadPrivate::start (arg=0x55da7ee304a0) at thread/qthread_unix.cpp:361
#8  0x00007f98526f3554 in start_thread (arg=<optimized out>) at pthread_create.c:463
#9  0x00007f98548d3ccf in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f98488ff700 (LWP 7767)):
#0  0x00007f98548c92c9 in __GI___poll (fds=0x7f9840006ba0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f98514bbfb6 in g_main_context_poll (priority=<optimized out>, n_fds=1, fds=0x7f9840006ba0, timeout=<optimized out>, context=0x7f9840000bf0) at gmain.c:4221
#2  g_main_context_iterate (context=context@entry=0x7f9840000bf0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3915
#3  0x00007f98514bc0dc in g_main_context_iteration (context=0x7f9840000bf0, may_block=may_block@entry=1) at gmain.c:3981
#4  0x00007f985501388b in QEventDispatcherGlib::processEvents (this=0x7f9840000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f9854fbe02b in QEventLoop::exec (this=this@entry=0x7f98488fec60, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#6  0x00007f9854e083b6 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#7  0x00007f9854e09702 in QThreadPrivate::start (arg=0x55da7ed6ed00) at thread/qthread_unix.cpp:361
#8  0x00007f98526f3554 in start_thread (arg=<optimized out>) at pthread_create.c:463
#9  0x00007f98548d3ccf in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f9849b10700 (LWP 7766)):
#0  0x00007f98548c92c9 in __GI___poll (fds=0x7f983c021c70, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f98514bbfb6 in g_main_context_poll (priority=<optimized out>, n_fds=1, fds=0x7f983c021c70, timeout=<optimized out>, context=0x7f983c000bf0) at gmain.c:4221
#2  g_main_context_iterate (context=context@entry=0x7f983c000bf0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3915
#3  0x00007f98514bc0dc in g_main_context_iteration (context=0x7f983c000bf0, may_block=may_block@entry=1) at gmain.c:3981
#4  0x00007f985501388b in QEventDispatcherGlib::processEvents (this=0x7f983c000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f9854fbe02b in QEventLoop::exec (this=this@entry=0x7f9849b0fc30, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#6  0x00007f9854e083b6 in QThread::exec (this=this@entry=0x7f98545b5d80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#7  0x00007f985453b565 in QDBusConnectionManager::run (this=0x7f98545b5d80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:178
#8  0x00007f9854e09702 in QThreadPrivate::start (arg=0x7f98545b5d80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:361
#9  0x00007f98526f3554 in start_thread (arg=<optimized out>) at pthread_create.c:463
#10 0x00007f98548d3ccf in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f984b142700 (LWP 7765)):
#0  0x00007f98548c92c9 in __GI___poll (fds=fds@entry=0x7f984b141b78, nfds=nfds@entry=1, timeout=timeout@entry=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f985144bcc7 in poll (__timeout=-1, __nfds=1, __fds=0x7f984b141b78) at /usr/include/bits/poll2.h:46
#2  _xcb_conn_wait (c=c@entry=0x55da7ecd4690, cond=cond@entry=0x55da7ecd46d0, vector=vector@entry=0x0, count=count@entry=0x0) at xcb_conn.c:479
#3  0x00007f985144d8ea in xcb_wait_for_event (c=c@entry=0x55da7ecd4690) at xcb_in.c:697
#4  0x00007f984bd335da in QXcbEventQueue::run (this=0x55da7ed11f20) at qxcbeventqueue.cpp:225
#5  0x00007f9854e09702 in QThreadPrivate::start (arg=0x55da7ed11f20) at thread/qthread_unix.cpp:361
#6  0x00007f98526f3554 in start_thread (arg=<optimized out>) at pthread_create.c:463
#7  0x00007f98548d3ccf in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f984da01000 (LWP 7764)):
[KCrash Handler]
#6  0x00007f9854296883 in QVector<QSharedPointer<Node> >::indexOf (this=<optimized out>, t=..., from=from@entry=0) at /usr/include/qt5/QtCore/qvector.h:900
#7  0x00007f9854291e39 in IncidenceTreeModel::Private::indexForNode (this=0x55da7f2080e0, node=...) at /usr/include/qt5/QtCore/qsharedpointer_impl.h:309
#8  0x00007f985429479d in IncidenceTreeModel::parent (this=this@entry=0x55da7f209330, child=...) at /usr/src/debug/eventviews-18.12.1-1.1.x86_64/src/todo/incidencetreemodel.cpp:826
#9  0x00007f985428c833 in TodoModel::parent (this=0x55da7ee8e540, child=...) at /usr/src/debug/eventviews-18.12.1-1.1.x86_64/src/todo/todomodel.cpp:913
#10 0x00007f9854f9a974 in QModelIndex::parent (this=0x7ffe692632d0) at ../../include/QtCore/../../src/corelib/tools/qlist.h:571
#11 QSortFilterProxyModelPrivate::update_persistent_indexes (this=0x55da7f1dda80, source_indexes=...) at itemmodels/qsortfilterproxymodel.cpp:1223
#12 0x00007f9854f9b170 in QSortFilterProxyModelPrivate::_q_sourceLayoutChanged (this=0x55da7f1dda80, sourceParents=..., hint=<optimized out>) at itemmodels/qsortfilterproxymodel.cpp:1594
#13 0x00007f9854f9ff05 in QSortFilterProxyModel::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1038
#14 0x00007f9854fe90ab in QMetaObject::activate (sender=0x55da7ee8e540, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3778
#15 0x00007f9854f71c26 in QAbstractItemModel::layoutChanged (this=<optimized out>, _t1=..., _t2=<optimized out>, _t2@entry=QAbstractItemModel::NoLayoutChangeHint) at .moc/moc_qabstractitemmodel.cpp:570
#16 0x00007f985428e7fd in TodoModel::Private::onLayoutChanged (this=0x55da7f04f1d0) at /usr/include/qt5/QtCore/qlist.h:151
#17 0x00007f9854fe90ab in QMetaObject::activate (sender=0x55da7f209330, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3778
#18 0x00007f9854f71c26 in QAbstractItemModel::layoutChanged (this=<optimized out>, _t1=..., _t2=<optimized out>, _t2@entry=QAbstractItemModel::NoLayoutChangeHint) at .moc/moc_qabstractitemmodel.cpp:570
#19 0x00007f98542946df in IncidenceTreeModel::Private::onLayoutChanged (this=<optimized out>) at /usr/include/qt5/QtCore/qlist.h:151
#20 0x00007f9854fe9200 in QtPrivate::QSlotObjectBase::call (a=0x7ffe69263880, r=0x55da7f2080e0, this=0x55da7f15e1b0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#21 QMetaObject::activate (sender=0x55da7eeb9450, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3759
#22 0x00007f9854f71c26 in QAbstractItemModel::layoutChanged (this=this@entry=0x55da7eeb9450, _t1=..., _t2=<optimized out>, _t2@entry=QAbstractItemModel::NoLayoutChangeHint) at .moc/moc_qabstractitemmodel.cpp:570
#23 0x00007f9854f9b1aa in QSortFilterProxyModelPrivate::_q_sourceLayoutChanged (this=0x55da7eebc9a0, sourceParents=..., hint=<optimized out>) at itemmodels/qsortfilterproxymodel.cpp:1603
#24 0x00007f9854f9ff05 in QSortFilterProxyModel::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1038
#25 0x00007f9854fe90ab in QMetaObject::activate (sender=0x55da7ee83000, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3778
#26 0x00007f9854f71c26 in QAbstractItemModel::layoutChanged (this=this@entry=0x55da7ee83000, _t1=..., _t2=<optimized out>, _t2@entry=QAbstractItemModel::NoLayoutChangeHint) at .moc/moc_qabstractitemmodel.cpp:570
#27 0x00007f9854f9ae36 in QSortFilterProxyModel::invalidate (this=0x55da7ee83000) at ../../include/QtCore/../../src/corelib/tools/qlist.h:151
#28 0x00007f9854fe9200 in QtPrivate::QSlotObjectBase::call (a=0x7ffe69263bd0, r=0x55da7ee83000, this=0x55da7ee62410) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#29 QMetaObject::activate (sender=0x7f9853a78a70 <KIdentityManagement::(anonymous namespace)::Q_QGS_s_self::innerFunction()::holder>, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3759
#30 0x00007f9853a62730 in KIdentityManagement::IdentityManager::Private::slotIdentitiesChanged (this=0x55da7edccc60, id=...) at /usr/src/debug/kidentitymanagement-18.12.1-1.1.x86_64/src/identitymanager.cpp:281
#31 0x00007f9853a64363 in KIdentityManagement::IdentityManager::qt_metacall (this=0x7f9853a78a70 <KIdentityManagement::(anonymous namespace)::Q_QGS_s_self::innerFunction()::holder>, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0x7ffe69263dc0) at /usr/src/debug/kidentitymanagement-18.12.1-1.1.x86_64/build/src/KF5IdentityManagement_autogen/include/moc_identitymanager.cpp:188
#32 0x00007f9854546eca in QDBusConnectionPrivate::deliverCall (this=<optimized out>, object=<optimized out>, msg=..., metaTypes=..., slotIdx=<optimized out>) at qdbusintegrator.cpp:991
#33 0x00007f9854fe9962 in QObject::event (this=0x7f9853a78a70 <KIdentityManagement::(anonymous namespace)::Q_QGS_s_self::innerFunction()::holder>, e=<optimized out>) at kernel/qobject.cpp:1249
#34 0x00007f9855a17591 in QApplicationPrivate::notify_helper (this=this@entry=0x55da7ecbe160, receiver=receiver@entry=0x7f9853a78a70 <KIdentityManagement::(anonymous namespace)::Q_QGS_s_self::innerFunction()::holder>, e=e@entry=0x7f983c02f8a0) at kernel/qapplication.cpp:3753
#35 0x00007f9855a1eb50 in QApplication::notify (this=0x7ffe692644e0, receiver=0x7f9853a78a70 <KIdentityManagement::(anonymous namespace)::Q_QGS_s_self::innerFunction()::holder>, e=0x7f983c02f8a0) at kernel/qapplication.cpp:3500
#36 0x00007f9854fbf359 in QCoreApplication::notifyInternal2 (receiver=0x7f9853a78a70 <KIdentityManagement::(anonymous namespace)::Q_QGS_s_self::innerFunction()::holder>, event=0x7f983c02f8a0) at ../../include/QtCore/5.12.0/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:322
#37 0x00007f9854fc2357 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x55da7eca24d0) at kernel/qcoreapplication.cpp:1800
#38 0x00007f9855014263 in postEventSourceDispatch (s=0x55da7edacb30) at kernel/qeventdispatcher_glib.cpp:276
#39 0x00007f98514bbc85 in g_main_dispatch (context=0x7f9844004ff0) at gmain.c:3182
#40 g_main_context_dispatch (context=context@entry=0x7f9844004ff0) at gmain.c:3847
#41 0x00007f98514bc048 in g_main_context_iterate (context=context@entry=0x7f9844004ff0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3920
#42 0x00007f98514bc0dc in g_main_context_iteration (context=0x7f9844004ff0, may_block=may_block@entry=1) at gmain.c:3981
#43 0x00007f9855013873 in QEventDispatcherGlib::processEvents (this=0x55da7edb7920, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#44 0x00007f9854fbe02b in QEventLoop::exec (this=this@entry=0x7ffe69264400, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#45 0x00007f9854fc6192 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#46 0x000055da7d00f171 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/korganizer-18.12.1-1.1.x86_64/src/main.cpp:64
[Inferior 1 (process 7764) detached]

Reported using DrKonqi
Comment 1 Laurent Montel 2019-08-13 11:27:06 UTC
I can't reproduce it in last version.
Can you test a new version please ?
Comment 2 Bruno Friedmann 2019-08-19 16:04:20 UTC
Hi Laurent, with newer version there's no more crashes

openSUSE Tumbleweed
Linux 5.2.8-1-default x86_64 GNU/Linux, nvidia: 430.34
Qt: 5.13.0, KDE Frameworks: 5.60.0, Plasma: 5.16.4, kmail2 5.11.3