Bug 403701 - Plasma or Kscreen KCM crash in KScreen::GetConfigOperation::start() on login with external monitor connected
Summary: Plasma or Kscreen KCM crash in KScreen::GetConfigOperation::start() on login ...
Status: RESOLVED FIXED
Alias: None
Product: KScreen
Classification: Unclassified
Component: common (show other bugs)
Version: 5.16.0
Platform: unspecified Linux
: HI crash
Target Milestone: ---
Assignee: Sebastian Kügler
URL:
Keywords: drkonqi
: 386914 408757 417705 418241 418310 418539 419143 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-01-28 18:01 UTC by Alexander Mentyu
Modified: 2022-04-27 19:45 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
attachment-26400-0.html (1.34 KB, text/html)
2022-04-27 19:45 UTC, Philip
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Mentyu 2019-01-28 18:01:35 UTC
Application: kcmshell5 (5.15.80)

Qt Version: 5.11.2
Frameworks Version: 5.54.0
Operating System: Linux 4.15.0-42-generic x86_64
Distribution: KDE neon Developer Edition

-- Information about the crash:
- What I was doing when the application crashed:
Started system with ext monitor connected and tried to launch Displays KCM, previously there ware log outs/ins with configuring displays in the KCM

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings Module (kcmshell5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f3cfd6aa380 (LWP 12583))]

Thread 2 (Thread 0x7f3ce1a14700 (LWP 12585)):
#0  0x00007ffe21d80aa3 in clock_gettime ()
#1  0x00007f3cfd006ea6 in __GI___clock_gettime (clock_id=clock_id@entry=1, tp=tp@entry=0x7f3ce1a13aa0) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007f3cf9fdcff1 in qt_clock_gettime (ts=0x7f3ce1a13aa0, clock=<optimized out>) at kernel/qelapsedtimer_unix.cpp:111
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at kernel/qelapsedtimer_unix.cpp:166
#4  qt_gettime () at kernel/qelapsedtimer_unix.cpp:175
#5  0x00007f3cf9fdb829 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f3cdc004cf0) at kernel/qtimerinfo_unix.cpp:91
#6  0x00007f3cf9fdbe05 in QTimerInfoList::timerWait (this=0x7f3cdc004cf0, tm=...) at kernel/qtimerinfo_unix.cpp:388
#7  0x00007f3cf9fdd44e in timerSourcePrepareHelper (timeout=0x7f3ce1a13b64, src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:132
#8  timerSourcePrepare (source=<optimized out>, timeout=0x7f3ce1a13b64) at kernel/qeventdispatcher_glib.cpp:165
#9  0x00007f3cf3d6fa98 in g_main_context_prepare () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f3cf3d7046b in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f3cf3d7064c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f3cf9fdd6eb in QEventDispatcherGlib::processEvents (this=0x7f3cdc000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#13 0x00007f3cf9f819aa in QEventLoop::exec (this=this@entry=0x7f3ce1a13d30, flags=..., flags@entry=...) at kernel/qeventloop.cpp:214
#14 0x00007f3cf9dad25a in QThread::exec (this=this@entry=0x7f3cfbb31d60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:525
#15 0x00007f3cfb8b9e45 in QDBusConnectionManager::run (this=0x7f3cfbb31d60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:178
#16 0x00007f3cf9db817b in QThreadPrivate::start (arg=0x7f3cfbb31d60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:367
#17 0x00007f3cf68046db in start_thread (arg=0x7f3ce1a14700) at pthread_create.c:463
#18 0x00007f3cfcff788f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f3cfd6aa380 (LWP 12583)):
[KCrash Handler]
#5  KScreen::GetConfigOperation::start (this=0x5640990d2130) at ./src/getconfigoperation.cpp:174
#6  0x00007f3cf9fb3282 in QObject::event (this=0x5640990d2130, e=<optimized out>) at kernel/qobject.cpp:1251
#7  0x00007f3cfad10e1c in QApplicationPrivate::notify_helper (this=this@entry=0x564098fe0620, receiver=receiver@entry=0x5640990d2130, e=e@entry=0x7f3ce40066e0) at kernel/qapplication.cpp:3727
#8  0x00007f3cfad183ef in QApplication::notify (this=0x7ffe21d42f00, receiver=0x5640990d2130, e=0x7f3ce40066e0) at kernel/qapplication.cpp:3486
#9  0x00007f3cf9f83688 in QCoreApplication::notifyInternal2 (receiver=0x5640990d2130, event=event@entry=0x7f3ce40066e0) at kernel/qcoreapplication.cpp:1048
#10 0x00007f3cf9f861cd in QCoreApplication::sendEvent (event=0x7f3ce40066e0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#11 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x564098fd7210) at kernel/qcoreapplication.cpp:1745
#12 0x00007f3cf9f86788 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1599
#13 0x00007f3cf9fde093 in postEventSourceDispatch (s=0x564099037190) at kernel/qeventdispatcher_glib.cpp:276
#14 0x00007f3cf3d70387 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#15 0x00007f3cf3d705c0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#16 0x00007f3cf3d7064c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#17 0x00007f3cf9fdd6cf in QEventDispatcherGlib::processEvents (this=0x56409902f4e0, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#18 0x00007f3cec88c761 in QPAEventDispatcherGlib::processEvents (this=0x56409902f4e0, flags=...) at qeventdispatcher_glib.cpp:69
#19 0x00007f3cf9f819aa in QEventLoop::exec (this=this@entry=0x7ffe21d42dd0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:214
#20 0x00007f3cf9f8ab70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1336
#21 0x00007f3cfa50a9cc in QGuiApplication::exec () at kernel/qguiapplication.cpp:1762
#22 0x00007f3cfad10d75 in QApplication::exec () at kernel/qapplication.cpp:2901
#23 0x00007f3cfd2d01b4 in kdemain (_argc=<optimized out>, _argv=<optimized out>) at ./kcmshell/main.cpp:328
#24 0x00007f3cfcef7b97 in __libc_start_main (main=0x564097a7c720 <main>, argc=2, argv=0x7ffe21d43058, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffe21d43048) at ../csu/libc-start.c:310
#25 0x0000564097a7c75a in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2019-07-03 14:39:55 UTC
*** Bug 408757 has been marked as a duplicate of this bug. ***
Comment 2 Nate Graham 2021-02-23 20:47:38 UTC
*** Bug 417705 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2021-02-23 21:00:38 UTC
*** Bug 418310 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2021-02-23 21:00:44 UTC
*** Bug 386914 has been marked as a duplicate of this bug. ***
Comment 5 Nate Graham 2021-02-23 21:00:50 UTC
*** Bug 418539 has been marked as a duplicate of this bug. ***
Comment 6 Nate Graham 2021-02-23 21:01:09 UTC
*** Bug 419143 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2021-02-23 21:01:17 UTC
*** Bug 418241 has been marked as a duplicate of this bug. ***
Comment 8 Nate Graham 2022-04-27 03:57:34 UTC
All reports are from Plasma 5.18 or earlier. I think it's safe to say this has been long since fixed.
Comment 9 Philip 2022-04-27 19:45:55 UTC
Created attachment 148419 [details]
attachment-26400-0.html

Very good,

Thanks
Philip

On Wed, 27 Apr 2022, 04:57 Nate Graham, <bugzilla_noreply@kde.org> wrote:

> https://bugs.kde.org/show_bug.cgi?id=403701
>
> Nate Graham <nate@kde.org> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>          Resolution|---                         |FIXED
>              Status|CONFIRMED                   |RESOLVED
>
> --- Comment #8 from Nate Graham <nate@kde.org> ---
> All reports are from Plasma 5.18 or earlier. I think it's safe to say this
> has
> been long since fixed.
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.