Bug 403650 - Effect Compressor (avfilter) explodes when attributes changed
Summary: Effect Compressor (avfilter) explodes when attributes changed
Status: RESOLVED FIXED
Alias: None
Product: kdenlive
Classification: Unclassified
Component: Effects & Transitions (show other bugs)
Version: 18.12.1
Platform: Appimage Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Vincent PINON
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-27 10:00 UTC by Dominik Leiner
Modified: 2020-07-14 16:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 20.8.0
fritzibaby: Brainstorm+
fritzibaby: timeline_corruption+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominik Leiner 2019-01-27 10:00:20 UTC
SUMMARY

The effect "Compressor (avfilter)" works correctly when added to a clip. However, when any value is changed (and changed back to the previous value), the audio exceed the 0db limits by far (massive overmodulation). May be related to German interface (using comma as decimal separator).


STEPS TO REPRODUCE
1. Add video to timeline
2. Add effect "Compressor (avfilter)"
3. Play video -> everything works correctly, filter s active
4. Change any setting (incl. Detection or Mix) and change to previous setting
5. Play video -> Clip plays much too loud an heavily distored

EXPECTED RESULT

Same effect of the effect if the same settings are set.


SOFTWARE/OS VERSIONS
Windows: 
MacOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
Comment 1 emohr 2019-01-28 17:17:31 UTC
Tested with the AppImage 18.12.1b in a Virtual Machine on Win7. I cannot reproduce it when setting back the value to default (middle mouse click). Only when I move the gain to, let’s say 3 then the distortion begins. 

This must be a LADSPA effect as this effect is not on the Windows version available. 

I have point and not comma as decimal. Does all effect as commas? 

I saw such issue with effects under the Kdenlive Windows version. 

Change the keyboard to English and the decimal separator to point and try again.
Comment 2 emohr 2020-07-14 16:51:54 UTC
Comma point issue is fixed with version 20.08.0.