Bug 403570 - Dark border around the Screen Edge effect
Summary: Dark border around the Screen Edge effect
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: 5.14.90
Platform: Other Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Vlad Zahorodnii
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-24 20:54 UTC by Viorel-Cătălin Răpițeanu
Modified: 2019-02-07 14:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.15.1


Attachments
black-blue kwin hint effect (3.21 KB, image/png)
2019-01-24 20:54 UTC, Viorel-Cătălin Răpițeanu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Viorel-Cătălin Răpițeanu 2019-01-24 20:54:57 UTC
Created attachment 117646 [details]
black-blue kwin hint effect

SUMMARY
The KWin hint border shadow has a black-blue shadow, even if the file that is responsible for this is blue-to-transparent: glowbar.svgz 

STEPS TO REPRODUCE
1. Open an application that has a white background and maximize it
2. Add an empty plasma panel that auto hides
3. Let the panel to hide itself
4. Approach to then panel edge without touching the edge but until the point to show the Edge hint

OBSERVED RESULT
1. The Edge hint should be transparent-to-blue and not black-to-blue


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 5.14.90
KDE Plasma Version: 5.14.90
KDE Frameworks Version: 5.54.0
Qt Version: 5.12.0-3
Comment 1 Vlad Zahorodnii 2019-02-07 00:12:41 UTC
Git commit bdddf4daf2d810630e1527798384188e001c80ce by Vlad Zagorodniy.
Committed on 07/02/2019 at 00:10.
Pushed by vladz into branch 'Plasma/5.15'.

[effects/screenedge] Use correct blend function

Summary:
Glow textures already have the red, green, and blue channels
premultiplied by the alpha component (because of QImage), thus we can't
use GL_SRC_ALPHA for sfactor in glBlendFunc.

Test Plan:
Before:
{F6592391}

After:
{F6592392}

Reviewers: #kwin, davidedmundson

Reviewed By: #kwin, davidedmundson

Subscribers: kwin

Tags: #kwin

Differential Revision: https://phabricator.kde.org/D18803

M  +1    -1    effects/screenedge/screenedgeeffect.cpp

https://commits.kde.org/kwin/bdddf4daf2d810630e1527798384188e001c80ce